Calculate Forum

Прилетело обновление с даунгрейдом пакетов libva

После вчерашнего обновления и постоянной кривизны моих рук была проблема с обновленией libva. Решил удалить и установить снова. Итог: http://pastebin.calculate-linux.org/en/show/129496
Так понимаю что требует X-ы для установки но не находит их.

checking for X11… no
configure: error: VA/X11 explicitly enabled, however No package ‘x11’ found
No package ‘xext’ found
No package ‘xfixes’ found

Печали не было ровно до вчерашнего дня. Кто опытный что делать? переустановку или можно отремонтировать? Спасибо.

x11-base/xorg-server какой версии установлен?
у меня так mesa не смогла обновиться вчера. Повторил cl-update и пошло.

1.20.5 версия. Дык вот вчера с обновления как залипло.

Пробовал cl-update повторить?

Да. Много раз. Упирается в невозможность установить libva и колом стоит.

Можно попробовать

cl-update --scan -veo -R off --sync-only
cl-setup-system -v
cl-update --scan -veo -R off

Спасибо. Попробую. Отпишусь.

Увы. Опять стопорится libva пакете.

checking for X11… no
configure: error: VA/X11 explicitly enabled, however No package ‘x11’ found
No package ‘xext’ found
No package ‘xfixes’ found

  • Установка dev-python/requests-2.22.0 [2.21.0-r1] … [ ok ]
    No package ‘xext’ found
    No package ‘xfixes’ found

!!! Please attach the following file when seeking support:
!!! /var/calculate/tmp/portage/x11-libs/libva-2.5.0-r1/work/libva-2.5.0-abi_x86_32.x86/config.log

  • ERROR: x11-libs/libva-2.5.0-r1::gentoo failed (configure phase):
  • econf failed
  • Call stack:
  •           ebuild.sh, line  125:  Called src_configure
    
  •         environment, line 1693:  Called multilib-minimal_src_configure
    
  •         environment, line 1108:  Called multilib_foreach_abi 'multilib-minimal_abi_src_configure'
    
  •         environment, line 1335:  Called multibuild_foreach_variant '_multilib_multibuild_wrapper' 'multilib-minimal_abi_src_configure'
    
  •         environment, line 1038:  Called _multibuild_run '_multilib_multibuild_wrapper' 'multilib-minimal_abi_src_configure'
    
  •         environment, line 1036:  Called _multilib_multibuild_wrapper 'multilib-minimal_abi_src_configure'
    
  •         environment, line  404:  Called multilib-minimal_abi_src_configure
    
  •         environment, line 1102:  Called multilib_src_configure
    
  •         environment, line 1556:  Called econf '--with-drivers-path=/usr/lib32/va/drivers' '--enable-glx' '--enable-x11' '--disable-wayland' '--enable-drm'
    
  •    phase-helpers.sh, line  681:  Called __helpers_die 'econf failed'
    
  • isolated-functions.sh, line 112: Called die
  • The specific snippet of code:
  •          die "$@"

попробуй обновиться без x11-libs/libva

EMERGE_DEFAULT_OPTS="--exclude x11-libs/libva" cl-update --scan -veo -R off

Нет. Там еще полезли зависмости. Видимо буду делать переустановку. Спасибо за помощь.

Вы не используете бинарные пакеты? Если так, то могут возникнуть проблемы со сборкой пакетов, в частности libva. На гентушном форуме есть такой рецепт:

USE="-opengl" emerge -1 x11-libs/libva
emerge -1 media-libs/mesa

После этого x11-libs/libva соберется с opengl.

1 Like

Спасибо большое. Вообще я сам виноват. Эспериментировал с различными версиями mesa, ядра и в итоге сам запутался. Я сделал переустановку на ночную сборку. В итоге все стало работать еще лучше - моник поддерживает свои 75 гц и нет горизонтальных зеленых полос и видеокарта работает тише, radeon-profile показывает разгон. Вообщем все к лучшему. Все равно большое спасибо за помощь и поиски. Вам +10 к карме.

Mastodon Mastodon