Сломался Kodi. Просто оставлю это здесь

При запуске пишет

kodi
libva info: VA-API version 1.14.0
libva info: Trying to open /usr/lib64/va/drivers/iHD_drv_video.so
libva info: va_openDriver() returns -1
libva info: Trying to open /usr/lib64/va/drivers/i965_drv_video.so
libva info: va_openDriver() returns -1
Failed to open VDPAU backend libvdpau_va_gl.so: cannot open shared object file: No such file or directory
/usr/bin/kodi: строка 181: 22022 Ошибка сегментирования ${KODI_BINARY} $SAVED_ARGS
Crash report available at /home/guest/kodi_crashlog-20220515_101031.log

Вот что интересное есть в crash report

2022-05-15 10:10:31.300 T:22022 INFO : VDPAU::CreateContext - creating decoder context
2022-05-15 10:10:31.301 T:22022 INFO : vdp_device = 0xf4c19d90 vdp_st = 0x00000001
2022-05-15 10:10:31.301 T:22022 ERROR : (VDPAU) unable to init VDPAU - vdp_st = 0x1. Falling back.
2022-05-15 10:10:31.301 T:22022 INFO : CRenderSystemGL::InitRenderSystem - Version: 4.6 (Compatibility Profile) Mesa 22.0.3, Major: 4, Minor: 6
2022-05-15 10:10:31.301 T:22022 INFO : GL_VENDOR = Intel
2022-05-15 10:10:31.301 T:22022 INFO : GL_RENDERER = Mesa Intel(R) HD Graphics 630 (KBL GT2)
2022-05-15 10:10:31.301 T:22022 INFO : GL_VERSION = 4.6 (Compatibility Profile) Mesa 22.0.3
2022-05-15 10:10:31.301 T:22022 INFO : GL_SHADING_LANGUAGE_VERSION = 4.60

Жду обновление, которое это исправит.

Не дождался обновления, которое это исправит. Нашел инструкцию 5. Установка и удаление программ, а в ней пример с firefox и команду

emerge --autounmask-write =www-client/firefox-22.0

Сделал размаскировку

emerge --autounmask-write =media-libs/mesa-21.3.8

, после чего коди заработал.

Т.е. понизили версию mesa?

Размаскировка данного пакета может привести, в будущем, к нестабильности системы в целом:

$ glxinfo | grep -i opengl | grep -i mesa
OpenGL vendor string: Mesa/X.org
OpenGL core profile version string: 4.5 (Core Profile) Mesa 22.0.5
OpenGL version string: 4.5 (Compatibility Profile) Mesa 22.0.5
OpenGL ES profile version string: OpenGL ES 3.2 Mesa 22.0.5

Будьте внимательны при обновлении.

А у меня так

glxinfo | grep -i opengl | grep -i mesa
OpenGL renderer string: Mesa Intel(R) HD Graphics 630 (KBL GT2)
OpenGL core profile version string: 4.6 (Core Profile) Mesa 21.3.8
OpenGL version string: 4.6 (Compatibility Profile) Mesa 21.3.8
OpenGL ES profile version string: OpenGL ES 3.2 Mesa 21.3.8