Calculate Forum

KDE + android + cut/paste

hi

which files should i change so i have posibility from dolphin to cut/paste files from android device to some folder on desktop machine?

File Sharing? KDE 4 or 5?

i don’t understand you what you mean by file sharing? here is example:
i connect my and device with usb cable, open folders (it says camera in dolphin) with dolphin, choose some files, right mouse button on selected files and i have enabled copy and delete options. cut option is disabled. so first i have to copy files from my and device to desktop machine and then delete them from my device. i repeat this is because option cut from popup menu is disabled. i think that this have something with permissions. but what/which permissions? and where i can change that?
it is scratch 15 kde version. and if i remember from system settings app this is kde4 (4.14.something…i am on win box now)

thanks

I understood. Perhaps incomplete support in KDE.

hm ok, but from today i am pretty confused…i searched with eix mtp what of mtp i have installed. and i found i don’t have none of mtp installed (kio-mtp, libmtp, whatever_mtp…). so how my kde can even open my device under dolphin?

thanks

As far as I know, the connection provides support package kde-misc/kio-mtp, but it has not yet KDE5 ported. Perhaps there are other ways.

camera protocol maybe? and this permission thing is a bug. still from kde 3.5 :smiley:

Hi, x y!

I read the documentation, and came to the conclusion that the problem is easily solved. You just need to install the "flag -mtp» in the package «kde-apps / kio-extras»

We do everything from user “root”!

Here is an example of how to solve it:

$ еix kio-extras

and that the flag is not set «mtp»

We set the flag «mtp» package «kde-apps / kio-extras»:

$ еcho "kde-apps/kio-extras mtp" > /etc/portage/package.use/kio-extras

Run the system update utility:

$ cl-update -eovR

After rebuilding the system, make the system restarts:

$ reboot

Everything is working.

Useful links:

MTP
https://wiki.archlinux.org/index.php/MTP

Вышла версия 2.4 Android File Transfer for Linux, теперь и для OS X
https://www.linux.org.ru/news/multimedia/12033926

no solution for me…simply won’t work. it worked when i get option in popup menu (devicenotifier) open with and not open in dolphin. i think that 1st one opens with camera protocol and 2nd with mtp protocol. mtp protocol simply won’t work with my device. maybe because it is rooted and i have custom rom. but it worked with camera protocol. i tried to wrote camera:/ in dolphin address bar but now this won’t work either :frowning:

all of this is pretty f… up. i have to turn on my smartphone as UMS. mtp on smartphone won’t work at all. and camera (PTP) shows only smartphone memory card and not external sdcard. what a mess…

Everything works. Tested on Android 5.1 and 6.0 smartphone Wileyfox Swift

Mastodon Mastodon