Is This NOT possible to put right

Hi guys
After months of no issues I have hit a wall with this Update
I have a pretty much original instalation and it usually updates quite quick…today it took a couple of hours to calculate dependencies and then i got this below…first time it highlighted chromium as being masked …which it wasnt, or not by me…anyway i tried uninstalling it
but on cl -update i get the readout below…which i dont understand at all so if someone could be kind enough to direct me to the right way of fixing this i would be very grateful

If it cannot be repaired please tell me as I need a working computer

*I do have and have had for a while a problem with browsers not working within the sandbox which i run
qupzilla --no-sandbox

but it has never affected an update before

* Update server
Updating packages
 * Calculating dependencies ...                                           [ ok ]
[binary     U  ] sys-apps/sed-4.5::gentoo [4.2.2::gentoo] USE="acl nls -forced-sandbox% (-selinux) -static" 273 KiB
[binary  NS    ] sys-devel/gcc-7.3.0-r3:7.3.0::gentoo [6.4.0-r1:6.4.0::gentoo] USE="cxx fortran nls nptl objc openmp pch pgo (pie) sanitize ssp vtv (-altivec) -cilk -debug -doc (-fixed-point) -go -graphite (-hardened) (-jit) (-libssp) -mpx (-multilib) -objc++ -objc-gc -regression-test -vanilla" 65220 KiB
[binary     U  ] app-arch/tar-1.30::gentoo [1.29-r3::gentoo] USE="acl nls xattr -minimal (-selinux) -static" 1032 KiB
[binary     U  ] dev-libs/libgpg-error-1.29::gentoo [1.27-r1::gentoo] USE="nls static-libs -common-lisp" 360 KiB
[binary     U  ] dev-libs/libgcrypt-1.8.3:0/20::gentoo [1.8.1:0/20::gentoo] USE="static-libs -doc -o-flag-munging%" 1146 KiB
[binary     U  ] media-libs/babl-0.1.50::gentoo [0.1.38::gentoo] USE="(-altivec)" CPU_FLAGS_X86="mmx sse sse2 sse3%* -f16c -sse4_1" 334 KiB
[binary  N     ] media-gfx/mypaint-brushes-1.3.0:1.0::gentoo  2340 KiB
[binary   R    ] x11-base/xorg-drivers-1.19::gentoo  INPUT_DEVICES="evdev keyboard libinput mouse synaptics -elographics -joystick -tslib -vmmouse -void -wacom" VIDEO_CARDS="amdgpu i915 i965 intel nouveau nv qxl radeon radeonsi vesa via virtualbox* -ast -dummy -fbdev (-freedreno) -geode -glint -mga (-newport) -nvidia (-omap) -r128 -siliconmotion (-tdfx) (-tegra) (-vc4) -vmware (-voodoo)" 17 KiB
[binary  N     ] x11-drivers/xf86-video-vboxvideo-1.0.0::gentoo  50 KiB
[binary     U  ] app-shells/bash-4.4_p12::gentoo [4.3_p48-r1::gentoo] USE="net nls (readline) -afs -bashlogger -examples -mem-scramble -plugins" 1830 KiB
[binary     U  ] dev-libs/nss-3.37.3::gentoo [3.36.1::gentoo] USE="nss-pem utils -cacert" 2910 KiB
[binary     U  ] dev-util/gdbus-codegen-2.54.3::gentoo [2.52.3::gentoo] PYTHON_TARGETS="python2_7 python3_5 -python3_4 -python3_6" 160 KiB
[binary     U  ] dev-libs/glib-2.54.3-r6:2::gentoo [2.52.3:2::gentoo] USE="dbus mime xattr -debug (-fam) (-selinux) -static-libs -systemtap {-test} -utils" PYTHON_SINGLE_TARGET="python2_7%* -python3_5% -python3_6%" PYTHON_TARGETS="python2_7 python3_5%* -python3_6%" 5793 KiB
[binary  N     ] media-libs/gexiv2-0.10.8::gentoo  USE="introspection -python -static-libs {-test} -vala" PYTHON_TARGETS="python2_7 python3_5 -python3_4" 127 KiB
[binary  N     ] app-arch/gcab-0.8::gentoo  USE="introspection -vala" 109 KiB
[binary     U  ] x11-misc/xdg-utils-1.1.3-r1::gentoo [1.1.2-r1::gentoo] USE="-doc" 84 KiB
[binary     U  ] media-libs/libwebp-1.0.0:0/7::gentoo [0.5.2:0/6::gentoo] USE="gif jpeg opengl png tiff (-neon) -static-libs -swap-16bit-csp (-experimental%)" CPU_FLAGS_X86="avx2 sse2 sse4_1" 541 KiB
[binary  N     ] dev-libs/appstream-glib-0.6.13:0/8::gentoo  USE="introspection nls -stemmer" 466 KiB
[binary     U  ] app-crypt/gnupg-2.2.8::gentoo [2.2.4-r2::gentoo] USE="bzip2 nls readline smartcard ssl usb -doc -ldap (-selinux) -tofu -tools -wks-server" 3519 KiB
[binary     U  ] sys-apps/calculate-utils- [] USE="backup client console dbus desktop install qt4 -minimal -pxe (-server)" PYTHON_TARGETS="python2_7" 2668 KiB
[binary     U  ] net-misc/openssh-7.7_p1-r5::gentoo [7.7_p1-r4::gentoo] USE="X pam pie ssl -X509 -audit -bindist -debug -hpn -kerberos -ldap -ldns -libedit -libressl -livecd -sctp (-selinux) -skey -static {-test}" 1673 KiB
[binary  NS    ] media-libs/gegl-0.4.2:0.4::gentoo [0.2.0-r5:0::gentoo] USE="cairo ffmpeg introspection jpeg2k openexr raw sdl svg tiff v4l webp -debug -lcms -lensfun {-test} -umfpack -vala" CPU_FLAGS_X86="mmx sse" 2220 KiB
[binary  NS    ] media-libs/gegl-0.3.26:0.3::gentoo [0.2.0-r5:0::gentoo] USE="cairo ffmpeg introspection jpeg2k openexr raw sdl svg tiff v4l webp -debug -lcms -lensfun {-test} -umfpack -vala" CPU_FLAGS_X86="mmx sse" 2029 KiB
[binary  N     ] www-client/chromium-66.0.3359.170::gentoo  USE="cups hangouts proprietary-codecs pulseaudio suid system-ffmpeg -component-build -custom-cflags -gnome-keyring -jumbo-build -kerberos (-neon) -pic (-selinux) (-system-icu) (-system-libvpx) (-tcmalloc) (-widevine)" L10N="am ar bg bn ca cs da de el en-GB es es-419 et fa fi fil fr gu he hi hr hu id it ja kn ko lt lv ml mr ms nb nl pl pt-BR pt-PT ro ru sk sl sr sv sw ta te th tr uk vi zh-CN zh-TW" 0 KiB
[binary  N     ] media-libs/libmypaint-1.3.0::gentoo  USE="gegl introspection nls openmp" 173 KiB
[binary     U  ] net-print/hplip-3.18.5::gentoo [3.18.4::gentoo] USE="hpcups hpijs policykit qt5 scanner snmp -X -doc -fax -kde -libressl -libusb0 -minimal -parport -static-ppds" PYTHON_SINGLE_TARGET="python3_5 -python2_7 -python3_4 -python3_6" PYTHON_TARGETS="python2_7 python3_5 -python3_4 -python3_6" 20119 KiB
[binary     U  ] media-gfx/gimp-2.10.2:2::gentoo [2.8.22-r1:2::gentoo] USE="alsa jpeg2k openexr%* python smp udev webp%* wmf -aalib (-altivec) (-aqua) -debug -doc -gnome -mng -postscript {-test} -vector-icons% -xpm (-bzip2%*) (-curl%) (-dbus%*) (-exif%*) (-jpeg%*) (-lcms%) (-pdf%*) (-png%*) (-svg%*) (-tiff%*)" CPU_FLAGS_X86="mmx sse" PYTHON_TARGETS="python2_7" 28726 KiB
[binary     U  ] net-print/hplip-plugin-3.18.5::gentoo [3.18.4::gentoo] 1446 KiB
[binary     U  ] media-sound/clementine-1.3.1_p20180523::gentoo [1.3.1_p20180416::gentoo] USE="box cdda dbus dropbox googledrive ipod mtp pulseaudio udisks -debug -lastfm -mms -moodbar -projectm -seafile -skydrive {-test} -wiimote" 5747 KiB
 * 29 packages will be installed, 151098 KiB will be downloaded
!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:


  (media-libs/libwebp-0.5.2:0/6::gentoo, installed) pulled in by
    >=media-libs/libwebp-0.3.0:0/6=[abi_x86_32(-)] required by (media-video/ffmpeg-3.3.6:0/55.57.57::gentoo, installed)
    (and 7 more with the same problem)

  (media-libs/libwebp-1.0.0:0/7::gentoo, binary scheduled for merge) pulled in by
    >=media-libs/libwebp-0.6.0 required by (media-gfx/gimp-2.10.2:2/2::gentoo, binary scheduled for merge)
    ^^                   ^^^^^                                                                                                                                   
    >=media-libs/libwebp-0.5.0:0/7= required by (media-libs/gegl-0.4.2:0.4/0.4::gentoo, binary scheduled for merge)
    (and 1 more with the same problems)

Someone started helping me but after problems with uploading a large file /var/db/pkg which isto big for E-mail in one hit i never heard from him again

let me know if its too far gone to put right and ill reinstall something else


try to update ffmpeg first

emerge -1u ffmpeg

And start update after

Hi Adrien
Thanks for the help
I ran

emerge -1u ffmpeg

Which gave me this

 emerge -1u ffmpeg

Local copy of remote index is up-to-date and will be used.

 * IMPORTANT: 20 news items need reading for repository 'gentoo'.
 * Use eselect news read to view new items.

Calculating dependencies... done!
>>> Jobs: 0 of 0 complete                           Load avg: 1.24, 1.39, 1.71
>>> Auto-cleaning packages...

I tried to update anyway and got

 cl-update --scan
Repositories synchronization
 * Checking Distros updates ...                                           [ ok ]
 * Checking Calculate updates ...                                         [ ok ]
 * Checking Gentoo updates ...                                            [ ok ]
 * Synchronization finished
System configuration
 * Fixing the settings ...                                                [ ok ]
 * Updating configuration files ...                                       [ ok ]
--- /etc/udev/rules.d/70-persistent-net.rules   2018-03-17 04:02:17.093000087 -0600
+++ /etc/udev/rules.d/._cfg0000_70-persistent-net.rules 2018-06-29 19:22:15.658255922 -0600
@@ -1,5 +1,5 @@
-# Modified Calculate Utilities
+# Modified Calculate Utilities
  # Processed template files:
  # /var/lib/layman/calculate/profiles/templates/3.5/3_ac_install_live/1-merge/sys-fs/eudev/70-persistent-net.rules
  # For modify this file, create /etc/udev/rules.d/70-persistent-net.rules.clt template.
@@ -8,7 +8,4 @@
  # Qualcomm AR8151
 SUBSYSTEM=="net", ACTION=="add", DRIVERS=="?*", ATTR{address}=="60:eb:69:b8:60:bb", ATTR{dev_id}=="0x0", ATTR{type}=="1", NAME="eth0"
  # Unknown vendor
-SUBSYSTEM=="net", ACTION=="add", DRIVERS=="?*", ATTR{address}=="8a:22:fd:99:bc:bc", ATTR{dev_id}=="0x0", ATTR{type}=="1", NAME="wlan0"
-# PCI device 0x14e4:0x4357 (bcma-pci-bridge)
-SUBSYSTEM=="net", ACTION=="add", DRIVERS=="?*", ATTR{address}=="88:9f:fa:a4:38:28", ATTR{dev_id}=="0x0", ATTR{type}=="1", NAME="wlan1"
+SUBSYSTEM=="net", ACTION=="add", DRIVERS=="?*", ATTR{address}=="ce:26:3f:4e:08:a3", ATTR{dev_id}=="0x0", ATTR{type}=="1", NAME="wlan1"

 * (1 of 1) -- /etc/udev/rules.d/70-persistent-net.rules

Choose a configuration action: (Zap new[z]/Use new[u]/Next[n]): 

I chose [u]

and got this very colourful print out its quite long so ive put it here

I am very confused as to why this comp has gone like this, it is a very standard install , that ive had running for 3 yrs, then i got a sandbox issue with browsers.

qupzilla --no-sandbox 

and for things like dropbox etc, or they wont run

Im not sure if they are connected issues or no

Humm i have an idea.

Try to uninstall gimp

emerge -C gimp

Do the update

Reinstall GIMP after

I have Uninstalled Gimp,

Sadly it still wont Update here is details of both

When the issue first happened i needed 29 packages, now its 242

I noticed that GIMP and Chromium are still at the end of the list and pulling in dependencies yet both are Uninstalled


  (media-libs/libwebp-0.5.2:0/6::gentoo, installed) pulled in by
    >=media-libs/libwebp-0.4.0:0/6= required by (www-client/chromium-66.0.3359.170:0/0::gentoo, binary scheduled for merge)
    (and 3 more with the same problem)

  (media-libs/libwebp-1.0.0:0/7::gentoo, binary scheduled for merge) pulled in by
    >=media-libs/libwebp-0.6.0 required by (media-gfx/gimp-2.10.4:2/2::gentoo, binary scheduled for merge)


try to remove old media-libs/libwebp version:

emerge -C media-libs/libwebp:0/6

And run again update

removed media libs as per suggestion
got same result on update so ill only post the problem bits


  (media-libs/libwebp-0.5.2:0/6::gentoo, binary scheduled for merge) pulled in by
    media-libs/libwebp:0/6=[abi_x86_32(-)] required by (media-libs/gd-2.2.5:2/3::gentoo, installed)
    (and 3 more with the same problem)

  (media-libs/libwebp-1.0.0:0/7::gentoo, binary scheduled for merge) pulled in by
    >=media-libs/libwebp-0.6.0 required by (media-gfx/gimp-2.10.4:2/2::gentoo, binary scheduled for merge)
    ^^                   ^^^^^                                                                                                                                   
    media-libs/libwebp:0/7= required by (dev-qt/qtimageformats-5.9.6:5/5.9::gentoo, binary scheduled for merge)
    (and 5 more with the same problems)

NOTE: Use the '--verbose-conflicts' option to display parents omitted above

It may be possible to solve this problem by using package.mask to
prevent one of those packages from being selected. However, it is also
possible that conflicting dependencies exist such that they are
impossible to satisfy simultaneously.  If such a conflict exists in
the dependencies of two different packages, then those packages can
not be installed simultaneously. You may want to try a larger value of
the --backtrack option, such as --backtrack=30, in order to see if
that will solve this conflict automatically.

For more information, see MASKED PACKAGES section in the emerge man
page or refer to the Gentoo Handbook.
 * Emerge failed
 * Update failed

Sorry If it seems i take a long time replying I am presently in Nicaragua and we have huge political issues with protests, barricades ,shootings etc…and i lose internet at times, + it takes about 2 hrs every time i try to update

Your problem is very hard and i don’t know where find a solution.

Can you try to update with emerge instead of cl-update ?

emerge -avquDN --with-bdeps=y @world

I really don’t understand why its gone like this , all i do is update every week , im not a tinkerer or havent changed setting for anything
very strange

I have run the Command and the outcome seems almost the same except it doesnt say it failed

emerge -avquDN --with-bdeps=y @world

My first real issue was 5 months ago when i suddenly needed to open browsers etc with


no one offered me any fixes…but everything updated ok until now

Please attach the command output:

emerge -avquDN --with-bdeps=y @world --verbose-conflicts

Hi That took a long time to do !

here is the readout from

emerge -avquDN --with-bdeps=y @world --verbose-conflicts

Hi Guys Thank you for trying to help

Sorry If I dont respond for a few days I have been called out of the country at short notice…

should return soon

Hi I have returned from my travels

has anything shown in my

Please update binary index by <<cl-update -s>> and execute:

emerge -avquDN --with-bdeps=y @world gd chromium qtwebkit ffmpeg --verbose-conflicts
cl-update -s 
Repositories synchronization
 * Checking Distros updates ...                                           [ ok ]
 * Checking Calculate updates ...                                         [ ok ]
 * Checking Gentoo updates ...                                            [ ok ]
 * Synchronization finished
System configuration
 * Update server
 * System update finished!

and here is the details of

emerge -avquDN --with-bdeps=y @world gd chromium qtwebkit ffmpeg --verbose-conflicts

I notice you have “Chromium” mentioned I uninstalled that when i first had issues due to it being a major block on the Update