Is cl-update broken? [Solved]

when I run the cl-update command this is what I get. Whats going on how do I solve this?

calculate ahutsona # cl-update
Traceback (most recent call last):
  File "/usr/sbin/cl-update", line 18, in <module>
    from calculate.core.server.cl_server import main
  File "/usr/lib64/python2.7/site-packages/calculate/core/server/", line 18, in <module>
    import cert_cmd
  File "/usr/lib64/python2.7/site-packages/calculate/core/server/", line 24, in <module>
    from func import new_key_req, uniq
  File "/usr/lib64/python2.7/site-packages/calculate/core/server/", line 25, in <module>
    from api_types import ReturnProgress,ViewParams,Integer,ViewInfo
  File "/usr/lib64/python2.7/site-packages/calculate/core/server/", line 17, in <module>
    from soaplib.serializers.primitive import String, Integer, Boolean
ImportError: No module named soaplib.serializers.primitive

What dev-lang/python and dev-python/soaplib versions has your system?

dev-python/soaplib I donot have installed.


I have python set to 3.3

calculate-core uses dev-python/soaplib. Did you uninstall soaplib by manual?

I dont think I did. But if I re install it calculate-core should have what it needs to run cl-update?

Calculate-core re-install will merge soaplib by depend. It should resolve the error described earlier.

Thank you. That worked perfectly.