Installer doesn't accept root password setup

I’m installing the Calculate Linux ‘cldxs-23-x86_64.iso’. When I get to the page where it wants me to enter the root password, whatever I type for my password get truncated to three characters and the installer complains that the password must have “8 symbols”
Screenshot 2023-02-26 200904
I can’t find a solution. I’ve tried different passwords. It doesn’t matter what I try to use.

Thanks for any assistance.

This is just a picture for safety. The installer remembers your real password (!NO!) and writes it (its hash) to the system being installed in /etc/passwd (/etc/shadow).

Thanks for the response, but this is not exactly true. The installer does not let me advance. (Note the red warning about password length.)

I’ve tried this multiple times, both with and without adding my user+password first. I am prevented from continuing every time. Initially I tried to install the the CLDXS iso, and then I tried the CLDX iso. Same problem both times.

Any other suggestions?

Maybe your password is too simple.

Thanks, but no, it’s 10 characters and it’s a mix of lower case, upper case, and symbols.

Are there no other reports of this problem? I don’t get it.

abc - lower
ABC - upper
!@# - symbols

And about number?

This error is not about root password. When you enter weak root pass, error message will be displayed right after root block:

So, probably mistake was in guest password

и пароль не должен заканчиваться пробелом

Давайте добавим это в подсказку?


Okay I finally got past the root password when I stopped using symbol characters. That is, only upper case, lower case, and numbers. No punctuation symbols. (Maybe one of my symbols was not allowed??)

Oh, and in response to a previous comment, I was using some numbers in the password, I just forgot to list it when I said what the password consisted of…

As for for the guest password, I’m not sure if that was involved in the error or not.

Anyway, thanks for the assistance and suggestions!


I am having exactly same problem, and the solution that worked for the OP, namely no symbols but a mix of lower and upper case and digits, is not working for me.

I wonder if someone may clarify what a “symbol” is meant to mean here, or at least what characters are accepted as symbols.

I have tried a large number of strong passwords, but even the one I use with my CLX-22, in another machine is not accepted. I keep getting the message that it must contain at least 8 symbols.

I have been trying many formulations with 8 different symbols plus lower cases,upper cases and digits, but keep getting the same message and the installer does not allow me to proceed.

I have noticed that “Caps Lock” is not working under CLDX-23 Live. “Shift” seems to work allright.
“Caps Lock” is working normally with other Linux distros in the same machine (it is a multiboot).

I am using a Swedish keyboard and chose Swedish in the first option presented by the installer.

I am not sure this is of any significance

Caps Lock changes the language, doesn’t it?

Sorry I have not answered yet, I have not had the time to go back and check it. I did not notice it while trying to install, but that may have been my miss.