Installation of beyond compare

I managed to install this tool : beyond compare in my previous calculate setup (it was last summer, so it was on 2 versions ago of calculate).

what I did:

  • emerge deb2targz
  • deb2targz bcompare-

this transforms the .deb to a tar.gz file, with content to be copied to /usr/
then I unzipped the content in /usr.
It worked smoothly.
I used it.

But after the upgrade I performed recently on that installed calculate version (installed with an ISO downloaded last summer), where gcc version changed & there are new stuff regarding the management of memory for the process, it was a total failure.
when I tried to launch it it said there was some libs missing (libc** or so)

No software would launch. No dolphin, no ark. nothing.

at reboot: black screen a few seconds after grub.

I tried a ldconfig -v, no luck.

the problem is, I can’t live without that tool: beyond compare. And I won’t switch to calculate if I can’t make it work.

I made a list of software that I use on a daily basis (on arch): I will not make the switch unless I can’t have them all (beyond compare, phpstorm, mysql workbench, WPS office…)

Thansk for your help guys !

Try to use that layman instead deb2targz

Don’t forget to mask all packages from that repo and unmask something when you need it, so that repo won’t collide with updates.

cat /etc/portage/package.mask/custom 

When you want to install such package, portage first asks you to change files, later you should inspect changes with dispatch-conf. Now you’re ready to go and you can install (compile) that package.

Thanks man.

I now just need to learn layman and the rest :wink:

so after reading some docs

  • emerge layman
  • layman -a gentoo-zh
  • layman -S


  • emerge app-misc/bcompare

It failed.

Reading the ebuild, which is really easy to understand, it shows the package is unmaintained because it relies on outdated stuff:

So it means that what I did with deb2targz is roughly the same, except I install by hand as root at the end.

at least I learned something today: layers & layman


the ebuild has this :

x86? (${PV}.i386.tar.gz )
amd64? (${PV}.x86_64.tar.gz )"

Irealized I just had to replace $PV with the current version: looking at their website you can download so I tried

and the download worked ! :wink:
(the ebuild tries the 4.2.2 version)

then the rest of the ebuild is a patch on the that comes with the archive.

    sed -i ./ -e 's/^# Create desktop entry and place.*/exit 0/g'
    sed -i ./ -e "s%^# Copy the files.*%BC_BIN=\"$D/\$BC_BIN\"; BC_LIB=\"$D/\$BC_LIB\";%g"
    sed -i ./ -e "s/^\texit 1.*//g"

then you can run the proper part manually in a shell:

local LAUNCHER="bcompare/bin/bcompare"
./ --prefix="${targetdir}"

I don’t know why it installs in /opt, but in the end, beyond compare works !

I tested this on the live cd, I have to redo it after the install - I hope it will work.

So far so good, I’ll have to change the ebuild & maintain it myself later on.

why not install it from the gentoo-zh overlay with layman?

sudo su
layman -o -L
layman -a gentoo-zh
emerge -av app-misc/bcompare

then you can remove the overlay after install if you want

layman -d gentoo-zh

So it’s better to add ebuild with newer version.

I think it is possible to get the last version automatically, then do the rest.
As soon as I get Calculate installed I’ll do that.

Thanks again

you could mask the whole overlay except bcompare

To mask all packages of an overlay the syntax in /etc/portage/package.mask is:


To unmask bcompare from gentoo-zh overlay the syntax in /etc/portage/package.unmask is:


that way the only package you will get and remain updated/replaced will be bcompare, from my understanding from the wiki’s i read about it. seen there was a lot of packages in that overlay wanted to make sure there was a way they wouldnt replace the packages from the calculate overlay.