I have an optimus cursed laptop and no current build of calculate will install on it, making YouTube videos about it
but my old ISO 17.12.2 still installs fine, just can’t get it to update the rolling release.
All help is very much appreciated and welcome ;-))
impossible to satisfy simultaneously. If such a conflict exists in
the dependencies of two different packages, then those packages can
not be installed simultaneously. You may want to try a larger value of
the --backtrack option, such as --backtrack=30, in order to see if
that will solve this conflict automatically.
For more information, see MASKED PACKAGES section in the emerge man
page or refer to the Gentoo Handbook.
!!! All ebuilds that could satisfy “>=dev-libs/ell-0.3” have been masked.
!!! One of the following masked packages is required to complete your request:
dev-libs/ell-0.17::gentoo (masked by: EAPI 7)
dev-libs/ell-0.16::gentoo (masked by: EAPI 7)
dev-libs/ell-0.9::gentoo (masked by: EAPI 7)
dev-libs/ell-0.9 (masked by: EAPI 7)
The current version of portage supports EAPI ‘6’. You must upgrade to a
newer version of portage before EAPI masked packages can be installed.
(dependency required by “net-wireless/bluez-5.50-r1::gentoo” [binary])
(dependency required by “dev-lang/python-3.6.6::gentoo[bluetooth]” [ebuild])
(dependency required by “dev-libs/libxml2-2.9.8-r1::gentoo[python,python_targets_python3_6]” [ebuild])
(dependency required by “sys-devel/gettext-0.19.8.1::gentoo” [installed])
(dependency required by “sys-apps/texinfo-6.5-r1::gentoo[nls]” [ebuild])
(dependency required by “sys-apps/groff-1.22.4::gentoo” [ebuild])
(dependency required by “net-nds/openldap-2.4.45::gentoo” [ebuild])
(dependency required by “autodeps" [set]) (dependency required by "selected” [set])
(dependency required by “@world” [argument])
For more information, see the MASKED PACKAGES section in the emerge
man page or refer to the Gentoo Handbook.
What going on, I run emerge portage? Result is
Failed to find the binary updates server.
If you have updated your servers or have been shut down, you are most likely updating support for eapi7 and support for IPV6. Half of the program had support for IPV6 half did not, it was supposed to look in the beans and solve the conflicts.
I know what it’s for, but I’ve lost my nerves, but for many days I’ve been fighting for IPV6, EAPI7. I contacted the author chaoslbab because that layman began to suck. The author told me that CLD was not fit to receive EAPI7 (whatever it was) and set up its chaoslab. A couple of days of shutdown and then a problem, do not run servers, coincidence just when I did that command does not suddenly have any server with binary packs. The problem of interdependence, which I was dragging from zz-file, additional setup, I deleted this parameter and after 2 days I managed to compile the file for which I asked for help. Some programs had default IPV6 in themselves and some did not. Now, finally, when all servers have run all the programs on the same IPv6 dependency, I do not need a menu because my provider takes money on CGNAT, the optical connection is 300Mb / s, the irony of the optical connection goes over CGNAT.
I know you do not adore a layman, but I need to use a couple of added repositories because these programs do not exist in Calculate and Gentoo. The most important one I use is radeon-profiles for my graphic card and I’m hoping to better cooling the graphic card through that program. I have a water cooled world-famous manufacturer that has 2x leak and burned 2 graphics cards. Now I use air cooled.
Something I did not understand is that from TeamViewer 13, Teamviewer does not work with me, in all the other Linux I use, but Calculate does not. For me, it’s unexplainable because I read 1000 pages and tips on the Internet and nothing helps. Maybe he does not like me to use 2 monitors, other linuxs do not mind. It does not run an automatic update and is set to work.
Apparently all the available versions of dev-python/certifi are EAPI=6, and that’s needed in order to update portage in order to… install EAPI6 packages. Apparently the EAPI=5 versions were removed yesterday.
I don’t know the correct way to solve this, but considering that package is very simple and small, simply setting EAPI=5 in order to install it would PROBABLY work.
I guess it would be wise for the Gentoo devs to keep this package as EAPI=5 for cases like this.