How to set ethernet card to gain IP


I am using your CLDG gnome version of CLD and liked it very much ,But i have a problem
I have few different types of hardware available like Dell,HCL,Novatium PC’s as CPU.
I am having problems with HCL and Dell systems like; When installing CLD on to it it gains IP Address from DHCP but doesn’t really ping any local or external IP Addresses.
When i ping DNS) it says Destination host unreachable.
When i plug another System on to the same port it picks the IP and works well.
Do i need to change iface or eth0 to configure to gain IP from DHCP.
I have tried net-setup eth0 and set as wired and DHCP , Still doesn’t ping any thing but picks IP Address
I am sure that a particular Ethernet card is not been recognized by CLDG.
Can you tell how can i configure/set my ethernet card to accept ip from DHCP,
For your information it pings and the IP itself that it gains, It doesn’t pings its gateway .
My N/w port and cable works fine with other system,And the same series of system works fine with Windows OS and Ubuntu.
Please guide me as how can i configure my eth1 or eth0 to have an IP that pings outside world
Also let me know what is the method in CLDG to change iface from eth0 to eth1 and configure ethernet card accordingly.

By the way i am using a hardware independent Cloned image to deploy on all machines. That makes eth1 as active iface…

Pranav Sharma

Try the commands on CLDG or CLD:

rm /etc/udev/rules.d/70-persistent-net.rules

/sbin/dhcpcd eth0

if there is another interface

/sbin/dhcpcd eth1

Hi Alex

Thanks for your reply,

After deleting the file

rm /etc/udev/rules.d/70-persistent-net.rules
when i do ifconfig: there is no IP Address,but interface is eth0

I have tried the commands , it says
/sbin/dhcpcd eth0

dhcpcd: version 5.1.3 starting
dhcpcd: eth0 rebinding lease of
dhcpcd: eth0: broadcasting for a lease
dhcpcd: timed out
dhcpcd: allowing 8 seconds for ipv4LL timedout
dhcpcd: timed out

When i checked dhcpcd status it was stopped
when i tried restarting dhcpcd like
/etc/init.d/dhcpcd restart

*Starting DHCP Client Daemon
dhcpcd: timed out
dhcpcd: allowing 8 seconds for ipv4LL timedout
dhcpcd: timed out
*start-stop-daemon: failed to start ‘/sbin/dhcpcd’
*Failed to start dhcpcd
*Error: dhcpcd failed to start

Please guide what to do?

Pranav Sharma


Also i have observed that i rebooted the machine it pings for a while and then again sets back to destination host unreachable.
And the file /etc/udev/rules.d/70-persistent-net.rules is again created…



no need to delete this file, it automatically created when you start the system.
show output when you run this line

ifconfig -a

Try to configure the network without dhcpd.