How to mount Samba share && Remove blinking wifi light && emerge programs

First I should say that this distro looks great and seems to work very well. I just have a couple issues and I would love to keep using it as my favorite distro.

# I tried setting up a permanent samba share with: //server/public /media/public cifs users,cred=/home/bob/.smbcred,uid=bob,gid=public,file_mode=0660,dir_mode=0770,nounix,nobrl,iocharset=utf8,_netdev 0 0, but I get the error: /sbin/mount.cifs not installed setuid - “user” CIFS mounts not supported. So my question is how do I connect to a samba share?
# In other distros I create: /etc/modprobe.d/wlan.conf with ‘options iwlcore led_mode=1’. This causes my wifi light to stay on all the time rather than blinking with internet activity. Is there some other way of doing this it doesn’t work in this distro?
# Last, I can’t seem to emerge any programs. I would like to install Banshee, but get the error messages in the attached file.

This is probably too many questions for one post. Sorry. Appreciate the help though.


emergeBansheeError (7.61 KB)

# where you are trying to mount a share? if you use a CDS, the server resources will be mounted automatically.
# never asked this question…
# copy and paste the text in the file /etc/portage/package.unmask/banshee


And the text in a file /etc/portage/package.use/banshee

>=media-libs/libgpod-0.8.0 mono

The samba share is on a CentOS server and I’m trying to mount it into /media. I’ve read about CDS and it’s peaked my interest but would be a bit of work to switch.

Well, it looks like this is the problem:

But I haven’t figured out a solution. Is there some way to rebuild mount.cifs with the setuid enabled?

Are you mount a samba share using the file /etc/fstab? Maybe when the system boots, at the time of mount partitions you have not yet risen network. Try to enter the mount command in /etc/NetworkManager/dispatcher.d/

Yes, the mount is in fstab, but I include the ‘_netdev’ option in the mount that requires the network to be available. This has worked in the past.

It seems that mount.cifs in specific versions has been built such that users cannot use it, only root. Even if you try to chmod u+s mount.cifs it will not work as the developers have restricted it.

Not sure what to do.

2. It seems like it like this
Have you tried change iwlcore to iwlagn in your’s config?

options iwlagn led_mode=1

3. For mounting from user you can try use fusesmb. May be it help you.

I tried iwlagn but it didn’t work, dang it.

I’ve been playing with smbnetfs and it seems to work alright. Just have to set it up to run when the computer boots.