High CPU utilization/usage by the process "mandb --quiet" and during package installation,update.

I downloaded “cldx-20160714-i686.iso” and “cldx-15.17-i686.iso” and the problem exist in the both.
I tried Virtualbox on AMD A4 4000 and bare metal ( A4 4000, Celeron 478 and Pentium 4) and there was no change in the behavior, mandb --quiet was utilizing the CPU at 100% and the system was barely usable. I killed the process, then everything was normal and installed the distro without problem.
“mandb --quiet” continued to start after the installation. I’v done something (But don’ know exactly what, disabled startup scripts like bluetooth,cupsd… disabled some autostart programs, disabled splash and quiet grub options…) so mandb --quiet wasn’t anymore starting after every boot and using 100% of my CPU.

Second question:
Is it normal the CPU (A4 4000 and Pentium 4 945 D) to be utilized at 100% the whole time (not just few peaks) during packages install, system update or just repo syncing (the same happened during the whole process of installation) ?
As I understand Calculate uses binary packages and that’s why this bugs me, cause make the installation of the distro on the older computers I have pointless for me if just the update will take forever, but despite that the system works fast. So, is it just, because the package manager is slow, resource-heavy and clumsy or what ? (please forgive my ignorance I come from Arch Linux and Void Linux where the package manager don’t often use more than 60% of the cpu when upgrading, syncing repos or installing packages on my hp nc6220)

I was suspecting something like faulty HDD’s, but now Manjaro OpenRC works flawlessly on the computers on which I tried Calculate.
So the second question is the most important here (for me) because it will give me answer if Calculate will suit my needs and if it worth trying to fix the problems I have with it.

Any help will be welcome and thanks in advance for any response!