Calculate Forum

Точка G или настройка D-link DWA-510 в CLDX 10.4

Понадобилось подключить к сети через беспроводный PCI-адаптер 802.11g DWA-519 компьютер с CLDX 10.4, собственно, он и раньше был подключен, но под другой ОС :wink:
Ядро вот такое:

name -a 
Linux calculate 2.6.32.11-calculate #1 SMP PREEMPT Sat Apr 3 06:41:42

Диск, идущий в комплекте с картой, как обычно, оказался бесполезен. Поэтому я занялся гуглением яндекса, которое показало что:

* В карте находится чипсет RaLink RT2561/RT61;

* В ядре поддержки оного нет (перекомпилировать лениво и долго на этой машине)
В подтверждение сего факта говорит следующее:

lspci|grep 802
00:0a.0 Network controller: RaLink RT2561/RT61 rev B 802.11g

Далее обратим свой взор к eix (а можно и emerge)

eix rt61
[I] net-wireless/rt61-firmware
     Available versions:  (~)1.2
     Installed versions:  1.2(00:43:09 01.01.2003)
     Homepage:            http://www.ralinktech.com/ralink/Home/Support/Linux.html
     Description:         Firmware for Ralink rt61-based PCI/PCMCIA WiFi adapters (rt61pci module)

Кажется, вот оно счастье, устанавливаем. Emerge пытается скачать firmware c сайта Ralink, но тот недоступен, поэтому обращется к зеркалу Gentoo, на котором нужные файлы (rt2561.bin, rt2561s.bin, rt2661.bin) оказываются. Затем эти файлы попадают в /lib/firmware. Что ж смотрим iwconfig:

#: iwconfig wlan0
wlan0     IEEE 802.11bg  ESSID:"blablabla"  
          Mode:Managed  Frequency:2.452 GHz  Access Point: 00:11:22:AA:BB:CC   
          Bit Rate=24 Mb/s   Tx-Power=16 dBm   
          Retry  long limit:7   RTS thr:off   Fragment thr:off
          Encryption key:off
          Power Management:off
          Link Quality=34/70  Signal level=-76 dBm  
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:0   Missed beacon:0

Теперь Wicd после сканирования видит точку доступа, Настраиваем шифрование WPA2, устанавливаем получение IP и DNS по DHCP. Жмём подключиться… и получаем ошибку о том, что пароль неверный! Вот те раз, как же так? Снова идём в настройки, включаем отображение пароля при вводе, снова вводим. Про пробуем подключиться, снова ожидание и снова пароль неверный.
Далее следуют мучительные раздумья в течении 3х дней с попытками отключить шифрование, перезагрузкой точки доступа и т.п. Но истина оказалась там, где её и не ждали. Оказывается, если убрать получение IP по DHCP в wicd, а заодно и указать ручками сервера DNS, то подключение таки происходит, но весьма недолго держится…
Снова думы и сомнения, а чтобы зря время не терять -

 emerge -uD system и world

И похоже, что апдейт помог. Жаль, что неизвестно какой именно пакет нужно было обновить. Теперь соединение не обрывается, но работа с DHCP так и заканчивается “неверным паролем”. Поэтому живём на ручном управлении. :slight_smile:

Может кто-то знает способ побороть такую проблему?

попробуй NetworkManager. Думаю проблему не решит(а может и решит), но он хотябы адекватные логи пишет в messages по поводу того - что делает и где падает.

для удобства настройки рекомендую установить gnome-extra/nm-applet.

Если все получится добавь в make.conf
USE="${USE} networkmanager"
чтоб включить его поддержку везде где включается.

Михаил Гагауз писал(а):

попробуй NetworkManager. Думаю проблему не решит(а может и решит), но он хотябы адекватные логи пишет в messages по поводу того - что делает и где падает.

Так и wicd тоже пишет логи (/var/log/wicd/wicd.log), но их чтение мне не помогло. Да и не хочется лишнего в систему ставить, тем более компьютер слабоват.

Так и wicd тоже пишет логи (/var/log/wicd/wicd.log), но их чтение мне не помогло.
Хм. незнал, хотя может не там искал в свое время. В любом случае c WiFi NetworkManager более адекватно себя ведет. во всяком случае так было раньше.

Помнится, был такой нехороший глюк у wicd - он держал соединение лишь на одном интерфейсе, т.е. если у тебя появляется линк на eth0, то падает eth1, это одна из многих причин по которой я перешел на NetworkManager (хотя отсутствие к нему консольной морды сильно огорчает).

Да и не хочется лишнего в систему ставить, тем более компьютер слабоват.
Ресурсов NetworkManager жрет немного, я не сравнивал, но думаю, разницы с Wicd большой нет. На жестком, же, занимает 365.63 KiB, что думаю, не существенно.

PS может скинешь кусок лога, касаемо подключения/отваливания сюда. Можно еще и куски из dmesg, если есть что интересное по поводу сетевых.

Михаил Гагауз писал(а):

Ресурсов NetworkManager жрет немного, я не сравнивал, но думаю, разницы с Wicd большой нет. На жестком, же, занимает 365.63 KiB, что думаю, не существенно.
Там ещё небольшой вагончик зависимостей тянется…

PS может скинешь кусок лога, касаемо подключения/отваливания сюда. Можно еще и куски из dmesg, если есть что интересное по поводу сетевых.
Логи имеет смысл смотреть включенном DHCP, только тогда возникает ошибка. Вечером выложу такие логи и приложу dmesg

Обещанные логи wicd:

2010/09/14 20:42:53 :: Autoconnecting...
2010/09/14 20:42:53 :: No wired connection present, attempting to autoconnect to wireless network
2010/09/14 20:42:53 :: trying to automatically connect to...MySIDD
2010/09/14 20:42:53 :: Connecting to wireless network SergeniuS
2010/09/14 20:42:54 :: Putting interface down
2010/09/14 20:42:54 :: Releasing DHCP leases...
2010/09/14 20:42:54 :: Setting false IP...
2010/09/14 20:42:54 :: Stopping wpa_supplicant
2010/09/14 20:42:54 :: Flushing the routing table...
2010/09/14 20:42:54 :: Putting interface up...
2010/09/14 20:42:56 :: Generating psk...
2010/09/14 20:42:56 :: Attempting to authenticate...
2010/09/14 20:43:31 :: wpa_supplicant authentication may have failed.
2010/09/14 20:43:31 :: connect result is Failed
2010/09/14 20:43:31 :: exiting connection thread
2010/09/14 20:43:31 :: Sending connection attempt result bad_pass

А теперь просто тупо и цинично нажимаем ещё раз подключиться:

2010/09/14 20:45:08 :: Connecting to wireless network MySIDD
2010/09/14 20:45:08 :: Putting interface down
2010/09/14 20:45:08 :: Releasing DHCP leases...
2010/09/14 20:45:08 :: Setting false IP...
2010/09/14 20:45:08 :: Stopping wpa_supplicant
2010/09/14 20:45:08 :: Flushing the routing table...
2010/09/14 20:45:08 :: Putting interface up...
2010/09/14 20:45:10 :: Generating psk...
2010/09/14 20:45:10 :: Attempting to authenticate...
2010/09/14 20:45:23 :: Setting static IP : 10.16.1.7
2010/09/14 20:45:23 :: Setting default gateway : 10.16.1.1
2010/09/14 20:45:23 :: Verifying AP association...
2010/09/14 20:45:23 :: Attempt 1 of 10...
2010/09/14 20:45:25 :: Successfully associated.
2010/09/14 20:45:25 :: Connecting thread exiting.
2010/09/14 20:45:25 :: Sending connection attempt result Success

И тут-то тот же самый пароль ВДРУГ оказывается верным… Мистика.

А вот откуда ноги растут у проблемы http://bugs.gentoo.org/274782

Mastodon Mastodon