Fresh install - wont boot

I am a long time gentoo user. I am trying calculate for the first time. So, I downloaded the cldm-17.12-x86_64.iso, I loaded into a usb key and I installed without hassle using all the default options. I haven’t changed a single tick mark. I have to mention that I wiped out my 500GB entirely with the default partition scheme, so Calculate is the only os in this HD. Everything went well apparently but when I reboot I get a message from the BIOS that there is no OS. I checked the boot order settings and they are ok. Also, UEFI option is disabled in the BIOS (I’ve also try enabling it). I’ve tried the same procedure in two different computers with the same result. Any clue? Thanks for your help.

I’ve solved the problem. The thing is that two systems I’ve tried Calculate on are old (around 8 years - Q6700 quad core - 8GB ram) so the BIOS has trouble to recognize the boot partition. I found the solution in Gentoo handbook.

fdisk -t dos /dev/sda
Command (m for help): a
Partition number (1-4): 1
Command (m for help): w

I think It can be useful to add a warning somewhere in the install gui that recommends to use fdisk for old system instead of GPT.

It’s strange that the installer did not set the partition’s activity. I have tested system install in virtualbox with dos partition table and partition activity was set correctly.

You are right. Later, I did the some test (setting dos partition) and it works out the box. What I meant to say, is that with all the default options, the installer choses a GPT partition scheme that does not work out of the box in old hardware. If Calculate wants to become more widespread in my opinion this something that the installer should warm the user about.