File Ownership after installation?

During the installation I added a new User Account (mtbvfr) for myself and intended to delete the guest account afterwards.

All the Directories and Files on my LinuxData partition are owned by the guest user account and I am unable to change the ownership.

I tried sudo thunar & in Terminal, which I was able to do using the guest account in the Live environment, but a Root instance of Thunar was not started.

When replying, please make sure that you provide a comprehensive and fully explained answer!


When logged in are you logged in as guest or as a normal user? Do you see two home directories? One guest and one for mtbvfr?

if you needed to change the owner and the group of all files I would use:

find /home -user guest -exec chown mtbvfr:mtbvfr ‘{}’ \;

Have a look at;

man find
man chown

Before executing anything please read the man pages!!!

Please test in a trivial folder with trivial files.

I am logged in as mtbvfr.

There are home directories for both guest and mtbvfr.

man chown is useless.

What does ‘{}’ \ mean?

Will I be able to use the chown command given that I can’t use sudo as per the following topic I also posted?


When replying, please make sure that you provide a comprehensive and fully explained answer!

’{}’ \

The ‘{}’ is like an “execute on everything in this set” its wrapped in quotes to protect the entries from being expanded by the shell. The ‘\’ is as an escape character for the ‘;’, the ‘;’ just ends the statement.

In regards to your other post. In order to use ‘sudo’ your user mtbvfr needs to be in the sudoers file located in /etc/sudoers. Switch to the root user via ‘su’, type the root password. Use your favorite editor to edit the sudoers file. The syntax will be like this ‘mtbvfr ALL=(ALL) ALL’ save and close (there are many other ways to do this, like adding your user to one of the groups in the file then un-comment out that groups line). Now mtbvfr can execute commands with elevated privileges (with mtbvfr’s password).

I would take care of adding your user to the sudoers file then chown all of the guest files over to mtbvfr.

Thanks Antonio!

Well, this is almost ready to be marked as SOLVED but for the following question.

Why was the Ownership given to the guest account or for what reason did the guest account have Ownership of these directories and files instead of the mtbvfr account I created for myself?

Thanks, MTB.

I don’t actually know the answer to that. What iso did you use? I can try to recreate the problem inside a VM.

I used the Xfce ISO.