Failed LUKS install using cl-install (no grub, no boot folder at reboot)


I tried the guideline for LUKS install from a post posted by someone.

Установка Calculate на LUKS - Planet Calculate

When I launch the cl-install command, at the end it displays:

Run process? (Yes/No): yes
 * Formatting the partitions ...                                                                                                                             [ ok ]
 * Unpacking the system image to the target ...                                                                                                              [ ok ]
 * Copying clt templates to the new system ...                                                                                                               [ ok ]
 * Updating the configuration ...
 * Configuring the grub  
 * Post-install configuration ...                                                                                                                            [ ok ]
 * Migrating users ...                                                                                                                                       [ ok ]
 * Preparing the system for reboot ...
* * Failed to install the bootloader*
 * Unmounting the target system volume ...                                                                                                                   [ ok ]
* * Failed to install the system!*

You can see at the end the failed messages.

It is a UEFI/SSD 26b NVM disk.
I first created with partitionmanager

  • one fat32 partition of 200mb for uefi
  • all the rest for luks partition

Here is the history executed on the LiveCD (adapted from

emerge -vt cryptsetup 
fdisk -l
HOSTNAME=$(pwgen -0A $(( 4 + (RANDOM%3) )) )
cryptsetup luksFormat $LUKS
LUKS_UUID=$( blkid $LUKS -o udev | sed -nre 's/^ID_FS_UUID=(\S+)$/\1/p' )
cryptsetup luksOpen "${LUKS}" "luks-${LUKS_UUID}" <<< "${lukspw}" 

pvcreate "${SYSDEV}" 
vgcreate "${HOSTNAME}" "${SYSDEV}" 

lvcreate -n swap -L 24G "${HOSTNAME}"
lvcreate -n root -L 30G "${HOSTNAME}"
lvcreate -n _var_calculate -l 100%FREE "${HOSTNAME}"

mkswap /dev/mapper/${HOSTNAME}-swap
swapon /dev/mapper/${HOSTNAME}-swap
mkfs.ext4 /dev/mapper/${HOSTNAME}-root
mkfs.ext4 /dev/mapper/${HOSTNAME}-_var_calculate
#mkfs.ext4 ${BOOT} not executed (kept Fat32)

this did not work:
cl-install --uefi /dev/nvme0n1 -p OFF     -d ${BOOT}:/boot:EFI     -d /dev/mapper/${HOSTNAME}-root:/:ext4     -d /dev/mapper/${HOSTNAME}-swap:swap     -d /dev/mapper/${HOSTNAME}-_var_calculate:/var/calculate     -d /var/calculate/home:/home

but this worked:

cl-install  -p OFF  --uefi /dev/nvme0n1       -d /dev/mapper/${HOSTNAME}-root:/:ext4     -d /dev/mapper/${HOSTNAME}-swap:swap     -d /dev/mapper/${HOSTNAME}-_var_calculate:/var/calculate     -d /var/calculate/home:/home                

after I read  this  (here
The EFI partition will be detected automatically. Should you have a few of them (on several disks), you can specify the one you need using the following syntax for the EFI mounting point: -d /dev/sda1:EFI. This very parameter  handles the automatic configuration of the partition you have specified. 

the install gave the 2 errors at the end
 * Failed to install the bootloader
 * Failed to install the system!*

then I tried the rest of the post

mkdir /tmp/newroot
mount -v /dev/mapper/${HOSTNAME}-root /tmp/newroot/
mount -v /dev/mapper/${HOSTNAME}-_var_calculate /tmp/newroot/var/calculate/
mount -v ${BOOT} /tmp/newroot/boot/
for d in /dev{,/shm,/pts} /sys /proc ; do     mount --bind -v $d /tmp/newroot$d; done
echo 'add_dracutmodules+=" crypt"' > /tmp/newroot/etc/dracut.conf.d/10-crypt.conf

    chroot /tmp/newroot /bin/bash <<< 'so

urce /etc/profile && emerge -vt sys-fs/cryptsetup && dracut --force’

Any idea?
smotheing wrong?
Thanks !

I am attachng the console.log during the install.

install_console_history.txt (54.2 KB)

i’m sad, no answer ;-(

FYI I installed Redcore linux which can install LUKS out of the box.
The Redcore team itself advised calculate if I wanted to run Plasma, because they are focused on Lxqt.
in effect, very difficult to install plasma on their linux (qt version conflicts).

In the end, i will try installing direclty gentoo with luks.
if it still fail, ultimately I’ll go back to Arch.