Emerge world Leaves me with House Cleaning ????

Need some portage direction.
What Next?

Seems the sync worked well but the emerge left me with a lot to do ( I think )
BUT the emerge world left me with
slot collisions
Use changes
requests to --autounmask-write

So, I need some help to maintain the install in a correct balanced way.

Here are the commands I performed and the results needing attention.

emerge -uDNa world

eix-sync worked well results

[N] >> x11-terms/terra (**9999): Terminal emulator with split-screen support
* Time statistics:
2 seconds for syncing
12 seconds for eix-update
5 seconds for eix-diff
127 seconds total

!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:
(dev-lang/python-2.7.3-r3::gentoo, binary scheduled for merge) pulled in by
(no parents that aren’t satisfied by other packages in this slot)
(dev-lang/python-2.7.3-r3::gentoo, ebuild scheduled for merge) pulled in by
dev-lang/python:2.7[threads,sqlite] required by (mail-client/thunderbird-17.0.4::gentoo, ebuild scheduled for >merge)

It might be possible to solve this slot collision
by applying all of the following changes:

  • dev-lang/python-2.7.3-r3 (Change USE: +sqlite)
    The following USE changes are necessary to proceed:
    (see “package.use” in the portage(5) man page for more details)
    # required by mail-client/thunderbird-17.0.4
    # required by `selected

required by `world (argument)

=dev-lang/python-2.7.3-r3:2.7 sqlite
# required by dev-util/eric-4.5.8
# required by `selected

required by `world (argument)

=dev-python/PyQt4-4.9.6-r2 webkit help

Use --autounmask-write to write changes to config files (honoring
CONFIG_PROTECT). Carefully examine the list of proposed changes,
paying special attention to mask or keyword changes that may expose
experimental or unstable packages.
!!! The following installed packages are masked:

  • x11-misc/google-gadgets-0.11.2::gentoo (masked by: package.mask)
    # Bernard Cafarelli voyageur@gentoo.org (20 Mar 2013)
    # Masked for removal in 30 days, bug #462472
    # Dead upstream (last website activity in 2010),
    # search for new widgets does not work anymore,
    # only a few pre-installed gadgets still work correctly,
    # plasma-workspace does not work with it,
    # does not work with current webkit-gtk

For more information, see the MASKED PACKAGES section in the emerge
man page or refer to the Gentoo Handbook.

Ok …
I believe I have the system updated cleanly.
I am posting what I have done with Portage and where I am at this time in system package status.

If Someone would Please examine my output below and comment and suggest.
Thank You, as you can see I am learning to use Portage.

Right now my system shows that I am at

I first

emerge -uDN world

By The Way I can’t find reference to difference if I emerge -uDNa world

Then as a result had to

echo “=dev-lang/python-2.7.3-r3:2.7 sqlite” >> /etc/portage/package.use/custom

echo “=dev-python/PyQt4-4.9.6-r2 webkit help” >> /etc/portage/package.use/custom

Also had to


Lastly I checked all with a sync and a pretend Update

000001 * emerge --sync --verbose --nospinner*
000002 >>> Starting git pull in /usr/portage…
000003 Already up-to-date.
000004 >>> Git pull in /usr/portage successful
000005 * process completed*
000006 * emerge --update --pretend --verbose --nospinner --noreplace world*
000008 These are the packages that would be merged, in order:
000010 Calculating dependencies … … … done!
000011 [ebuild U ] dev-util/eric-4.5.8:4 [4.5.6:4] USE=“spell -kde” LINGUAS=“de en es fr it ru -cs -tr -zh_CN” 0 kB
000012 [binary U ] media-sound/sox-14.4.1 [14.3.2-r1] USE=“alsa amr encode ffmpeg flac id3tag mad ogg openmp png wavpack -ao -debug -ladspa -oss -pulseaudio -sndfile -static-libs -twolame%” 0 kB
000013 [binary U ] media-gfx/gimp-2.8.4:2 [2.8.2-r1:2] USE=“aalib alsa bzip2 dbus exif jpeg jpeg2k mmx mng pdf png smp sse svg tiff udev* wmf xpm (-altivec) -curl -debug -doc -gnome -lcms -postscript -python -webkit” LINGUAS=“bg de es fr it pl pt pt_BR ro ru uk -am -ar -ast -az -be -br -ca -ca@valencia -cs -csb -da -dz -el -en_CA -en_GB -eo -et -eu -fa -fi -ga -gl -gu -he -hi -hr -hu -id -is -ja -ka -kk -km -kn -ko -lt -lv -mk -ml -ms -my -nb -nds -ne -nl -nn -oc -pa -rw -si -sk -sl -sr -sr@latin -sv -ta -te -th -tr -tt -vi -xh -yi -zh_CN -zh_HK -zh_TW” 0 kB
000014 [binary U ] sys-kernel/calckernel-3.4.18-r14::calculate [3.4.18-r11::calculate] USE=“bash-completion lspci nfs (-ibm) (-selinux)” VIDEO_CARDS=“radeon” 0 kB
000015 [binary U ] dev-vcs/git- [] USE=“blksha1 curl gnome-keyring%* gpg iconv nls pcre python threads tk webdav -cgi -cvs -doc -emacs -gtk -highlight -perl (-ppcsha1) -subversion {-test} -xinetd” 0 kB
000016 [binary UD ] app-text/evince-2.32.0-r4 [3.4.0] USE=“dbus djvu gnome-keyring introspection postscript tiff -debug -dvi -gnome% -nautilus -t1lib (-xps%)” 0 kB
000017 [binary U ] www-client/chromium-25.0.1364.160 [24.0.1312.56] USE=“cups gnome-keyring -bindist -custom-cflags -gnome -kerberos (-pulseaudio) (-selinux) (-system-ffmpeg) (-tcmalloc) {-test}” LINGUAS=“bg de es fr it pl pt_BR pt_PT ro ru uk -am -ar -bn -ca -cs -da -el -en_GB -es_LA -et -fa -fi -fil -gu -he -hi -hr -hu -id -ja -kn -ko -lt -lv -ml -mr -ms -nb -nl -sk -sl -sr -sv -sw -ta -te -th -tr -vi -zh_CN -zh_TW” 0 kB
000018 [binary U ] net-analyzer/nmap-6.25 [6.01] USE=“ipv6* lua* nls* ssl -gtk -ncat -ndiff -nmap-update -nping” LINGUAS=“de* es* fr* it* pl* pt_BR* ro* ru* -hr% -hu% -id% -ja% -pt_PT% -sk% -zh%” 0 kB
000019 [binary U ] net-misc/networkmanager- [] USE=“bluetooth connection-sharing consolekit dhcpcd introspection modemmanager nss ppp wext wimax -avahi -dhclient -doc -gnutls -resolvconf (-systemd) -vala” 0 kB
000020 [binary U ] net-im/pidgin-2.10.7-r1 [2.10.6] USE=“dbus gtk ncurses networkmanager nls spell xscreensaver (-aqua) -debug -doc -eds -gadu -gnutls -groupwise -gstreamer -idn -meanwhile -perl -prediction -python -sasl -silc -tcl -tk -zephyr -zeroconf” 0 kB
000021 [ebuild U ] media-sound/clementine-1.1.1 [1.0.1-r1] USE=“cdda dbus ios* ipod udev (-ayatana) -debug% -googledrive% -lastfm -mms -moodbar% -mtp -projectm {-test} -wiimote (-kde)” LINGUAS=“bg de es fr it pl pt pt_BR ro ru uk -af -ar -be -bn -br -bs -ca -cs -cy -da -el -en_CA -en_GB -eo -es_AR% -et -eu -fa -fi -ga% -gl -he -hi -hr -hu -hy -ia -id -is -ja -ka -kk -ko -lt -lv -mr -ms -nb -nl -oc -pa -sk -sl -sr -sr@latin -sv -te% -tr -uz% -vi -zh_CN -zh_TW” 0 kB
000022 [binary NS ] sys-kernel/calculate-sources-3.8.4:3.8.4::calculate [3.6.11:3.6.11::calculate] USE=“minimal symlink vmlinuz -build” 0 kB
000023 [binary U ] sys-apps/calculate-lib-2.2.31-r1:2.2::calculate [2.2.31:2.2::calculate] USE="-minimal" 0 kB
000024 [binary U ] sys-apps/calculate-builder-2.2.31-r10::calculate [2.2.31::calculate] 0 kB
000025 [binary U ] sys-apps/calculate-utilities-2.2.31-r11::calculate [2.2.31::calculate] CL=“builder -assemble -server” 0 kB
000027 Total: 15 packages (13 upgrades, 1 downgrade, 1 in new slot, 13 binaries), Size of downloads: 0 kB
000028 ***** Based on the build history of these packages on your system, I can estimate that emerging them usually takes, on average, 0 days, 0 hrs, 10 mins, and 19 secs.
000029 ***** Note: If you have a lot of programs running on your system while porthole is emerging packages, or if you have changed your hardware since the last time you built some of these packages, this estimate may be inaccurate.
000030 * process completed*

Any comments or suggestions on above results?
Thank You

I do not understand your question. What is wrong? It seems there is nothing stopping you upgrade or did you just check yourself?


My first post shows my results of my sync and Update.

My second post shows my Use adjustments, the config adjustments and a Pretend sync Update to compare to my Actual Update in my first post.

My conclusion is that all seems updated and clean.
My question is by looking at the results of the Second Pretend Update are any steps left un-done or is there a suggestion for further steps?

THank You

I think everything is fine and does not require further action.

Thanks Iurii !
The more I use portage the more confident I become with viewing the results.
It it is a help to have the results reviewed by an experienced portage user.
I read the the wiki and how tos but I do have some doubts upon viewing the results sometimes.

Next emerge world I will be more confident with my steps.