emerge -ua world and emerge firefox

When I do emerge -ua world, I get this;

!!! FAILED postinst: 1
/bin/bash: /lib/libc.so.6: version `GLIBC_2.15' not found (required by /bin/bash)

Tried to install sys-libs/glibc, dev-libs/libg15 as suggested, but the same reply as above.

Also with Firefox:

Emerging (1 of 1) www-client/firefox-10.0.6
[www-client/firefox-10.0.6] bash: /lib/libc.so.6: version `GLIBC_2.15' not found (required by [www-client/firefox-10.0.6] bash)
 * The ebuild phase 'die_hooks' has been aborted since PORTAGE_BUILDIR does
 * not exist: '/var/calculate/tmp/portage/www-client/firefox-10.0.6'

>>> Failed to emerge www-client/firefox-10.0.6

 * Messages for package www-client/firefox-10.0.6:

This happens today, but yesterday Firefox was installed. Today I tried to install firefox-15.0.1, but without results. Can’t install anything today, as the “GLIBC_2.15 not found” reason.

What am I doing wrong?

I re-installed CLDG, but now I can’t even install Firefox. This is what I get;

>>> Failed to emerge www-client/firefox-10.0.7, Log file:

>>>  '/var/calculate/tmp/portage/www-client/firefox-10.0.7/temp/build.log'

 * Messages for package www-client/firefox-10.0.7:

 * You are enabling official branding. You may not redistribute this build
 * to any users on your network or the internet. Doing so puts yourself into
 * a legal problem with Mozilla Foundation
 * You can disable it by emerging firefox _with_ the bindist USE-flag
 * ERROR: www-client/firefox-10.0.7 failed (compile phase):
 *   emake failed
 * Call stack:
 *     ebuild.sh, line  85:  Called src_compile
 *   environment, line 7036:  Called die
 * The specific snippet of code:
 *           CC="$(tc-getCC)" CXX="$(tc-getCXX)" LD="$(tc-getLD)" MOZ_MAKE_FLAGS="${MAKEOPTS}" emake -f client.mk || die "emake failed";
 * If you need support, post the output of `emerge --info '=www-client/firefox-10.0.7'`,

So, here is that;

Portage 2.2.0_alpha120 (!../var/lib/layman/calculate/profiles/calculate/desktop/CLDG/x86/binary, gcc-4.5.3, glibc-2.14.1-r3, 3.4.5-calculate i686)
                        System Settings
System uname: Linux-3.4.5-calculate-i686-Intel-R-_Core-TM-2_Duo_CPU_P8600_@_2.40GHz-with-gentoo-12.0
Timestamp of tree: Sun, 16 Sep 2012 19:00:01 +0000
app-shells/bash:          4.2_p20
dev-lang/python:          2.7.3-r2, 3.2.3
dev-util/cmake:           2.8.7-r5
dev-util/pkgconfig:       0.27.1
sys-apps/baselayout:      2.1-r1
sys-apps/sandbox:         2.5
sys-devel/autoconf:       2.13, 2.68
sys-devel/automake:       1.9.6-r3, 1.11.1
sys-devel/binutils:       2.21.1-r1
sys-devel/gcc:            4.5.3-r2
sys-devel/gcc-config:     1.6
sys-devel/libtool:        2.4-r1
sys-devel/make:           3.82-r1
sys-kernel/linux-headers: 3.1 (virtual/os-headers)
sys-libs/glibc:           2.14.1-r3
Repositories: gentoo calculate
Installed sets: @custom
CFLAGS="-O2 -march=i686 -pipe"
CONFIG_PROTECT="/etc /usr/share/gnupg/qualified.txt /usr/share/openvpn/easy-rsa"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/dconf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/splash /etc/terminfo"
CXXFLAGS="-O2 -march=i686 -pipe"
EMERGE_DEFAULT_OPTS="--binpkg-respect-use=y --quiet-build=n"
FCFLAGS="-O2 -march=i686 -pipe"
FEATURES="assume-digests binpkg-logs config-protect-if-modified distlocks ebuild-locks fixlafiles getbinpkg metadata-transfer parallel-fetch parallel-install parse-eapi-ebuild-head preserve-libs protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch"
FFLAGS="-O2 -march=i686 -pipe"
LINGUAS="en bg de es fr it pl pt pt_BR ro ru ru_RU uk"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
USE="3dnow X a52 aac aalib acl acpi alsa amr audiofile avi bash-completion berkdb bittorrent bluetooth bzip2 cairo cdda cddb cdparanoia cdr chm clamav cli consolekit cpudetection cracklib crypt css cue cups cxx dbus djvu dri dv dvd dvdr dvdread ebook encode exif faac fbcon fdftk ffmpeg flac flash foomaticdb fortran ftp gd gdbm ggi gif gnome gnome-keyring gphoto2 gpm gtk iconv id3tag ieee1394 imagemagick ipod ipv6 irc jabber jingle jpeg jpeg2k libcaca libnotify libwww lirc logrotate lzo mad matroska mbox mikmod mmx mmxext mng modules mp3 mpeg mplayer mudflap musepack nas nautilus ncurses networkmanager nfs nls nptl nsplugin ogg oggvorbis openal opencore-amr openexr opengl openmp oscar pam pcre pdf png policykit portaudio ppp pppd qt3support quicktime raw readline samba scanner sdl session smp speex spell srt sse sse2 sse3 sse4.1 sse4.2 sse4a sse5 ssl ssse3 svg tcpd tga theora tiff truetype unicode usb userlocales v4l v4l2 vaapi vcd vdpau vhosts vidix vorbis wavpack wimax win32codecs wmf wxwindows x264 x86 xanim xcomposite xinerama xpm xv xvid xvmc yahoo zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1 emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALCULATE="printer wireless" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump" CAMERAS="* ptp2" CDISTRO="CLDG desktop" CL="builder client desktop console consolegui" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" FOO2ZJS_DEVICES="*" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" INPUT_DEVICES="keyboard mouse evdev mutouch synaptics" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" LINGUAS="en bg de es fr it pl pt pt_BR ro ru ru_RU uk" LIRC_DEVICES="devinput" PHP_TARGETS="php5-3" PYTHON_TARGETS="python3_2 python2_7" RUBY_TARGETS="ruby18 ruby19" USERLAND="GNU" VIDEO_CARDS="fbdev glint intel mach64 mga neomagic nouveau nv r128 radeon savage sis tdfx trident vesa via vmware nouveau nvidia i915 i965 r100 r200 r300 r600 radeonhd dummy v4l" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"


What is your USE FLAGS for firefox in



XKomodor | Julien