emerge --depclean have a problem

 # emerge --depclean

 * Always study the list of packages to be cleaned for any obvious
 * mistakes. Packages that are part of the world set will always
 * be kept.  They can be manually added to this set with
 * `emerge --noreplace <atom>`.  Packages that are listed in
 * package.provided (see portage(5)) will be removed by
 * depclean, even if they are part of the world set.
 * As a safety measure, depclean will not remove any packages
 * unless *all* required dependencies have been resolved.  As a
 * consequence, it is often necessary to run `emerge --update
 * --newuse --deep @world` prior to depclean.

Calculating dependencies... done!
>>> Calculating removal order...

!!! 'sys-apps/less' (virtual/pager) is part of your system profile.
!!! Unmerging it may be damaging to your system.

why ?
how cuold i do now?

Because it’s one of basic Linux commands, I guess.
But I have no idea why you are experiencing this problem - I thought the system never tried to remove packages like this one.

Have you had a complete update, though? With <<emerge -uDN world>>, as recommended?

If you have and it still doesn’t work, the fastest method to solve this is to reinstall less (<>), for it to be put explicitly on the @world list. But as far as I know, the situation itself isn’t normal, so…

This is the second attempt to throw the package out of dependency. For some reason, only to Portage it needed.

Diff portage-2.2.0_alpha59 with a portage-2.2.0_alpha60

As a temporary solution, we added depending to app-misc/cl-base-meta-11.9-r1.