Calculate🐧Forum

Emege a échoué Blocked Packages

#1

Bonjour a tous !
Pour faire court voici le message
amicalement larkinux.

Synchronisation des dépôts
 * Checking current binhost ...                                           [ ok ]
 * Checking Distros updates ...                                           [ ok ]
 * Checking Calculate updates ...                                         [ ok ]
 * Syncing the Calculate repository ...                                   [ ok ]
 * Checking Gentoo updates ...                                            [ ok ]
 * Update packages index ...                                              [ ok ]
 * Check packages index signature ...                                     [ ok ]
 * Actualisation du cache du dépôt Distros ...                            [ ok ]
 * Actualisation du cache du dépôt Calculate ...                          [ ok ]
 * Updating the eix cache for Distros, Calculate, Gentoo ...              [ ok ]
 * Updating the cache of configurable packages ...                        [ ok ]
 * Synchronisation terminée
Configuration système
 * Update server http://miroir.linuxtricks.fr/calculate
 * Correction des paramètres ...                                          [ ok ]
 * Mise à jour des fichiers de configuration ...                          [ ok ]
Mise à jour des paquets
 * Calcul des dépendances ...                                             [ ok ]
[binary     U  ] x11-misc/xbitmaps-1.1.2-r1::gentoo [1.1.2::gentoo] 34 KiB
[binary     U  ] sys-apps/baselayout-2.6-r1::gentoo [2.4.1-r2::gentoo] USE="split-usr%* -build" 54 KiB
[binary     U  ] x11-misc/xkeyboard-config-2.25::gentoo [2.23.1-r1::gentoo] 946 KiB
[binary     U  ] dev-libs/ivykis-0.42.3-r1::gentoo [0.42.2::gentoo] USE="-static-libs%" 69 KiB
[binary     U  ] x11-misc/makedepend-1.0.5-r1::gentoo [1.0.5::gentoo] 42 KiB
[binary     U  ] x11-misc/util-macros-1.19.2-r1::gentoo [1.19.2::gentoo] 56 KiB
[binary     U  ] media-fonts/encodings-1.0.4-r3::gentoo [1.0.4-r1::gentoo] USE="(-X)" 618 KiB
[binary     U  ] sys-libs/timezone-data-2018g::gentoo [2018e::gentoo] USE="nls -leaps_timezone" 313 KiB
[binary     U  ] sys-process/lsof-4.91::gentoo [4.89::gentoo] USE="ipv6 rpc -examples (-selinux) (-static%)" 363 KiB
[binary     U  ] sys-devel/bison-3.1::gentoo [3.0.5-r1::gentoo] USE="nls -examples -static -test" 841 KiB
[binary     U  ] dev-libs/openssl-1.0.2p-r1::gentoo [1.0.2p::gentoo] USE="asm sslv3 tls-heartbeat zlib -bindist -gmp -kerberos -rfc3779 -sctp -sslv2 -static-libs -test -vanilla" ABI_X86="32 (64) (-x32)" CPU_FLAGS_X86="(sse2)" 4384 KiB
[binary     U  ] x11-libs/libX11-1.6.7::gentoo [1.6.6::gentoo] USE="ipv6 -doc -static-libs -test" ABI_X86="32 (64) (-x32)" 2667 KiB
[binary     U  ] net-misc/wget-1.19.5-r1::gentoo [1.19.5::gentoo] USE="idn ipv6 nls pcre ssl zlib -debug -gnutls -libressl -ntlm -static -test -uuid" 794 KiB
[binary  N     ] sys-power/powermgmt-base-1.31::gentoo  USE="(-pm-utils)" 0 KiB
[binary   R    ] sys-apps/lm_sensors-3.4.0_p20180923:0/4.4.0::gentoo  USE="-contrib -sensord -static-libs" ABI_X86="32* (64) (-x32)" 208 KiB
[binary     U  ] media-libs/imlib2-1.5.1-r1::gentoo [1.5.1::gentoo] USE="X bzip2 gif jpeg mp3 nls png shm%* tiff zlib -doc% -static-libs" ABI_X86="(64) -32 (-x32)" CPU_FLAGS_X86="sse2 (-mmx)" 636 KiB
[binary     U  ] net-firewall/shorewall-5.2.1.1::gentoo [5.2.0.5::gentoo] USE="init ipv4 ipv6 -doc -lite4 -lite6 (-selinux)" 678 KiB
[binary     U  ] dev-db/postgresql-10.6:10::gentoo [10.5:10::gentoo] USE="nls pam readline server ssl threads zlib -doc -kerberos -ldap -libressl -perl -python (-selinux) -static-libs (-systemd) -tcl -uuid -xml" PYTHON_SINGLE_TARGET="python3_6 -python2_7 -python3_4 -python3_5" PYTHON_TARGETS="python2_7 python3_6 -python3_4 -python3_5" 7412 KiB
[binary     U  ] x11-libs/libSM-1.2.3::gentoo [1.2.2-r2::gentoo] USE="ipv6 uuid -doc -static-libs" ABI_X86="32 (64) (-x32)" 84 KiB
[binary     U  ] sys-fs/mdadm-4.1::gentoo [3.4::gentoo] USE="-static" 510 KiB
[binary     U  ] app-admin/syslog-ng-3.17.2::gentoo [3.13.2::gentoo] USE="caps ipv6 smtp tcpd -amqp -dbi -geoip -geoip2% -http -json -libressl -mongodb -pacct -python -redis -spoof-source (-systemd)" PYTHON_SINGLE_TARGET="python3_6%* -python2_7% -python3_4% -python3_5%" PYTHON_TARGETS="python2_7 python3_6%* -python3_4% -python3_5%" 893 KiB
[binary     U  ] net-fs/nfs-utils-2.3.3::gentoo [2.3.1-r3::gentoo] USE="caps ipv6 libmount nfsidmap nfsv4 tcpd uuid -junction% -kerberos -ldap -nfsdcld -nfsv41 (-selinux)" 434 KiB
[binary     U  ] dev-libs/rasqal-0.9.33::gentoo [0.9.32::gentoo] USE="crypt mhash pcre -gmp -static-libs -test -xml" 380 KiB
[binary     U  ] virtual/dev-manager-0-r2::gentoo [0-r1::gentoo] 8 KiB
[binary     U  ] virtual/logger-0-r1::gentoo [0::gentoo] 9 KiB
[binary     U  ] net-libs/libmbim-1.16.2::gentoo [1.14.0::gentoo] USE="udev -static-libs" 259 KiB
[binary     U  ] x11-libs/libdrm-2.4.96::gentoo [2.4.93::gentoo] USE="libkms -valgrind" ABI_X86="32 (64) (-x32)" VIDEO_CARDS="amdgpu intel nouveau radeon vmware (-exynos) (-freedreno) (-omap) (-tegra) (-vc4) (-vivante)" 440 KiB
[binary     U  ] net-libs/libqmi-1.20.2:0/5.1::gentoo [1.16.2:0/5.1::gentoo] USE="mbim -doc -static-libs" 1317 KiB
[binary     U  ] sys-apps/groff-1.22.3::gentoo [1.22.2::gentoo] USE="X -examples" L10N="(-ja%)" 3598 KiB
[binary     U  ] net-fs/samba-4.8.6-r2::gentoo [4.8.6::gentoo] USE="acl client cups ldap pam system-mitkrb5 winbind -addc -addns -ads -ceph -cluster -debug (-dmapi) -fam -gnutls -gpg -iprint -python -quota (-selinux) -syslog (-system-heimdal) (-systemd) -test -zeroconf" ABI_X86="(64) -32 (-x32)" PYTHON_TARGETS="python2_7" 8255 KiB
[binary     U  ] media-libs/mesa-18.2.4::gentoo [18.1.9::gentoo] USE="classic dri3 egl gallium gbm gles2 llvm lm_sensors%* vaapi vdpau vulkan xa xvmc -d3d9 -debug -gles1 -opencl -osmesa -pax_kernel -pic (-selinux) -test% -unwind -valgrind -wayland (-bindist%) (-nptl%*) (-openmax%)" ABI_X86="32 (64) (-x32)" VIDEO_CARDS="i915 i965 intel nouveau r100 r200 r300 r600 radeon radeonsi (-freedreno) (-imx) (-vc4) -virgl (-vivante) -vmware" 36540 KiB
[binary     U  ] media-libs/libepoxy-1.5.3::gentoo [1.5.1::gentoo] USE="X -test" ABI_X86="32 (64) (-x32)" 690 KiB
[binary   R    ] x11-base/xorg-server-1.20.3:0/1.20.3::gentoo  USE="glamor ipv6 kdrive suid* udev xorg xvfb -debug -dmx -doc -libressl -minimal (-selinux) -static-libs (-systemd) -unwind -wayland -xcsecurity -xephyr -xnest" 4141 KiB
[binary     U  ] dev-python/pycairo-1.17.0-r1::gentoo [1.16.3-r1::gentoo] USE="-doc -examples -test" PYTHON_TARGETS="python2_7 python3_6 (-pypy) (-pypy3) -python3_4 -python3_5 (-python3_7)" 140 KiB
[binary     U  ] virtual/editor-0-r2::gentoo [0-r1::gentoo] 11 KiB
[binary     U  ] net-dialup/pptpclient-1.10.0::gentoo [1.8.0::gentoo] USE="-tk" 94 KiB
[binary     U  ] app-admin/sudo-1.8.25_p1-r1::gentoo [1.8.23-r2::gentoo] USE="nls pam sasl sendmail -gcrypt -ldap -offensive -openssl (-selinux) -skey -sssd%" 955 KiB
[binary     U  ] media-video/ffmpeg-3.3.6:0/55.57.57::gentoo [3.3.6_rc73:0/55.57.57::gentoo] USE="X alsa amr bzip2 chromium cpudetection encode gpl hardcoded-tables iconv ieee1394 jpeg2k mp3 network openal opengl openssl opus postproc pulseaudio sdl speex theora threads truetype v4l vaapi vdpau vorbis vpx wavpack webp x264 x265 xcb xvid zlib (-altivec) -amrenc -bluray -bs2b -cdio -chromaprint -debug -doc -fdk -flite -fontconfig -frei0r -fribidi -gcrypt -gme -gmp -gnutls -gsm -iec61883 -jack -kvazaar -ladspa -libass -libcaca -libilbc -librtmp -libsoxr -libv4l -lzma (-mipsdspr1) (-mipsdspr2) (-mipsfpu) (-mmal) -modplug -nvenc -openh264 -oss -pic -rubberband -samba (-schroedinger) -snappy -sofalizer -ssh -static-libs -test -twolame -zeromq -zimg -zvbi (-celt%)" ABI_X86="32 (64) (-x32)" CPU_FLAGS_X86="3dnow 3dnowext aes avx avx2 fma3 fma4 mmx mmxext sse sse2 sse3 sse4_1 sse4_2 ssse3 xop" FFTOOLS="aviocat cws2fws ffescape ffeval ffhash fourcc2pixfmt graph2dot ismindex pktdumper qt-faststart sidxindex trasher" 26647 KiB
[binary     U  ] mate-extra/mate-power-manager-1.20.2-r1::calculate [1.20.2_rc73::calculate] USE="applet policykit -gnome-keyring (-pm-utils) (-systemd) -test" 3305 KiB
[binary     U  ] mate-base/mate-applets-1.20.2::calculate [1.20.2_rc73::calculate] USE="X ipv6 policykit upower" PYTHON_TARGETS="python2_7" 7971 KiB
[binary   R    ] media-video/mplayer-1.3.0-r5::gentoo  USE="X a52 alsa bidi cddb cdio cdparanoia cpudetection dv dvd dvdnav enca encode faac ftp gif iconv ipv6 jpeg libass live lzo mad mp3 network openal opengl osdmenu png pulseaudio samba sdl shm speex tga theora truetype unicode v4l vcd vdpau vorbis x264 xinerama xscreensaver xv xvid -aalib (-altivec) (-aqua) -bl -bluray -bs2b -debug -dga -doc -dts -dvb -faad -fbcon -ggi -gsm -jack -joystick -ladspa -libcaca -libmpeg2 -lirc -md5sum -mng -nas -nut -oss -pnm -pvr -radio -rar -rtc -rtmp (-selinux) -toolame -tremor -twolame (-vidix) -yuv4mpeg -zoran (-xvmc%*)" CPU_FLAGS_X86="3dnow 3dnowext mmx mmxext sse sse2 ssse3" VIDEO_CARDS="-mga (-tdfx)" 2177 KiB
[binary     U  ] www-client/firefox-63.0.1-r1::gentoo [63.0.1::gentoo] USE="bindist dbus gmp-autoupdate hwaccel system-icu system-jpeg system-libevent system-libvpx system-sqlite -clang -custom-cflags -custom-optimization -debug -eme-free -geckodriver -hardened -jack -lto (-neon) -pulseaudio -screenshot (-selinux) -startup-notification -system-harfbuzz -test -wifi" L10N="bg bs cs da de es-AR es-ES es-MX et fi fr hr hu it kk lt lv nl pl pt-BR pt-PT ro ru sk sl sq sr sv uk -ach -af -an -ar -as -ast -az -bn-BD -bn-IN -br -ca -cak -cy -dsb -el -en-GB -en-ZA -eo -es-CL -eu -fa -ff -fy -ga -gd -gl -gn -gu -he -hi -hsb -hy -id -is -ja -ka -kab -km -kn -ko -lij -mai -mk -ml -mr -ms -nb -nn -or -pa -rm -si -son -ta -te -th -tr -uz -vi -xh -zh-CN -zh-TW" 59358 KiB
[binary     U  ] sys-apps/calculate-utils-3.6.1.11:3::calculate [3.6.1.8_rc73:3::calculate] USE="backup client console dbus desktop gpg install qt5 -minimal -pxe (-server)" PYTHON_TARGETS="python2_7" 2588 KiB
[blocks B      ] sys-power/powermgmt-base[-pm-utils(+)] ("sys-power/powermgmt-base[-pm-utils(+)]" is blocking sys-power/pm-utils-1.4.1-r7)
 * 43 paquets à installer, 180899 KiB à télécharger
Conflict: 1 block (1 unsatisfied)

 * Error: The above package list contains packages which cannot be
 * installed at the same time on the same system.

  (sys-power/powermgmt-base-1.31:0/0::gentoo, binary scheduled for merge) pulled in by
    >=sys-power/powermgmt-base-1.31 required by (sys-apps/apmd-3.2.2_p14-r1:0/0::gentoo, installed)

  (sys-power/pm-utils-1.4.1-r7:0/0::gentoo, installed) pulled in by
    sys-power/pm-utils required by @selected
    sys-power/pm-utils required by (sys-auth/consolekit-1.2.1:0/0::gentoo, installed)

For more information about Blocked Packages, please refer to the following
section of the Gentoo Linux x86 Handbook (architecture is irrelevant):

https://wiki.gentoo.org/wiki/Handbook:X86/Working/Portage#Blocked_packages
 * Emege a échoué
 * Mise à jour échouée
#2

Bonjour,

Normalement sur MATE (sur la mienne) je n’ai ni sys-apps/apmd ni sys-power/powermgmt-base.

Un paquet MATE a été recompilé sans ce support, il faut le mettre à jour d’abord. La commande

emerge @preserved-rebuild

doit régler le problème.

Retentes la MàJ après

cl-update
#3

salut et merci adrien
mais j’ai toujours ce vilain message

Synchronisation des dépôts
 * Checking current binhost ...                                                                                                                         [ ok ]
 * Checking Distros updates ...                                                                                                                         [ ok ]
 * Checking Calculate updates ...                                                                                                                       [ ok ]
 * Checking Gentoo updates ...                                                                                                                          [ ok ]
 * Synchronisation terminée
Configuration système
 * Update server http://miroir.linuxtricks.fr/calculate
Mise à jour des paquets
 * Calcul des dépendances ...                                                                                                                           [ ok ]
[binary  NS    ] dev-lang/spidermonkey-52.9.1_pre1:52::gentoo [1.8.5-r6:0/mozjs185::gentoo] USE="system-icu -custom-cflags -custom-optimization -debug -minimal -test" 7253 KiB
[binary     U  ] app-text/hunspell-1.6.2-r1:0/1.6::gentoo [1.6.1-r1:0/1.6::gentoo] USE="ncurses nls readline -static-libs" L10N="bg cs da de de-1901 en es et fr hr hu it kk lt lv nl pl pt pt-BR ro ru sk sl sq sv uk -af -ca -cy -el -eo -fo -ga -gl -he -ia -id -is -km -ku -mi -mk -ms -nb -nn -sw -tn -zu" 397 KiB
[binary     U  ] sys-apps/keyutils-1.5.11-r1:0/1.7::gentoo [1.5.10-r1:0/1.6::gentoo] USE="-static -static-libs -test" ABI_X86="(64) -32 (-x32)" 108 KiB
[binary  N     ] sys-power/pm-utils-1.4.1-r7::gentoo  USE="alsa -debug -ntp" VIDEO_CARDS="intel radeon" 0 KiB
[binary     U  ] media-libs/mesa-18.2.5::gentoo [18.2.4::gentoo] USE="classic dri3 egl gallium gbm gles2 llvm lm_sensors vaapi vdpau vulkan xa xvmc -d3d9 -debug -gles1 -opencl -osmesa -pax_kernel -pic (-selinux) -test -unwind -valgrind -wayland" ABI_X86="32 (64) (-x32)" VIDEO_CARDS="i915 i965 intel nouveau r100 r200 r300 r600 radeon radeonsi (-freedreno) (-imx) (-vc4) -virgl (-vivante) -vmware" 36546 KiB
[binary   R    ] x11-base/xorg-server-1.20.3:0/1.20.3::gentoo  USE="glamor ipv6 kdrive suid* udev xorg xvfb -debug -dmx -doc -libressl -minimal (-selinux) -static-libs (-systemd) -unwind -wayland -xcsecurity -xephyr -xnest" 4141 KiB
[binary     U  ] sys-auth/polkit-0.115-r1::gentoo [0.113-r4::gentoo] USE="introspection nls pam -elogind -examples -gtk -jit -kde (-selinux) (-systemd) -test" 234 KiB
[binary   R    ] media-video/mplayer-1.3.0-r5::gentoo  USE="X a52 alsa bidi cddb cdio cdparanoia cpudetection dv dvd dvdnav enca encode faac ftp gif iconv ipv6 jpeg libass live lzo mad mp3 network openal opengl osdmenu png pulseaudio samba sdl shm speex tga theora truetype unicode v4l vcd vdpau vorbis x264 xinerama xscreensaver xv xvid -aalib (-altivec) (-aqua) -bl -bluray -bs2b -debug -dga -doc -dts -dvb -faad -fbcon -ggi -gsm -jack -joystick -ladspa -libcaca -libmpeg2 -lirc -md5sum -mng -nas -nut -oss -pnm -pvr -radio -rar -rtc -rtmp (-selinux) -toolame -tremor -twolame (-vidix) -yuv4mpeg -zoran (-xvmc%*)" CPU_FLAGS_X86="3dnow 3dnowext mmx mmxext sse sse2 ssse3" VIDEO_CARDS="-mga (-tdfx)" 2177 KiB
[blocks B      ] sys-power/powermgmt-base[-pm-utils(+)] ("sys-power/powermgmt-base[-pm-utils(+)]" is blocking sys-power/pm-utils-1.4.1-r7)
 * 8 paquets à installer, 50854 KiB à télécharger
Conflict: 1 block (1 unsatisfied)

 * Error: The above package list contains packages which cannot be
 * installed at the same time on the same system.

  (sys-power/powermgmt-base-1.31:0/0::gentoo, installed) pulled in by
    >=sys-power/powermgmt-base-1.31 required by (sys-apps/apmd-3.2.2_p14-r1:0/0::gentoo, installed)
    sys-power/powermgmt-base required by @selected

  (sys-power/pm-utils-1.4.1-r7:0/0::gentoo, binary scheduled for merge) pulled in by
    sys-power/pm-utils required by (sys-auth/consolekit-1.2.1:0/0::gentoo, installed)

For more information about Blocked Packages, please refer to the following
section of the Gentoo Linux x86 Handbook (architecture is irrelevant):

https://wiki.gentoo.org/wiki/Handbook:X86/Working/Portage#Blocked_packages
 * Emerge a échoué
 * Mise à jour échouée
#4

salut a tous mon probleme a été résolu en parti grace a adrien

calculate /home/jfrancois # emerge --pretend pm-utils

These are the packages that would be merged, in order:

Calculating dependencies... done!
[binary  N     ] sys-power/pm-utils-1.4.1-r7  USE="alsa -debug -ntp" VIDEO_CARDS="intel radeon" 
[blocks B      ] sys-power/powermgmt-base[-pm-utils(+)] ("sys-power/powermgmt-base[-pm-utils(+)]" is blocking sys-power/pm-utils-1.4.1-r7)

 * Error: The above package list contains packages which cannot be
 * installed at the same time on the same system.

  (sys-power/powermgmt-base-1.31:0/0::gentoo, installed) pulled in by
    sys-power/powermgmt-base required by @selected

  (sys-power/pm-utils-1.4.1-r7:0/0::gentoo, binary scheduled for merge) pulled in by
    pm-utils


For more information about Blocked Packages, please refer to the following
section of the Gentoo Linux x86 Handbook (architecture is irrelevant):

https://wiki.gentoo.org/wiki/Handbook:X86/Working/Portage#Blocked_packages


 * IMPORTANT: 9 news items need reading for repository 'gentoo'.
 * Use eselect news read to view new items.

calculate /home/jfrancois # emerge -C sys-power/powermgmt-base-1.31

 * This action can remove important packages! In order to be safer, use
 * `emerge -pv --depclean <atom>` to check for reverse dependencies before
 * removing packages.

 sys-power/powermgmt-base
    selected: 1.31 
   protected: none 
     omitted: none 

All selected packages: =sys-power/powermgmt-base-1.31

>>> 'Selected' packages are slated for removal.
>>> 'Protected' and 'omitted' packages will not be removed.

>>> Waiting 5 seconds before starting...
>>> (Control-C to abort)...
>>> Unmerging in: 5 4 3 2 1
>>> Unmerging (1 of 1) sys-power/powermgmt-base-1.31...

 * IMPORTANT: 2 config files in '/etc' need updating.
 * See the CONFIGURATION FILES and CONFIGURATION FILES UPDATE TOOLS
 * sections of the emerge man page to learn how to update config files.

 * IMPORTANT: 9 news items need reading for repository 'gentoo'.
 * Use eselect news read to view new items.

cl-update

Synchronisation des dépôts
 * Searching new binhost ...                                                                                                                            [ ok ]
 * Checking Distros updates ...                                                                                                                         [ ok ]
 * Checking Calculate updates ...                                                                                                                       [ ok ]
 * Checking Gentoo updates ...                                                                                                                          [ ok ]
 * Update packages index ...                                                                                                                            [ ok ]
 * Check packages index signature ...                                                                                                                   [ ok ]
 * Synchronisation terminée
Configuration système
 * Update server was changed to http://miroir.linuxtricks.fr/calculate
 * Correction des paramètres ...                                                                                                                        [ ok ]
 * Mise à jour des fichiers de configuration ...                                                                                                        [ ok ]
--- /etc/hosts  2018-08-09 00:26:35.292245101 +0200
+++ /etc/._cfg0000_hosts    2018-05-28 21:31:04.000000000 +0200
@@ -1,7 +1,37 @@
-#------------------------------------------------------------------------------
-# Modified Calculate Utilities 3.5.8.2
-# Processed template files:
-# /var/lib/layman/calculate/profiles/templates/deprecated/3.5/3_ac_install_live/1-merge/sys-apps/baselayout/hosts
-# For modify this file, create /etc/hosts.clt template.
-#------------------------------------------------------------------------------
-127.0.0.1  calculate.local calculate localhost
+# /etc/hosts: Local Host Database
+#
+# This file describes a number of aliases-to-address mappings for the for 
+# local hosts that share this file.
+#
+# The format of lines in this file is:
+#
+# IP_ADDRESS   canonical_hostname  [aliases...]
+#
+#The fields can be separated by any number of spaces or tabs.
+#
+# In the presence of the domain name service or NIS, this file may not be 
+# consulted at all; see /etc/host.conf for the resolution order.
+#
+
+# IPv4 and IPv6 localhost aliases
+127.0.0.1  localhost
+::1        localhost
+
+#
+# Imaginary network.
+#10.0.0.2               myname
+#10.0.0.3               myfriend
+#
+# According to RFC 1918, you can use the following IP networks for private 
+# nets which will never be connected to the Internet:
+#
+#       10.0.0.0        -   10.255.255.255
+#       172.16.0.0      -   172.31.255.255
+#       192.168.0.0     -   192.168.255.255
+#
+# In case you want to be able to connect directly to the Internet (i.e. not 
+# behind a NAT, ADSL router, etc...), you need real official assigned 
+# numbers.  Do not try to invent your own network numbers but instead get one 
+# from your network provider (if any) or from your regional registry (ARIN, 
+# APNIC, LACNIC, RIPE NCC, or AfriNIC.)
+#

 * (1 of 2) -- /etc/hosts

Sélectionnez une action de configuration : (Supprimer le nouveau[z]/Utiliser le nouveau[u]/Suivant[n]): 
--- /etc/conf.d/apmd    2017-10-04 15:42:42.000000000 +0200
+++ /etc/conf.d/._cfg0000_apmd  2018-11-16 09:43:27.970039137 +0100
@@ -1,4 +1,3 @@
  # /etc/init.d/apmd:
-# $Id$

 APMD_OPTS="-P /etc/apm/apmd_proxy"

 * (2 of 2) -- /etc/conf.d/apmd

Sélectionnez une action de configuration : (Supprimer le nouveau[z]/Utiliser le nouveau[u]/Suivant[n]): 
Mise à jour des paquets
 * Calcul des dépendances ...                                                                                                                           [ ok ]
[binary  NS    ] dev-lang/spidermonkey-52.9.1_pre1:52::gentoo [1.8.5-r6:0/mozjs185::gentoo] USE="system-icu -custom-cflags -custom-optimization -debug -minimal -test" 7253 KiB
[binary     U  ] app-text/hunspell-1.6.2-r1:0/1.6::gentoo [1.6.1-r1:0/1.6::gentoo] USE="ncurses nls readline -static-libs" L10N="bg cs da de de-1901 en es et fr hr hu it kk lt lv nl pl pt pt-BR ro ru sk sl sq sv uk -af -ca -cy -el -eo -fo -ga -gl -he -ia -id -is -km -ku -mi -mk -ms -nb -nn -sw -tn -zu" 397 KiB
[binary  N     ] sys-power/powermgmt-base-1.31::gentoo  USE="(-pm-utils)" 0 KiB
[binary     U  ] sys-apps/keyutils-1.5.11-r1:0/1.7::gentoo [1.5.10-r1:0/1.6::gentoo] USE="-static -static-libs -test" ABI_X86="(64) -32 (-x32)" 108 KiB
[binary  N     ] sys-power/pm-utils-1.4.1-r7::gentoo  USE="alsa -debug -ntp" VIDEO_CARDS="intel radeon" 0 KiB
[binary     U  ] media-libs/mesa-18.2.5::gentoo [18.2.4::gentoo] USE="classic dri3 egl gallium gbm gles2 llvm lm_sensors vaapi vdpau vulkan xa xvmc -d3d9 -debug -gles1 -opencl -osmesa -pax_kernel -pic (-selinux) -test -unwind -valgrind -wayland" ABI_X86="32 (64) (-x32)" VIDEO_CARDS="i915 i965 intel nouveau r100 r200 r300 r600 radeon radeonsi (-freedreno) (-imx) (-vc4) -virgl (-vivante) -vmware" 36546 KiB
[binary   R    ] x11-base/xorg-server-1.20.3:0/1.20.3::gentoo  USE="glamor ipv6 kdrive suid* udev xorg xvfb -debug -dmx -doc -libressl -minimal (-selinux) -static-libs (-systemd) -unwind -wayland -xcsecurity -xephyr -xnest" 4141 KiB
[binary     U  ] sys-auth/polkit-0.115-r1::gentoo [0.113-r4::gentoo] USE="introspection nls pam -elogind -examples -gtk -jit -kde (-selinux) (-systemd) -test" 234 KiB
[binary   R    ] media-video/mplayer-1.3.0-r5::gentoo  USE="X a52 alsa bidi cddb cdio cdparanoia cpudetection dv dvd dvdnav enca encode faac ftp gif iconv ipv6 jpeg libass live lzo mad mp3 network openal opengl osdmenu png pulseaudio samba sdl shm speex tga theora truetype unicode v4l vcd vdpau vorbis x264 xinerama xscreensaver xv xvid -aalib (-altivec) (-aqua) -bl -bluray -bs2b -debug -dga -doc -dts -dvb -faad -fbcon -ggi -gsm -jack -joystick -ladspa -libcaca -libmpeg2 -lirc -md5sum -mng -nas -nut -oss -pnm -pvr -radio -rar -rtc -rtmp (-selinux) -toolame -tremor -twolame (-vidix) -yuv4mpeg -zoran (-xvmc%*)" CPU_FLAGS_X86="3dnow 3dnowext mmx mmxext sse sse2 ssse3" VIDEO_CARDS="-mga (-tdfx)" 2177 KiB
[blocks B      ] sys-power/powermgmt-base[-pm-utils(+)] ("sys-power/powermgmt-base[-pm-utils(+)]" is blocking sys-power/pm-utils-1.4.1-r7)
 * 9 paquets à installer, 50854 KiB à télécharger
Conflict: 1 block (1 unsatisfied)

 * Error: The above package list contains packages which cannot be
 * installed at the same time on the same system.

  (sys-power/powermgmt-base-1.31:0/0::gentoo, binary scheduled for merge) pulled in by
    >=sys-power/powermgmt-base-1.31 required by (sys-apps/apmd-3.2.2_p14-r1:0/0::gentoo, installed)

  (sys-power/pm-utils-1.4.1-r7:0/0::gentoo, binary scheduled for merge) pulled in by
    sys-power/pm-utils required by (sys-auth/consolekit-1.2.1:0/0::gentoo, installed)

For more information about Blocked Packages, please refer to the following
section of the Gentoo Linux x86 Handbook (architecture is irrelevant):

https://wiki.gentoo.org/wiki/Handbook:X86/Working/Portage#Blocked_packages
 * Emerge a échoué
 * Mise à jour échouée

calculate /home/jfrancois # emerge -C sys-apps/apmd-3.2.2_p14-r1

 * This action can remove important packages! In order to be safer, use
 * `emerge -pv --depclean <atom>` to check for reverse dependencies before
 * removing packages.

 sys-apps/apmd
    selected: 3.2.2_p14-r1 
   protected: none 
     omitted: none 

All selected packages: =sys-apps/apmd-3.2.2_p14-r1

>>> 'Selected' packages are slated for removal.
>>> 'Protected' and 'omitted' packages will not be removed.

>>> Waiting 5 seconds before starting...
>>> (Control-C to abort)...
>>> Unmerging in: 5 4 3 2 1
>>> Unmerging (1 of 1) sys-apps/apmd-3.2.2_p14-r1...

 * IMPORTANT: 9 news items need reading for repository 'gentoo'.
 * Use eselect news read to view new items.

eix powermgmt
si je fait la mise a jour ici le powermgmt va s’installer on refuse l’installation en ajoutant la ligne >=sys-power/powermgmt-base-1.31 dans le fichier calculate /home/jfrancois # vi /etc/portage/package.mask/custom
ensuite on interroge de nouveau la commande
eix powermgmt

* sys-power/powermgmt-base
     Available versions:  [m]1.31{tbz2} {+pm-utils}
     Homepage:            http://packages.debian.org/testing/utils/powermgmt-base
     Description:         Script to test whether computer is running on AC power

powermgmt-base 1.31 et masquer option [m]

on ajoute au fichier /etc/portage/package.mask/custom
la ligne
<=sys-power/pm-utils-1.4.1-r7
pour forcé l’installation de la version pm-utils-1.4.1-r6 (la révision 6)
et on interroge EIX

calculate /home/jfrancois # eix pm-utils
* sys-power/pm-utils
     Available versions:  1.4.1-r6 [m]1.4.1-r7{tbz2} {alsa debug ntp VIDEO_CARDS="intel radeon"}
     Homepage:            https://pm-utils.freedesktop.org/
     Description:         Suspend and hibernation utilities

* sys-power/upower-pm-utils
     Available versions:  [M]0.9.23-r2 {+introspection ios KERNEL="FreeBSD linux"}
     Homepage:            https://upower.freedesktop.org/
     Description:         The upstream upower 0.9 git branch for use with sys-power/pm-utils

Found 2 matches

la version r6 n’es pas masquer mais la version r7 est masqué
ensuite on fait
cl-update

Synchronisation des dépôts
 * Checking current binhost ...                                                                                                                         [ ok ]
 * Checking Distros updates ...                                                                                                                         [ ok ]
 * Checking Calculate updates ...                                                                                                                       [ ok ]
 * Checking Gentoo updates ...                                                                                                                          [ ok ]
 * Synchronisation terminée
Configuration système
 * Update server http://miroir.linuxtricks.fr/calculate
Mise à jour des paquets
 * Calcul des dépendances ...
 * Liste des paquets à installer  
 * Hunspell spell checker - an improved replacement for myspell in OOo (U) app-text/hunspell-1.6.2-r1 (397 KiB)
 * Stand-alone JavaScript C++ library (NS) dev-lang/spidermonkey-52.9.1_pre1 (7253 KiB)
 * OpenGL-like graphic library for Linux (U) media-libs/mesa-18.2.5 (36546 KiB)
 * Media Player for Linux (rR) media-video/mplayer-1.3.0-r5 (2177 KiB)
 * Linux Key Management Utilities (U) sys-apps/keyutils-1.5.11-r1 (108 KiB)
 * Policy framework for controlling privileges for system-wide services (U) sys-auth/polkit-0.115-r1 (234 KiB)
 * Suspend and hibernation utilities (N) sys-power/pm-utils-1.4.1-r6 (204 KiB)
 * X.Org X servers (rR) x11-base/xorg-server-1.20.3 (4141 KiB)
 * 8 paquets à installer, 51057 KiB à télécharger

Voulez-vous installer ces paquets ? (Yes/No): yes
 * Récupération de paquets binaires ...                                                                                                                 [ ok ]
 *  (1 sur 8) Stand-alone JavaScript C++ library
 * Compilation de dev-lang/spidermonkey-52.9.1_pre1 ...                                                                                                 [ ok ]
 *  (2 sur 8) Hunspell spell checker - an improved replacement for myspell in OOo
 * Compilation de app-text/hunspell-1.6.2-r1 ...                                                                                                        [ ok ]
 * Installation de app-text/hunspell-1.6.2-r1 [1.6.1-r1] ...                                                                                            [ ok ]
 * Installation de dev-lang/spidermonkey-52.9.1_pre1 [1.8.5-r6] ...                                                                                     [ ok ]
 *  (3 sur 8) Linux Key Management Utilities
 * Compilation de sys-apps/keyutils-1.5.11-r1 ...                                                                                                       [ ok ]
 *  (4 sur 8) Suspend and hibernation utilities
 * Compilation de sys-power/pm-utils-1.4.1-r6 ...                                                                                                       [ ok ]
 * Installation de sys-apps/keyutils-1.5.11-r1 [1.5.10-r1] ...                                                                                          [ ok ]
 * Installation de sys-power/pm-utils-1.4.1-r6 ...                                                                                                      [ ok ]
 *  (5 sur 8) OpenGL-like graphic library for Linux
 * Compilation de media-libs/mesa-18.2.5 ...                                                                                                            [ ok ]
 * Installation de media-libs/mesa-18.2.5 [18.2.4] ...                                                                                                  [ ok ]
 *  (6 sur 8) X.Org X servers
 * Compilation de x11-base/xorg-server-1.20.3 ...                                                                                                       [ ok ]
 *  (7 sur 8) Policy framework for controlling privileges for system-wide services
 * Compilation de sys-auth/polkit-0.115-r1 ...                                                                                                          [ ok ]
 * Installation de x11-base/xorg-server-1.20.3 ...                                                                                                      [ ok ]
 * Installation de sys-auth/polkit-0.115-r1 [0.113-r4] ...                                                                                              [ ok ]
 *  (8 sur 8) Media Player for Linux
 * Compilation de media-video/mplayer-1.3.0-r5 ...                                                                                                      [ ok ]
 * Installation de media-video/mplayer-1.3.0-r5 ...                                                                                                     [ ok ]
Suppression des paquets devenus inutiles
 * Calcul des dépendances ...
 * Liste des paquets à supprimer  
 * Stand-alone JavaScript C++ library dev-lang/spidermonkey-1.8.5-r6
 * Virtual for awk implementation virtual/awk-1
 * A gtk+ frontend for libgksu x11-libs/gksu-2.0.2-r2
 * A library for integration of su into applications x11-libs/libgksu-2.0.12-r4

Would you like to unmerge these unused packages (recommended)? (Yes/No): yes
 * Suppression de  (1 sur 4) dev-lang/spidermonkey-1.8.5-r6 ...                                                                                         [ ok ]
 * Suppression de  (2 sur 4) virtual/awk-1 ...                                                                                                          [ ok ]
 * Suppression de  (3 sur 4) x11-libs/gksu-2.0.2-r2 ...                                                                                                 [ ok ]
 * Suppression de  (4 sur 4) x11-libs/libgksu-2.0.12-r4 ...                                                                                             [ ok ]
Recompilation des modules dépendants
 * Mise à jour des modules du serveur X.Org ...                                                                                                         [ ok ]
 * Récupération de paquets binaires ...                                                                                                                 [ ok ]
 *  (1 sur 15) X.Org driver for mouse input devices
 * Compilation de x11-drivers/xf86-input-mouse-1.9.3 ...                                                                                                [ ok ]
 * Installation de x11-drivers/xf86-input-mouse-1.9.3 ...                                                                                               [ ok ]
 *  (2 sur 15) Keyboard input driver
 * Compilation de x11-drivers/xf86-input-keyboard-1.9.0 ...                                                                                             [ ok ]
 * Installation de x11-drivers/xf86-input-keyboard-1.9.0 ...                                                                                            [ ok ]
 *  (3 sur 15) X.Org driver for Intel cards
 * Compilation de x11-drivers/xf86-video-intel-2.99.917_p20180214-r1 ...                                                                                [ ok ]
 * Installation de x11-drivers/xf86-video-intel-2.99.917_p20180214-r1 ...                                                                               [ ok ]
 *  (4 sur 15) VMware SVGA video driver
 * Compilation de x11-drivers/xf86-video-vmware-13.3.0 ...                                                                                              [ ok ]
 * Installation de x11-drivers/xf86-video-vmware-13.3.0 ...                                                                                             [ ok ]
 *  (5 sur 15) Nvidia 2D only video driver
 * Compilation de x11-drivers/xf86-video-nv-2.1.21 ...                                                                                                  [ ok ]
 * Installation de x11-drivers/xf86-video-nv-2.1.21 ...                                                                                                 [ ok ]
 *  (6 sur 15) Generic Linux input driver
 * Compilation de x11-drivers/xf86-input-evdev-2.10.6 ...                                                                                               [ ok ]
 * Installation de x11-drivers/xf86-input-evdev-2.10.6 ...                                                                                              [ ok ]
 *  (7 sur 15) ATI video driver
 * Compilation de x11-drivers/xf86-video-ati-18.1.0 ...                                                                                                 [ ok ]
 * Installation de x11-drivers/xf86-video-ati-18.1.0 ...                                                                                                [ ok ]
 *  (8 sur 15) VirtualBox guest video driver
 * Compilation de x11-drivers/xf86-video-vboxvideo-1.0.0 ...                                                                                            [ ok ]
 * Installation de x11-drivers/xf86-video-vboxvideo-1.0.0 ...                                                                                           [ ok ]
 *  (9 sur 15) X.org input driver based on libinput
 * Compilation de x11-drivers/xf86-input-libinput-0.28.1 ...                                                                                            [ ok ]
 * Installation de x11-drivers/xf86-input-libinput-0.28.1 ...                                                                                           [ ok ]
 *  (10 sur 15) QEMU QXL paravirt video driver
 * Compilation de x11-drivers/xf86-video-qxl-0.1.5 ...                                                                                                  [ ok ]
 * Installation de x11-drivers/xf86-video-qxl-0.1.5 ...                                                                                                 [ ok ]
 *  (11 sur 15) Driver for Synaptics touchpads
 * Compilation de x11-drivers/xf86-input-synaptics-1.9.1 ...                                                                                            [ ok ]
 * Installation de x11-drivers/xf86-input-synaptics-1.9.1 ...                                                                                           [ ok ]
 *  (12 sur 15) Accelerated Open Source driver for nVidia cards
 * Compilation de x11-drivers/xf86-video-nouveau-1.0.15-r1 ...                                                                                          [ ok ]
 * Installation de x11-drivers/xf86-video-nouveau-1.0.15-r1 ...                                                                                         [ ok ]
 *  (13 sur 15) X.Org driver for VIA/S3G cards
 * Compilation de x11-drivers/xf86-video-openchrome-0.6.0 ...                                                                                           [ ok ]
 * Installation de x11-drivers/xf86-video-openchrome-0.6.0 ...                                                                                          [ ok ]
 *  (14 sur 15) Accelerated Open Source driver for AMDGPU cards
 * Compilation de x11-drivers/xf86-video-amdgpu-18.1.0 ...                                                                                              [ ok ]
 * Installation de x11-drivers/xf86-video-amdgpu-18.1.0 ...                                                                                             [ ok ]
 *  (15 sur 15) Generic VESA video driver
 * Compilation de x11-drivers/xf86-video-vesa-2.4.0 ...                                                                                                 [ ok ]
 * Installation de x11-drivers/xf86-video-vesa-2.4.0 ...                                                                                                [ ok ]
 * Mise à jour des bibliothèques réservées ...                                                                                                          [ ok ]
 * Mise à jour des fichiers de configuration ...                                                                                                        [ ok ]
 * Votre système a bien été mis à jour !

on commente la ligne #<=sys-power/pm-utils-1.4.1-r7 dans le fichier
calculate /home/jfrancois # vi /etc/portage/package.mask/custom
et on refait un cl-update

Synchronisation des dépôts
 * Checking current binhost ...                                                                                                                         [ ok ]
 * Checking Distros updates ...                                                                                                                         [ ok ]
 * Checking Calculate updates ...                                                                                                                       [ ok ]
 * Checking Gentoo updates ...                                                                                                                          [ ok ]
 * Synchronisation terminée
Configuration système
 * Update server http://miroir.linuxtricks.fr/calculate
Mise à jour des paquets
 * Calcul des dépendances ...
 * Liste des paquets à installer  
 * Suspend and hibernation utilities (U) sys-power/pm-utils-1.4.1-r7 (0 KiB)
 * 1 paquets à installer, 0 KiB à télécharger

Voulez-vous installer ces paquets ? (Yes/No): yes
 *  (1 sur 1) Suspend and hibernation utilities
 * Compilation de sys-power/pm-utils-1.4.1-r7 ...                                                                                                       [ ok ]
 * Installation de sys-power/pm-utils-1.4.1-r7 [1.4.1-r6] ...                                                                                           [ ok ]
Suppression des paquets devenus inutiles
 * Calcul des dépendances ...                                                                                                                           [ ok ]
Recompilation des modules dépendants
 * Mise à jour des bibliothèques réservées ...                                                                                                          [ ok ]
 * Mise à jour des fichiers de configuration ...                                                                                                        [ ok ]
 * Votre système a bien été mis à jour !

voilà c’est fini la mise a jour du systeme est faite
merci calculate merci a tous
on en apprend tout les jours
CONCLUSION:
les logiciels
powermgmt-base 1.31 et pm-utils-1.14.1-r7 gère tout les deux la mise et la sortie du mode hibernation d’où le conflit a moins d’y faire erreur
si des esprits plus DOC peuvent me le confirmer ou me corriger un grand MERCI!

Mastodon Mastodon