eclipse 3.7

Почему eclipse 3.7 нету в портажах? Даже нестабильной версии?

Потому что никто не написал для него ebuild
Настоятельно предлагаю вам написать самому, получится - отсылайте разрабам gentoo.

Или просто качайте с оффсайта интсляшку и ставьте из под юзера в ~/.local, благо eclipse это позволяет.

Ебилд для данной версии есть в оверлее seden

Тогда проверьте его работоспособность.
Если все ок, то поищите в bugs.gentoo.org eclipse-3.7, если пока никто не писал, то напишите мантейнерам gentoo об этом и приложите ebuild.