Calculate Forum

Если не включается програмное микширование (dmix) через ALSA...

:http://harzah.ru/sites/default/files/filefield_images/10_00.jpg В Calculate уже на протяжении многих выпусков не включается автоматом программное микширование, если звуковая карта не поддерживает аппаратное (что ALSA уже давно умеет). Не знаю по какой причине этого не происходит, но из-за этого многие переходят на Pulseaudio (так как действительно неудобно каждый раз перед проигрыванием песни или видео на youtube смотреть, чтобы звук у тебя не был занят скайпом, например), хотя нужно всего лишь поместить в .asoundrc

pcm.!default { 
    type plug 
    slave.pcm "dmixer" 
} 

pcm.dsp0 { 
    type plug 
    slave.pcm "dmixer" 
} 

pcm.dmixer  { 
    type dmix 
    ipc_key 1024 
    slave { 
        pcm "hw:0,0" 
        period_time 0 
        period_size 1024 
        buffer_size 8192 
        rate 44100 
    } 
    bindings { 
        0 0 
        1 1 
    } 
} 

ctl.mixer0 { 
    type hw 
    card 0 
}

И в результате dmix будет работать, нужно все настройки у плееров переставить на default или alsa (без уточнений с какой именно картой), а в настройках alsa.conf выбрать очерёдность карты так, чтобы нужная была первой. Если при этом используется ещё и HDMI тем же модулем, то это тоже решаемая задача:

options snd-hda-intel index=0,1 
options snd-usb-audio index=2

Здесь первые два - это (у меня, например) NVidia HDMI и встроенная Intel Realtek (которая и используется по умолчанию). Последняя - это usb-микрофон, который можно отдельно указать в скайпе. В результате всех этих немногих настроек, мы имеем тоже самое, что и в Pulseaudio, только без задержек, без падения сервера и без необходимости слушать звук с постоянными проблемами (например в играх он звучал у меня просто ужасно).

Из моей личной памятки по Calculate Linux:
Чтобы посмотреть, какой у вас порядок звуковых карт, используем команду: cat /proc/asound/cards
Чтобы посмотреть загруженные модули ядра для звука используем под рутом: lsmod | grep snd
И далее идём для настроек в /etc/modprobe.d/alsa.conf

Пасибоу! Буду пробовать, есть такая проблемка.

Mastodon Mastodon