Calculate Forum

compilation webkit-gtk impossible (résolu)

Je signale un souci de compilation de webkit-gtk : elle Ă©choue toujours au mĂŞme stade :
DerivedSources/WebCore/libWebCore_la-JSDOMWindow.lo

Salut,

Sur Calculate, tu n’es pas sensé la compiler :

[binary   R    ] net-libs/webkit-gtk-1.8.3-r300

Tu peux nous en dire un peu plus, dans quel cadre tu souhaites l’installer par exemple ?

Merci

XKomodor | Julien

webkit est nécessaire pour l’install de jumanji et autre midori par exemple.

Je vais suivre ton conseil et installer directement le binaire.

Cordialement

Salut,

Si je suis bien, tu es sous CLS alors ?

Effectivement Webkit-GTK comme la version QT n’est pas préinstallée d’où mon “étonnement”.

Merci

XKomodor | Julien

ouaip.
Et je ne parviens pas à le compiler sous mon vieux p4 : ça plante toujours au même endroit.
Je retente une install propre, toujours Ă  parti de CLS.
Je te tiens au courant.

Cordialement

Davidvs

Salut,

Combien de place sur le disque, les partitions ?

df -h

Surtout il faudrait que tu nous donnes l’erreur de sortie : on “travaille” en aveugle là.

Merci

XKomodor | Julien

Si je puis intervenir :slight_smile: parce qu’on le discutait aussi sur le chan.

Ce qui est étrange aussi, c’est que David n’arrive pas à installer un Webkit binaire en changeant de profil !

Pour ma part, j’ai eu plusieurs fois affaire à webkit-gtk qui plantait à la compilation, mais c’était toujours à cause de CFLAGS trop agressifs … une fois le make.conf corrigé, le paquet s’installait. Cependant ça ne semble pas être le cas ici, à moins que les USE n’aient été modifiés.

Salut,

Ha … dans ce cas, pas la peine de toucher au profile … Tu n’aurais tout simplement pas changer le BINHOST dans le make.conf ?

Si c’est le cas, commente toutes les lignes en question de façon à utiliser le BINHOST par défaut.

Merci

XKomodor | Julien

C’est moi qui ai besoin d’explication alors (mais ça servira à la communauté tout aussi bien j’espère) …

Comment arrive-t-on à installer un binaire qui ne figure pas parmi les paquets du profil (on parle toujours de CLS) si ce n’est en changeant celui-ci ? Et si on modifiait le binhost, ça ne reviendrait donc pas au même ?

Je ne pense pas que l’auteur du post ait modifié quoi que ce soit dans le make.conf, d’ailleurs.

bon, je suis reparti d’une cls vierge :
toute fraîchement installée, sans même faire un eix-sync, j’ai changé le profil vers cldx binaire et là j’ai fait eix-sync.
Je vérifie webkit-gtk via eix, et on ne me propose toujours pas de binaire (comme d’hab’). Je lance malgré tout emerge webkit-gtk et là, le binaire s’installe tout seul, sans prévenir, sans compilation donc :-/ et sans souci. A ne rien y comprendre…
Je confirme ce que disait Eléna, il n’y avait aucune modif particulière dans la CLS précédente.

Salut,

Faudrait que tu fasses un tour sur IRC dans ce cas en utilisant le canal #calculate-fr / Serveur Freenode pour que nous puissions en discuter plus facilement puis poster ici le résultat final pour avoir un suivi.

Merci

XKomodor | Julien

ok, dès que j’ai 2’ ;-))

Cordialement

Bon, avec l’aide de XKomodor, on peut dire que le souci initial était lié à la base du dépôt FR de CLS. Donc pb réglé avec le gel de celui-ci…
Si tu as quelque chose à ajouter à ce propos XKomodor…

Je mets en résolu

Salut,

Rien de particulier … Il faut que je vois pourquoi cela pose “problème”.

Merci

XKomodor | Julien

For proper compilation, you need a better-integrated development kit and get information about it from kaspersky antivirus error 1922

Mastodon Mastodon