Calculate Forum

Clock in KDE doesn't set automatically to network time

I tried configuring the clock in KDE. IT’s set to pool.ntp.org, but it doesn’t set the clock. Unticking the “Set date and time automatically” and reticking the box presents a dialog box that won’t take my root password (“Unable to authenticate the action: 4,”). I installed rdate, as the Help Center advised; doesnt’ work either.

The same situation as in the latest Kali 2020.1 based on Debian. Does not accept password in KDE-plasma environment. I gave up automatically updating my watch. Most likely a bug in KDE and plus Calculate and not accepting GUI setups

This command works to set the clock # rc-service ntp-client start but # rc-update add ntp-client doesn’t work, so how do you invoke the first command at startup? (A start-up script, I would think.)

It might help
https://wiki.gentoo.org/wiki/Ntp

Add ntpd to the default runlevel to have the time synchronized automatically. There is no need to run a client when the service is running. In this case verify that ntp-client or ntpdate are not in any runlevels.

root # rc-update

When it is confirmed the configuration is clear from ntp-client or ntpdate, add the ntpd service:

root # rc-service ntpd start

root # rc-update add ntpd default

To monitor status of the server:

root # rc-service ntpd status

it may be bad typed

rc-update add ntp-client

should like this

rc-update add ntp-client default

Yep, I did that (used default so it wasn’t a typo), tried ntpd, then chrony. None worked as far as I know. (To test, I purposely mis-set the Kde clock, then rebooted and the time wasn’t corrected, although the ntpd or chrony services were started). Is there an error log? Didn’t see any obvious log in /var/log.

This is ridiculous, I set a deliberate time from the plasma set, wrong ntpd. Restarted the machine and nothing. When I started the system setting of the plasma in the language settings and the clock setting it happened that then ntpd corrected the time on the clock at the right time. Trying to remember it automatically by using a time server is futile because the setup asks for a password and then does not accept the password

Uh, I changed in this file and put ntpd and now it doesn’t work for time correction from system setup in plasma. I didn’t write down what the word was instead of the ntpd
# /etc/conf.d/ntp-client

Command to run to set the clock initially

Most people should just leave this line alone …

however, if you know what you’re doing, and you

want to use ntpd to set the clock, change this to ‘ntpd’

NTPCLIENT_CMD="ntpd"

There is something wrong with KDE auto-updating time. I uninstalled NTP and installed openntpd. There is nothing else that can be done with automatic updating through KDE setups. I typed this command and it turns out that openntpd updates the time.
If I set the wrong time it won’t correct it, it just corrects the time that was set. I have set UTC and if I hit UTC +00 on UTC -01 it will not correct to UTC +00.

ntpctl -s all
8/12 peers valid, clock synced, stratum 3

peer
wt tl st next poll offset delay jitter
162.159.200.1 from pool 0.gentoo.pool.ntp.org
1 10 3 33s 33s 225.963ms 2.935ms 1.173ms
195.178.58.245 from pool 0.gentoo.pool.ntp.org

My file says: NTPCLIENT_CMD=“ntpdate”

Thanks, in the meantime the update restored everything to the old, I no longer know what is being updated with the creation of the same file and clt extension and what is normally updated. The KDE placement is a nightmare, Plasma-based update, nest system accepts missing seas via .clt. KDE-plasma can’t just be overwritten and applied to Gentoo and Calculate bass because of the updates that have to go through the .clt file. Other distros do not differentiate between GUI plasma setups, everything is the same as with CLI. This over time server is already too complicated, one distro does not ask for password at all in KDE and Calcualte is looking for it.

© 2007-2020 Calculate Ltd.
Mastodon Mastodon