Cl-update Assistance

Hi All,

I have been a Calculate Linux user for the last 5 years. In all that time cl-update has never failed an update. However that run of good luck has now ended.

The following error messages indicate that cl-update has failed on an update to my cldl (lxqt) system.

I would appreciate any suggestions on how to resolve these problems given I am not a calculate (gentoo) internals expert.

cl-update output below …

ik3@calculate ~ $ sudo cl-update

Updating packages

  • Calculating dependencies … [ ok ]

(dev-libs/icu-72.1:0/72.1::gentoo, installed) USE=“userland_GNU -debug -doc -examples -static-libs -test -verify-sig” ABI_X86=“32 (64) (-x32)” pulled in by
dev-libs/icu:0/72.1= required by (dev-qt/qtcore-5.15.9:5/5.15.9::gentoo, installed) USE=“icu userland_GNU -debug -old-kernel (-systemd) -test” ABI_X86=“(64)”

(and 1 more with the same problem)

NOTE: Use the ‘–verbose-conflicts’ option to display parents omitted above

!!! The slot conflict(s) shown above involve package(s) which may need to
!!! be rebuilt in order to solve the conflict(s). However, the following
!!! package(s) cannot be rebuilt for the reason(s) shown:

(dev-qt/qtnetwork-5.15.9:5/5.15::gentoo, installed): ebuild is masked or unavailable
(dev-qt/qtcore-5.15.9:5/5.15.9::gentoo, installed): ebuild is masked or unavailable

It may be possible to solve this problem by using package.mask to
prevent one of those packages from being selected. However, it is also
possible that conflicting dependencies exist such that they are
impossible to satisfy simultaneously. If such a conflict exists in
the dependencies of two different packages, then those packages can
not be installed simultaneously.

For more information, see MASKED PACKAGES section in the emerge man
page or refer to the Gentoo Handbook.

emerge: there are no ebuilds built with USE flags to satisfy “dev-python/pycryptodome[python_targets_python3_10(-)]”.
!!! One of the following packages is required to complete your request:

  • dev-python/pycryptodome-3.18.0::gentoo (Change USE: +python_targets_python3_10)
    (dependency required by “net-misc/youtube-dl-2021.12.17-r1::gentoo” [installed])
    (dependency required by “@selected” [set])
    (dependency required by “@world” [argument])
  • Emerge failed
  • Update failed

The problem may be in the already superseded “Python 3.10”?

You can also find package dependencies:
equery d --indirect dev-python/pycryptodome

And maybe reinstall it.

Alternatively, remove the “net-misc/youtube-dl-2021.12.17-r1” package, then update the system, then, for example, install the “net-misc/yt-dlp” package.