cl-passwd issue?

I have a problem my CDS is 10.2 (2.1.10) and my CLDG (2.1.17-r1) is 10.4.
My CLDG ldap users can’t change their passwords when i do cl-passwd,It shows like password

  • Changed password of user 25773 … [ ok ]
  • Password will be changed when you logout from the X session

But doesn’t take effect when logged out and logged in back.
Tried restarting, domain out and rejoining the domain.
Tried on CDS cl-update samba.Still no luck,Do you know what problem could be?

On investigating further ,on client it shows Password updated and logout from x session , but it never updates the same on CDS?
Please help:)


Try install last version of calculate-server. (2.1.12-r1)
After install calculate-server package perform command:

cl-update samba

Hi Mike

Thanks for your reply, But the same server with same version was working fine before,May be i need to change something in file configurations.?
Main problem it shows password is updated on client side , but doesn’t really updates on server.

Also if i go updating the server to 2.1.12-r1, Will that change any configurations on my CDS.
Will my users be affected.?
In snapshot what all file changes will happen on CDS, Is there any other way by which i can enable this feature as before :slight_smile: Your kind reply will help me a lot:))


2.1.17 version of calculate-client not support change password in calculate-server 2.1.10, because algorithm was changed. Configuration of samba will not changed.
If you afraid of configuration changing, then you can backup settings of server:


Then update calculate-server package to 2.1.12-r1 and perform

cl-update samba

If something was working bad, you can install calculate-server-2.1.10-r1 and restore old configuration

cl-backup -r

Thanks Mike ,It’s now working fine as i have upgraded my Server as recommended by you.
Thanks for Support,