Calculate Forum

Chromium последняя версия на сегодня не загружает картинки в интернет

Доброго времени суток!

Вчера обновил браузер Chromium, и больше не могу пользоваться серверами imgur и тому подобными. Ни через выбор файла, ни через перетаскивание файла.

Скажите пожалуйста, как я могу откатиться к предыдущей версии браузера?

Я сделал так: echo “<=www-client/chromium-87.0.4280.88” > /etc/portage/package.mask/custom

И дальше:

emerge --ask chromium
setlocale: unsupported locale setting
setlocale: unsupported locale setting

Вот как раз сообщение насчёт проблем с локалями из предыдущего топика!

These are the packages that would be merged, in order:

Calculating dependencies… done!
[ebuild U ~] dev-libs/icu-68.2 [67.1]
[ebuild U ~] www-client/chromium-88.0.4324.50 [87.0.4280.88]

!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

dev-libs/icu:0

(dev-libs/icu-68.2:0/68.2::gentoo, ebuild scheduled for merge) USE="-debug -doc -examples -static-libs" ABI_X86=“32 (64) (-x32)” pulled in by
>=dev-libs/icu-68.1:= required by (www-client/chromium-88.0.4324.50:0/0::gentoo, ebuild scheduled for merge) USE=“cups hangouts js-type-check (pic) proprietary-codecs pulseaudio suid system-ffmpeg system-icu tcmalloc vaapi wayland widevine (-component-build) -custom-cflags (-headless) -kerberos -official (-selinux)” ABI_X86="(64)" L10N=“am ar bg bn ca cs da de el en-GB es es-419 et fa fi fil fr gu he hi hr hu id it ja kn ko lt lv ml mr ms nb nl pl pt-BR pt-PT ro ru sk sl sr sv sw ta te th tr uk vi zh-CN zh-TW”
^^ ^^^^

(dev-libs/icu-67.1:0/67.1::gentoo, installed) USE="-debug -doc -examples -static-libs" ABI_X86=“32 (64) (-x32)” pulled in by
>=dev-libs/icu-3.6:0/67.1=[abi_x86_64(-)] required by (dev-libs/boost-1.74.0-r1:0/1.74.0::gentoo, installed) USE=“bzip2 context icu nls python threads zlib zstd -debug -doc -lzma -mpi (-numpy) -static-libs -tools” ABI_X86="(64) -32 (-x32)" PYTHON_TARGETS=“python3_7 python3_8 -python3_6 -python3_9”
^^^^^^^^
(and 16 more with the same problem)

NOTE: Use the ‘–verbose-conflicts’ option to display parents omitted above

It may be possible to solve this problem by using package.mask to
prevent one of those packages from being selected. However, it is also
possible that conflicting dependencies exist such that they are
impossible to satisfy simultaneously. If such a conflict exists in
the dependencies of two different packages, then those packages can
not be installed simultaneously.

For more information, see MASKED PACKAGES section in the emerge man
page or refer to the Gentoo Handbook.

The following keyword changes are necessary to proceed:
(see “package.accept_keywords” in the portage(5) man page for more details)

required by chromium (argument)
=www-client/chromium-88.0.4324.50 ~amd64

required by www-client/chromium-88.0.4324.50::gentoo[system-icu]

required by @selected

required by @world (argument)
=dev-libs/icu-68.2 ~amd64

Would you like to add these changes to your config files? [Yes/No]

Чтобы я понимал что всё это значит… Понимаю что какие-то пакеты конфликтуют, понимаю что система сама просит изменения внести в конфиги какие-то. Больше ничего не понимаю. Правильно ли я сделал, какие шаги дальше предпринимать?

Только что попытался загрузить на форум в этот топик скрин с пк, получил ошибку:

Код ошибки: RESULT_CODE_KILLED_BAD_MESSAGE

О чём и писал выше. С любым сайтом так при попытке загрузки изображения. Может и других вайлов. Зачем выпускать новую версию браузера, если она кривая?

Неверно сформирована строка маскировки. Надо не <= текущей версии, а >=.

© 2007-2020 Calculate Ltd.
Mastodon Mastodon