Calculate Forum

Changement de session figer sous MATE

Bonjour à tous,
Lors d’un changement de session sans fermer celle en cours, Calculate fige.
Pareil quand je veux passer en tty.

Salut,
Quelle est la config matérielle que tu as ? (notamment la carte graphique?)
Merci

Salut
J’ai une NVIDIA Corporation GK107 [GeForce GTX 650]
Carte mère Gigabytes socket AM3+
Avec un AMD FX ™-6300 Six-Core Processeur
Pilotes propriétaire installé pour CG

J’ai 12Go de RAM
j’ai vu que je n’avais pas de swap
j’en ai un qui est commun à une autre distribution qui est installé sur un autre disque
je l’ai activer en faisant swapon /dev/sda2
Et j’ai fait un essai de passer en tty, c’est bon çà marche.
Mais par contre, revenir en mode graphique çà fige, plus d’accés au clavier.
J’ai modifier mon fstab et en plaçant le bon UUID au bon endroit.
J’ai redémarrer mais cela ne change rien.
Mon swap est de 20 Go
Donc pour résumer le swap à permis de passer en tty.

Salut,

OK pour la configuration.
Je ne pense pas que l’absence de swap soit la cause du freeze.

Une fois que ça fige, il ne se passe plus rien du tout et donc tu éteins avec le bouton le PC ?

Si Oui, quand ça fige, essaie d’attendre quelques minutes. Au redémarrage, il faudrait consulter le fichier /var/log/messages (au besoin le copier sur un pastebin) pour voir s’il n’y a pas une erreur assez parlante.
Et pourquoi pas les dernières lignes du fichier /var/log/kern.log

Le problème est assez étrange, et je ne vois pas trop où chercher…

A noter que l’interface graphique, c’est CTRL+ALT+F7 chez moi, pas F1.

Voici j’ai fais plusieurs fois le changement de session en repèrant l’heure à laquelle je l’ai fait.
L’erreur qui reviens tout le temps est la suivant:
https://pastebin.com/3qqpMupU

C’est un extrait du /var/log/messages

OK, j’ai une petite idée, j’ai besoin de plus de précisions…

Que renvoie la commande

eix nvidia-drivers

pour voir quelle version des pilote est installée chez toi ?

voici ce que cela retourne
https://pastebin.com/901BFy6M

!!

Capture_du_2017-12-20_19-33-09.png

Comme vu oralement, voir si rétrograder les pilotes règlent le problème (en passant sur le 375.82 au lieu du 387.22)

J’ai rétrograder le pilote graphique à la version 375.82, mais au reboot, tout ce charge puis s’arrête sur un fond d’écran d’orage avec le curseur en haut à gauche qui clignote.
Le clavier répond car je peux passer en console tty.
J’ai essayer de stopper le service xdm et et le relance mais le retour de la commande me dit qu’il est déjà lancé.

OK
Donc retourner dans le package.mask/custom et supprimer la ligne nvidia pour installer la dernière version.

Avant de faire un cl-update, essaie de désactiver les splash (ces écrans qui sont dur fond d’image) :

Editer le fichier /etc/default/grub
Editer GRUB_CMDLINE_LINUX=
Remplacer splash=theme:calculate par splash=off

regénérer grub :

grub-mkconfig -o /boot/grub/grub.cfg

Faire une mise à jour avec cl-update

Si cl(update dit que le fichier /etc/default/grub a été modifié, mets “z” pour ne pas utiliser le nouveau fichier de configuration (et conserver ta modif du grub)

Tester de rebooter.

Salut Adrien,
J’ai fais comme tu l’a mentionné pour le grub, mais il n’y a pas de changement.

Je pense avoir une idée, j’ai vu quand j’ai configurer un noyau que dans la section Device Graphique une option comme celle qui est mentionné dans mon log messages.
Dec 20 17:19:16 calculate kernel: nvidia-modeset: ERROR: GPU:0: Idling display engine timed out: 0x0000917d:0:0

nvidia-modeset = cette option peut-être activer par défaut dans le noyau de la Calculate. Et que c’est la le problème.
Je pensais là déactivée mais je ne sais pas comment modifier le noyau actuellement installé sur ma machine.

Salut,

alors si c’est modset qui pose soucis, essayer d’ajouter l’option nomodset à GRUB pour désactiver la fonctionnalité dans le noyau :

Editer le fichier /etc/default/grub
Editer GRUB_CMDLINE_LINUX=
Remplacer mettre au bout de la ligne nomodeset

regénérer grub :

grub-mkconfig -o /boot/grub/grub.cfg

Tester de rebooter.

Salut Adrien, aucun changement.
J’ai essayer de différente façon:
nvidia.modeset=0
nvidia nomodeset
nvidia-dkm.modeset=0

sans résultat.

© 2007-2020 Calculate Ltd.
Mastodon Mastodon