Calculate Forum

как обновить cds 17.12.2

cds

#1

помогите обновить cds с версии 17.12.2
если обновлять просто emerge -upgrade то затыкается на маскировках EAPI 7:
пробую простым cl-update:

mail / # cl-update
Синхронизация репозиториев
 * Проверка текущего сервера обновлений ...               [ ok ]
 * Проверка обновлений Distros ...                                [ ok ]
 * Проверка обновлений Calculate ...                             [ ok ]
 * Проверка обновлений Gentoo ...                                [ ok ]
 * Обновление индекса пакетов ...                                [ ok ]
 * Проверка подписи индекса пакетов ...                       [ ok ]
 * Синхронизация завершена
Конфигурация системы
 * Сервер обновлений ftp://ftp.mtu.ru/pub/calculate-linux
 * Исправление настроек ...                                                                                                                                                                                                             [ ok ]
 * Обновление конфигурационных файлов ...                                                                                                                                                                                               [ ok ]
Обновление пакетов
 * Вычисление зависимостей ...                                                                                                                                                                                                          [ ok ]

    (and 10 more with the same problem)

  (sys-libs/zlib-1.2.11:0/0::gentoo, installed) pulled in by
    >=sys-libs/zlib-1.2.8-r1:0/0=[abi_x86_64(-)] required by (media-libs/tiff-4.0.8:0/0::gentoo, installed)
                            ^^^^^

NOTE: Use the '--verbose-conflicts' option to display parents omitted above

!!! The slot conflict(s) shown above involve package(s) which may need to
!!! be rebuilt in order to solve the conflict(s). However, the following
!!! package(s) cannot be rebuilt for the reason(s) shown:

  (media-libs/tiff-4.0.8:0/0::gentoo, installed): ebuild is masked or unavailable

It may be possible to solve this problem by using package.mask to
prevent one of those packages from being selected. However, it is also
possible that conflicting dependencies exist such that they are
impossible to satisfy simultaneously.  If such a conflict exists in
the dependencies of two different packages, then those packages can
not be installed simultaneously.

For more information, see MASKED PACKAGES section in the emerge man
page or refer to the Gentoo Handbook.

The following keyword changes are necessary to proceed:
 (see "package.accept_keywords" in the portage(5) man page for more details)
 # required by dev-lang/ruby-2.3.8::gentoo
 # required by @selected
 # required by @world (argument)
=dev-ruby/minitest-5.11.3 ~amd64
 * Выполнение Emerge завершилось с ошибкой
 * Не удалось обновить

#2
(media-libs/tiff-4.0.8:0/0::gentoo, installed): ebuild is masked or unavailable

Портаж ругается на tiff-4.0.8, что он замаскирован или недоступен. На данный момент есть версия tiff-4.0.9-r4, нужно обновиться до неё.

The following keyword changes are necessary to proceed:
 (see "package.accept_keywords" in the portage(5) man page for more details)
 # required by dev-lang/ruby-2.3.8::gentoo
 # required by @selected
 # required by @world (argument)
=dev-ruby/minitest-5.11.3 ~amd64

А здесь говорится, что для продолжения обновления нужно размаскировать версию minitest-5.11.3


#3

строка где minitest постоянно меняется. случайно заметил при повторном запуске, что там ещё 3 разных библиотеки (или программы) пролетают.

спасибо за пояснения, попробую разобраться.


#4

добавились keywords про руби.
теперь картина такая:

 # emerge -u -av @world -t

Local copy of remote index is up-to-date and will be used.

These are the packages that would be merged, in reverse order:

Calculating dependencies... done!

!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

sys-libs/zlib:0

  (sys-libs/zlib-1.2.11:0/0::gentoo, installed) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

  (sys-libs/zlib-1.2.11-r2:0/1::gentoo, binary scheduled for merge) pulled in by
    >=sys-libs/zlib-1.1.3:0/1= required by (dev-lang/python-3.6.5:3.6/3.6m::gentoo, binary scheduled for merge)
                         ^^^^^


It may be possible to solve this problem by using package.mask to
prevent one of those packages from being selected. However, it is also
possible that conflicting dependencies exist such that they are
impossible to satisfy simultaneously.  If such a conflict exists in
the dependencies of two different packages, then those packages can
not be installed simultaneously. You may want to try a larger value of
the --backtrack option, such as --backtrack=30, in order to see if
that will solve this conflict automatically.

For more information, see MASKED PACKAGES section in the emerge man
page or refer to the Gentoo Handbook.


!!! All ebuilds that could satisfy "dev-lang/ruby:2.4" have been masked.
!!! One of the following masked packages is required to complete your request:
- dev-lang/ruby-2.5.3::gentoo (masked by: EAPI 7)
- dev-lang/ruby-2.4.5::gentoo (masked by: EAPI 7)
- dev-lang/ruby-2.4.5 (masked by: EAPI 7)

The current version of portage supports EAPI '6'. You must upgrade to a
newer version of portage before EAPI masked packages can be installed.
(dependency required by "dev-ruby/json-2.1.0::gentoo" [binary])
(dependency required by "dev-lang/ruby-2.3.8::gentoo" [binary])
(dependency required by "dev-ruby/did_you_mean-1.0.2::gentoo" [binary])
For more information, see the MASKED PACKAGES section in the emerge
man page or refer to the Gentoo Handbook.

#5
The current version of portage supports EAPI '6'. You must upgrade to a
newer version of portage before EAPI masked packages can be installed.

Нужно обновить Portage.


#6

а вот с этим самое интересное.

[blocks B      ] <sys-libs/glibc-2.26 ("<sys-libs/glibc-2.26" is blocking net-libs/libnsl-1.2.0)
[blocks B      ] >=app-shells/bash-4.4 (">=app-shells/bash-4.4" is blocking sys-kernel/dracut-044_rc73)
[blocks B      ] <app-shells/bash-completion-2.7-r1 ("<app-shells/bash-completion-2.7-r1" is blocking sys-apps/util-linux-2.32-r4)

и целая куча конфликтов.

во вложении полный лог.

emerge_portage.txt (17.8 KB)


#7

в /etc/portage/package.mask и unmask у меня всё пусто.

keywords/custom

net-analyzer/squidview ~amd64

keywords/kernel

~sys-kernel/calculate-sources-3.15.9 ~amd64 ~x86
=dev-ruby/power_assert-1.1.3 ~amd64
=dev-ruby/net-telnet-0.2.0 ~amd64
=dev-ruby/power_assert-1.1.2 ~amd64

последние 3 добавились при попытке обновляться.


#8

А что говорит eselect profile list? Я так понимаю это старый профиль.

Собственно портаж и требует обновить gcc, glib, binutils и т.д. самом конце лога, это для начала.


#9
 # eselect profile list
Available profile symlink targets:
  [1]   default/linux/amd64/13.0
  [2]   default/linux/amd64/13.0/selinux
  [3]   default/linux/amd64/13.0/desktop
  [4]   default/linux/amd64/13.0/desktop/gnome
  [5]   default/linux/amd64/13.0/desktop/gnome/systemd
  [6]   default/linux/amd64/13.0/desktop/plasma
  [7]   default/linux/amd64/13.0/desktop/plasma/systemd
  [8]   default/linux/amd64/13.0/developer
  [9]   default/linux/amd64/13.0/no-multilib
  [10]  default/linux/amd64/13.0/systemd
  [11]  default/linux/amd64/13.0/x32
  [12]  default/linux/amd64/17.0
  [13]  default/linux/amd64/17.0/selinux
  [14]  default/linux/amd64/17.0/hardened
  [15]  default/linux/amd64/17.0/hardened/selinux
  [16]  default/linux/amd64/17.0/desktop
  [17]  default/linux/amd64/17.0/desktop/gnome
  [18]  default/linux/amd64/17.0/desktop/gnome/systemd
  [19]  default/linux/amd64/17.0/desktop/plasma
  [20]  default/linux/amd64/17.0/desktop/plasma/systemd
  [21]  default/linux/amd64/17.0/developer
  [22]  default/linux/amd64/17.0/no-multilib
  [23]  default/linux/amd64/17.0/no-multilib/hardened
  [24]  default/linux/amd64/17.0/no-multilib/hardened/selinux
  [25]  default/linux/amd64/17.0/systemd
  [26]  default/linux/amd64/17.0/x32
  [27]  default/linux/amd64/17.1
  [28]  default/linux/amd64/17.1/selinux
  [29]  default/linux/amd64/17.1/hardened
  [30]  default/linux/amd64/17.1/hardened/selinux
  [31]  default/linux/amd64/17.1/desktop
  [32]  default/linux/amd64/17.1/desktop/gnome
  [33]  default/linux/amd64/17.1/desktop/gnome/systemd
  [34]  default/linux/amd64/17.1/desktop/plasma
  [35]  default/linux/amd64/17.1/desktop/plasma/systemd
  [36]  default/linux/amd64/17.1/developer
  [37]  default/linux/amd64/17.1/no-multilib
  [38]  default/linux/amd64/17.1/no-multilib/hardened
  [39]  default/linux/amd64/17.1/no-multilib/hardened/selinux
  [40]  default/linux/amd64/17.1/systemd
  [41]  hardened/linux/amd64
  [42]  hardened/linux/amd64/selinux
  [43]  hardened/linux/amd64/no-multilib
  [44]  hardened/linux/amd64/no-multilib/selinux
  [45]  hardened/linux/amd64/x32
  [46]  default/linux/musl/amd64
  [47]  hardened/linux/musl/amd64
  [48]  default/linux/musl/amd64/x32
  [49]  hardened/linux/musl/amd64/x32
  [50]  default/linux/amd64/17.0/musl
  [51]  default/linux/amd64/17.0/musl/hardened
  [52]  default/linux/amd64/17.0/musl/hardened/selinux
  [53]  default/linux/uclibc/amd64
  [54]  hardened/linux/uclibc/amd64
  [55]  default/linux/amd64/17.0/uclibc
  [56]  default/linux/amd64/17.0/uclibc/hardened
  [57]  calculate:default/amd64/18/desktop
  [58]  calculate:default/amd64/18/server
  [59]  distros:CLD/amd64
  [60]  distros:CLDC/amd64
  [61]  distros:CLDL/amd64
  [62]  distros:CLDM/amd64
  [63]  distros:CLDX/amd64
  [64]  distros:CLDXE/amd64
  [65]  distros:CDS/amd64 *
  [66]  distros:CLC/amd64
  [67]  distros:CLS/amd64
  [68]  distros:CSS/amd64

странно, но до всего этого профиль лист был раз в 6 меньше :slight_smile:


#10

хм… а как же мне на новый профиль перейти ? %)
в /usr/portage/profiles/eapi вообще 5 написано.


#11

Нет, всё правильно, профиль нормальный. Нужно тогда обновить в первую очередь gcc, glibc, binutils.


#12

запустил emerge gcc… вроде пытается :slight_smile:

выдал следующее

 * Messages for package sys-devel/gcc-7.3.0-r3:

 * If you have issues with packages unable to locate libstdc++.la,
 * then try running 'fix_libtool_files.sh' on the old gcc versions.
 * You might want to review the GCC upgrade guide when moving between
 * major versions (like 4.2 to 4.3):
 * https://wiki.gentoo.org/wiki/Upgrading_GCC

фикс нужно запускать ?


#13

Пока не не нужно, это если будут проблемы с libstdc**.la


#14

теперь лог обновления portage следующий

emerge_portage.txt (15.8 KB)


#15
The following keyword changes are necessary to proceed:
(see "package.accept_keywords" in the portage(5) man page for more details)
 # required by dev-lang/python-3.4.8::gentoo[readline,ncurses]
 # required by @__auto_slot_operator_replace_installed__ (argument)
=sys-libs/readline-7.0_p5 ~amd64

Размаскировать.

dev-libs/icu-58.2-r1::gentoo (masked by: package.mask)
/usr/portage/profiles/base/package.mask:
 # Andreas Sturmlechner <asturm@gentoo.org> (15 Jul 2018)
 # Old ICU is unsupported. ICU 58 only remains for 13.0 based profiles.

А это нужно обновить.


#16

что теперь ему нужно ?

emerge_portage.txt (10.9 KB)


#17

Вручную обновлять пакеты, которые перечислены в конце лога, т.к. данных версий уже нет в портежах.

(sys-libs/slang-2.3.0:0/0::gentoo, installed): ebuild is masked or unavailable
  (sys-apps/gawk-4.1.3:0/0::gentoo, installed): ebuild is masked or unavailable
  (media-libs/libpng-1.6.29:0/16::gentoo, installed): ebuild is masked or unavailable
  (app-crypt/gnupg-2.1.20-r1:0/0::gentoo, installed): ebuild is masked or unavailable
  (dev-lang/python-2.7.12:2.7/2.7::gentoo, installed): ebuild is masked or unavailable
  (dev-db/postgresql-9.6.3-r1:9.6/9.6::gentoo, installed): ebuild is masked or unavailable
  (media-libs/tiff-4.0.8:0/0::gentoo, installed): ebuild is masked or unavailable
  (dev-lang/ruby-2.1.9:2.1/2.1::gentoo, installed): ebuild is masked or unavailable
  (sys-apps/util-linux-2.28.2:0/0::gentoo, installed): ebuild is masked or unavailable
  (dev-libs/libpcre2-10.22:0/0::gentoo, installed): ebuild is masked or unavailable
  (dev-lang/ruby-2.2.6:2.2/2.2::gentoo, installed): ebuild is masked or unavailable
  (dev-lang/python-3.4.5:3.4/3.4m::gentoo, installed): ebuild is masked or unavailable
  (net-misc/ntp-4.2.8_p10-r1:0/0::gentoo, installed): ebuild is masked or unavailable
  (dev-libs/libpcre-8.40-r1:3/3::gentoo, installed): ebuild is masked or unavailable
  (sys-fs/xfsprogs-4.9.0:0/0::gentoo, installed): ebuild is masked or unavailable
  (app-shells/bash-4.3_p48-r1:0/0::gentoo, installed): ebuild is masked or unavailable
  (app-text/ghostscript-gpl-9.21:0/0::gentoo, installed): ebuild is masked or unavailable
  (net-dns/bind-tools-9.11.1_p1:0/0::gentoo, installed): ebuild is masked or unavailable
  (net-misc/openssh-7.5_p1-r1:0/0::gentoo, installed): ebuild is masked or unavailable
  (media-libs/lcms-2.8-r1:2/2::gentoo, installed): ebuild is masked or unavailable
  (dev-db/sqlite-3.19.3:3/3::gentoo, installed): ebuild is masked or unavailable
  (media-gfx/imagemagick-6.9.9.0:0/6.9.9.0::gentoo, installed): ebuild is masked or unavailable
  (net-fs/samba-4.5.10:0/0::gentoo, installed): ebuild is masked or unavailable
  (media-libs/openjpeg-2.1.1_p20160922:2/7::gentoo, installed): ebuild is masked or unavailable
  (dev-libs/libxml2-2.9.4-r1:2/2::gentoo, installed): ebuild is masked or unavailable
  (sys-block/parted-3.2:0/0::gentoo, installed): ebuild is masked or unavailable

#18

ясно. спасибо.
там на при обновлении любого из этих пакетов, ещё пачка зависимостей выходит :slight_smile:
т.е. на самом деле список получается гораздо больше.
ну ничего :slight_smile: мы терпеливые…


#19

Главное чтобы portage обновился, а дальше emerge -avuND world


#20

ясно. спасибо за помощь! о результате отпишу.