Can't unlock KDE session

Hi All,

On my fresh install of CLD 18 (multiboot, Nvidia driver installed) I have the problem as in the title, I did nothing strange beyond setting up the DE and installing some preferred packages but the following day Plasma does’nt start.
In a nutshell, I have been doing the following attempts to log in:
# ck-unlock-session -u Session1 ### etc.
# su -c ‘dbus-send --system --print-reply --dest=“org.freedesktop.ConsoleKit” /org/freedesktop/ConsoleKit/Session1 org.freedesktop.ConsoleKit.Session.Unlock’
After that, I can log in as root but not as user (try also with new user); trying also:
# emerge -e @world
got nothing.
When installing packages apparently everything gone well, the only weird point is that I have been installing
but it is not coming out on GIMP. Don’t know if it is important, I add terminal output here:
Please, do someone knowing the solution for this issue?

Best Regards

Edit (15.X.2018)
I am pretty sure the problem comes from OpenGL / Nvidia driver but I don’t know how to fix it

Edit (18.X.2018)
I discovered something weird today: can log in with user “guest”.
I deleted the user created by me (/home included) and creating a new user, log in impossible too.
cl-update today brought kernel 4.18.14 and Nvidia Drivers 340.107

Hi Silvio,

Hopefully this will help, as on a previous install of Calculate Linux (xfce version) a few months ago I seem to recall a similar situation where I couldn’t log in at the display manager.

Was your user set at install to have administrative rights (i.e. to be a member of the wheel group, which is more commonly used in Calculate Linux than the sudo group)? If so, if I recall correctly I think that after trial and error the problem was solved addressing the fact that, currently, Calculate Linux does not have the following line uncommented in the /etc/sudoers file:

 # %wheel     ALL=(ALL)      ALL

Here are detailed instructions for those in the future who may not have experience with this.

First, you could start a session by ignoring the display manager ‘log in’ prompt when it appears, and holding down the following three keys instead: Ctr+Alt+F1. You should be able to log in as user; otherwise log in as root.

To uncomment the line (to make the wheel group active, so to speak), the standard and safest way to do so is by using visudo, which is an editor that edits that critical file and reports whether you did something incorrectly. It is based on the vi (or vim?) text editor (although there is a way to use another editor to work for visudo).

You could use visudo by using su - to get a root prompt first, exceptionally (although it is not typically recommended for most other purposes):

$ su -
 # visudo

Navigate down to place the cursor on the line shown earlier.
Hit the esc key and type i to be able to _insert_/delete characters. Then you should be able delete the # character with the delete key.
Then hit the esc key again and type :wq and the Enter key to write the changes to the file and to quit visudo.

You could get that file printed to the screen with the following command to check whether you have modified the file correctly, while you are still working as ‘root’ (with the hash prompt):

cat /etc/sudoers

Type ‘exit’ afterwards to leave the ‘root’ prompt, or reboot.

I can’t explain how that is related to the fact that I couldn’t log in at the display manager, but I think that solved the problem for me. Does that help?
Best wishes.

Hi Jose,

Thank you for the kind concern, I have been following your hint but unfortunately it did’nt solve.
That line in /etc/sudoers file was commented indeed but uncommenting it session is still blocked.

Ciao :slight_smile: