Calculate Forum

Вышел Calculate Linux 20.6

Вышел 21 июня 2020 г.

К 20-летию компании «Калкулэйт» мы рады представить вашему вниманию новый релиз дистрибутива Calculate Linux 20.6!

В новой версии проведены оптимизации загрузки, снижены требования к объему оперативной памяти, добавлена поддержка преднастройки плагинов браузера для работы с Nextcloud.

Для загрузки доступны следующие редакции дистрибутива: Calculate Linux Desktop с рабочим столом KDE (CLD), Cinnamon (CLDC), LXQt (CLDL), Mate (CLDM) и Xfce (CLDX и CLDXS), Calculate Directory Server (CDS), Calculate Linux Scratch (CLS) и Calculate Scratch Server (CSS).

Основные изменения

  • Вместо дискового Swap раздела по умолчанию используется Zram.
  • Переход на сжатие Zstd для ядра, модулей и initramfs.
  • Модули ядра, устанавливаемые из пакетов, теперь также запаковываются в Zstd-формат.
  • По умолчанию используется звуковой сервер PusleAudio, но при этом сохранён выбор ALSA.
  • Выполнен переход на браузер Chromium с преднастроенным плагином uBlock Origin.
  • Добавлена поддержка настройки плагинов браузера Passman и FreedomMarks для работы с Nextcloud во время создания профиля пользователя.
  • Вместо Deluge используется qBittorrent.
  • Действие по умолчанию при закрытии крышки ноутбука изменено на suspend.
  • Улучшена поддержка Wi-Fi.
  • Улучшено удаление неиспользуемых зависимостей пакетным менеджером.
  • Изменён порядок образов на мультизагрузочной флешке - основной образ находится всегда в конце.
  • В бинарный репозиторий включены 6 ядер разных версий, в том числе с патчем futex-wait-multiple для ускорения работы Steam.
  • Добавлена преднастройка для ccache для использования как в emerge, так и cl-kernel.

Исправления

  • Исправлено выполнение suspend и hibernate в XFCE.
  • Исправлена работа touchpad после suspend.
  • Исправлено отключение образа при использовании кэширования образа в память (docache).
  • Исправлена настройка локального оверлея.
  • Исправлен вход в сеанс MATE.

Утилиты Calculate

  • Добавлена возможность прерывать сборку пакета при неподходящем патче в шаблонах.
  • Исправлены загрузка и установка PXE.
  • Исправлена ошибка при одновременной настройке пакета и установке его в систему.
  • Добавлена возможность использовать FEATURES=“userpriv” при сборке пакетов.
  • Исправлено определение запущенного emerge при cl-update.
  • Исправлена подготовка дистрибутива для сборки.
  • Добавлено удаление .old-файлов в /boot при запаковке дистрибутива.
  • Добавлена поддержка работы eix-diff в собираемом образе.
  • Группа lpadmin добавлена в список групп по умолчанию.
  • Добавлена поддержка работы утилит с sys-apps/portage без Python 2.7.
  • Исправлена работа с pyopenssl.
  • Исправлено определение видеодрайвера.
  • Добавлена возможность выбора VESA в списке видеодрайверов.
  • Исправлена установка x11-drivers/nvidia-drivers во время загрузки.
  • Исправлена подготовка образа с x11-drivers/nvidia-drivers.
  • Исправлена работа cl-console-gui.
  • Исправлена инициализация пользовательской директории при использовании шифрованного профиля.
  • Добавлена возможность указывать дополнительные параметры загрузки ядра в собираемом образе.
  • Параметр --skip-revdep-rebuild заменён на --revdep-rebuild.
  • Исправлена функция шаблонов world().

Состав пакетов

  • CLD (KDE desktop): KDE Frameworks 5.70.0, KDE Plasma 5.18.5, KDE Applications 19.12.3, LibreOffice 6.4.3.2, Chromium 83.0.4103.106 - 2.73 G
  • CLDC (Cinnamon desktop): Cinnamon 4.4, LibreOffice 6.4.3.2, Chromium 83.0.4103.106, Evolution 3.34.4, Gimp 2.10.18, Rhythmbox 3.4.4 - 2.48 G
  • CLDL (LXQt desktop): LXQt 0.14.1, LibreOffice 6.4.3.2, Chromium 83.0.4103.106, Claws Mail 3.17.5, Gimp 2.10.18, Clementine 1.4.0 RC1 - 2.49 G
  • CLDM (MATE desktop): MATE 1.24, LibreOffice 6.4.3.2, Chromium 83.0.4103.106, Claws Mail 3.17.5, Gimp 2.10.18, Clementine 1.4.0 RC1 - 2.60 G
  • CLDX (Xfce desktop): Xfce 4.14, LibreOffice 6.4.3.2, Chromium 83.0.4103.106, Claws Mail 3.17.5, Gimp 2.10.18, Clementine 1.4.0 RC1 - 2.43 G
  • CLDXS (Xfce Scientific desktop): Xfce 4.14, Eclipse 4.13.0, Inkscape 1.0, LibreOffice 6.4.3.2, Chromium 83.0.4103.106, Claws Mail 3.17.5, Gimp 2.10.18 - 2.79 G
  • CDS (Directory Server): OpenLDAP 2.4.50, Samba 4.11.8, Postfix 3.5.1, ProFTPD 1.3.7 RC3, Bind 9.14.8 - 763 M
  • CLS (Linux Scratch): Xorg-server 1.20.8, Kernel 5.4.45 - 1.27 G
  • CSS (Scratch Server): Kernel 5.4.45, Calculate Utilities 3.6.7.42 - 562 M

Загрузка и обновление

Live USB образы Calculate Linux доступны для загрузки на странице https://wiki.calculate-linux.org/ru/download

Если у вас уже установлен Calculate Linux, просто обновите вашу систему до версии 20.6.

А можно сделать, чтобы с 3й версией питоне не обращало внимания на его версию? Т.е. всем программам было всё равно какая там версия - 3.5, 3.6 , 3.7 …

Только требовать минимальную - как это сделано в perl-е.

А то уже не первый раз при обновлениях вылазит проблема из-за версий питона.

Я думаю постепенно мантейнеры к этому придут. Сейчас в ebuild-ах просто перечисляют диапазон версий, в то время как раньше просто указывалась одна версия. Из-за того, чтобы удалить 3.6 пришлось прилично ebuild-ов перенести в оверлей.

Ура!!!

А что конкретно исправлено? А то вроде зависание при выходе из гибернации у меня не пропало…

Работа live usb образа.

© 2007-2020 Calculate Ltd.
Mastodon Mastodon