Building Your Own Gentoo-Based Linux System - overlay missing assemble and builder ?

I was trying to follow [[]] guide to build my own Calculate system, followed instructions up to the point where I am supposed to install calculate-assemble and calculate-builder. But emerge doesn’t find those packages and I can’t find .ebuild for those packages under /var/lib/layman/calculate either.

I have tried deleting and adding the overlay ‘calculate’ again, but without success.

What am I missing here ? Is the overlay really missing these files or do I need some other overlay to install the 2 crucial packages ?

This is a very old article. What exactly do you want to change in the distro?

I’m running into same issue where calculate-assemble (or cl-assemble) doesn’t exist anymore.

And in my case it’s not so much about “change the distro”. I wanted to generate stage3 (or stage4) tar.gz for installing calculate-linux on a remote server - where I can login/ssh remotely into a “rescue” system.

In particular case or

You can install the system in a free partition from the iso image:

cl-install --iso=/path_to_iso

Perhaps I’m asking the wrong question :slight_smile:

Basically I’m in “catch 22” situation :expressionless:

I don’t have physical access to the server -> I can’t boot Calculate-Linux iso -> so I can’t just like that run “cl-install” command. I tried their remoteKVM that is supposedly allowing booting custom iso images, but I couldn’t get it to boot from it, and remoteKVM system kept crashing.

What I can do is utilize/boot their rescue system, ssh into it and then install Gentoo the old school way using stage3.tar.bz2 … But then I need to configure the whole thing, emerge package(s) like layman, calculate-utils …etc to be able to run cl-install (on another partition). But manually installing Gentoo and the rest of thing is exactly what I’ve been trying to avoid doing in the first place.

So - any other ideas on how to install CalculateLinux on a remote server to which you don’t have physical access, and booting custom iso is not possible?

Hi Aleksandar,

You can install Gentoo, then download and unpack the CL into a free partition.

That’s almost what I ended up doing :slight_smile:

I tried with addition of that has Samba/FTP/etc because (in theory) Hetzner’s remote KVM can mount .iso from it. But I couldn’t really get Calculate Scratch Server iso to boot in (U)EFI mode no matter what I tried - I think problem was with Samba on that storage box.

So at the end I started with their rescue system and used a mix of following traditional Gentoo Installation Handbook +

That 5 years old guide of switching/migrating from base Gentoo to Calculate needs updating - in case I don’t get around to re-testing and writing that soon, for anyone else looking here’s TL;DR: calculate-utilities is now calculate-utils, you also need distros layman repo for calculate profiles, and I’m not (yet) 100% sure what created cl-setup-system alias…

(order might be wrong)

1) emerge layman
2) layman -a calculate
3) layman -a distros; # this gives you Calculate profiles
4) emerge calculate-utils
5) eselect profile set XXX
6) cl-update-profile; # I think this created alias for cl-setup-system - but not 100% sure as I had to "improvise"
7) cl-setup-system
7) cl-update --rebuild-world

In order to get to the point I can run/emerge anything rescue system chroot I already did the rest of steps from Install Handbook manually. So I didn’t run cl-install and instead manually wired up everything - e.g.:

grub-install --target=x86_64-efi --efi-directory=/boot
grub-mkconfig -o /boot/grub/grub.cfg

Due to many problems with combination of Samba share and remote KVM - I was expecting something to go wrong, so I requested another free 3 hour session of remote KVM and then typed “reboot” …

To my surprise everything worked :wink: