blocked packages....

Hi friends,
Although I basically understand the “blocked Packages” I have trouble to execute and correct the problem.
Calculate Linux Mate: sys-power/powermgmt-base[-pm-utils()] ("sys-power/powermgmt-base[-pm-utils()" is blocking sys-power/pm-utils-1.4.1-r7)

How can I solve this problem and what would I physically type in to make the necessary changes?
I am new at Gentoo but usually find my way around problems…but not this time.
I would greatly appreciate any help in this matter, thanks, Rene

Untitled_1.odt (24.8 KB)


you can run the

emerge @preserved-rebuild

command to solve the new changes with mate-power-manager package and run again the update.

Please show autodepends for all installed packages

grep -rn power /var/db/pkg/*/*/autodeps

Attn: Mikhail Hiretsky,

Hi Mikhail,

I am the guy with the blocked packages problem in Calculate-Mate, My name is Rene Bolders and I want to run some additional information by you.
(I hope you got my latest e-mail with the output and additional info!)

I took an average laptop, (Asus) and installed a new SanDisk 120GB SSD. I downloaded the ISO from the Calculate website, burned a USB stick and installed Calculate Mate.
All went fine…without making any modifications to the settings, I ran the Updater first and ran into the same “blocked Packages” problem.
One of my friends did the same thing with his desktop and reached the same conclusion.
This leads us to think that the problem is on the Calculate Server side, not on our side. (we are in Florida-USA)
My friends and I have a total of 9 machines running Calculate Linux-Mate since about two years and we love it!!

But…we don’t love having our updates blocked for more than two weeks now. All machines perform fine and probably will for some time to come but eventual problems will creep up if we can’t update.
I still believe that the cause is a conflict because of two apps with either the same name or one of them is not thoroughly tested and blocks an important app…MATE-power manager.
On one of the not so important computers in my collection, I uninstalled all the apps that were marked by using emerge -C but all that happened is that, when you want to shut the machine down, you don’t get the window: restart-shut down, 60 seconds and so on.
Other than that I have not noticed any shortcomings but the problem is still not solved…the block is still there.

Are you guys aware of this problem? Are we the only ones having this problem? Maybe a solution is being written as we speak and I’ll be happy to wait a while until a new update comes through…

We would greatly appreciate your help in this matter, we are enthusiastic Calculate-Gentoo users but by no means are we Gentoo experts.

Thank you up front for your help,

best, Rene Bolders

Hi Rene,

Unfortunately I’ve faced the same issue with blocked packages during update. And there is my solution. As sys-power/powermgmt-base is an indirect dependency of mate-base/mate-applets-1.20.2_rc73, then what we can do with that:

# install mate-base/mate-applets-1.20.2 which does not depend on sys-power/powermgmt-base
emerge =mate-base/mate-applets-1.20.2

# fix the version of mate-base/mate-applets-1.20.2
# add a line to /etc/portage/profile/package.provided
echo “mate-base/mate-applets-1.20.2” >> /etc/portage/profile/package.provided

# perform update