И опять ATI, на этот раз Radeon HD 6410D[РЕШЕНО]

Собрал для своего офиса новый системник, в нем:
Интегрированая в процессор графика
AMD A4-3400 APU with Radeon™ HD Graphics
VGA compatible controller: Advanced Micro Devices [AMD] nee ATI Sumo [Radeon HD 6410D]

Сразу после установки CLD 13.6.1
Загружался, но в место окна KDM просто появлялся курсор мыши.
Если долго постоит, то окно KDM появлялось, но зависало. Ни клавиатура и ни мышь не реагировали, хотя в консоль переключится было возможно.

Удалил все видео драйвера
emerge -C `qlist -IC drivers|grep video`

Установил:
x11-drivers/ati-drivers, он попросили отключить или собрать как модуль CONFIG_DRM

Пересобрал стандартное ядро CLD, с отключенным CONFIG_DRM.
x11-drivers/ati-drivers

потом, опят переустановил драйвера ATI
module-rebuild -X rebuild
Сказал смотреть на новые драйвера:
eselect opengl set ati

Но после загрузки KDM в графический режим вообще не переключается.
kdm.log говорит: no screen found
Потому, что
Xorg.0.log говорит, что
Failed to load module "radeon"

Не могу понять почему он пытается загрузить radeon в место fglrx?

Подскажите пожалуйста как запустить графику.

cl-setup-video --video fglrx

Алексей Тихонов wrote:

cl-setup-video --video fglrx

а если видяха HD3000?

те драва что идут в комплекте с дистром не поддерживают этого “динозавра”

Помогло спасибо.

Анатолий from еБург wrote:

а если видяха HD3000?

те драва что идут в комплекте с дистром не поддерживают этого “динозавра”

какие драйвера поддерживают вашу карточку можно посмотреть тут
http://support.amd.com/us/gpudownload/linux/legacy/Pages/legacy-radeon_linux.aspx