Calculate Forum

ASUS ZenBook UX32VD и CLDM

Здравствуйте. С линуксом уже более 20 лет, но последние 10 лет использовал debian-based дистрибутивы. Debian великолепен, но хочется расширить кругозор. Выбор пал на gentoo, конкретно на calculate linux - несколько лет назад некоторое время пользовался им, понравилось сообщество.
А проблема такая - при установке на ультрабук ASUS ZenBook UX32VD не работает FireFox. Встает колом и ни на что не реагирует. Пробовал пересобрать его - не помогает. Ставлю систему на внешний хард - ведет себя полностью аналогично. Причем все остальное на первый взгляд работает нормально. Загружаюсь с этого же внешнего харда на десктопе все работает прекрасно. В какую сторону копать?
Вообще я подозреваю проблемы с UEFI BIOS. Подарок от майкрософт - новый ноутбук глючил по-черному с любым линуксом, пока не обновил BIOS. С тех пор обновлений BIOS выпущено не было, стоит последняя версия.
И еще - подскажите, пожалуйста, экранную клавиатуру для CLDM. Ubuntu имела прекрасную OnBoard, в Debian использовал Florence. Что существует для gentoo/calculate linux? Необходимо наличие персидского/арабского шрифтов.

Cromium не работает столь же успешно. Удалил firefox-51.0, поставил firefox-bin-45.7.0 - работает успешно. Что-то со сборкой не так?

UEFI здесь точно не причём. Глючит в дефолтном профиле или сеанс пользователя у вас уже настроен был?

Не работает сразу же после установки, уже в дефолтном guest.
Но эта же система (если поставить на внешний хард) прекрасно работает на другом компе.
И, как сегодня выяснилось, бинарный пакет (правда, более младшей версии) работает успешно.
Можно, конечно, для чистоты эксперимента попробовать собрать ту же версию. USE-флаги, что ли, для этого ноута нужно как-то иначе выставить?

Если с флешки загрузиться то тоже проблемы?

Думаю, что нет. Я пошёл немного неверным путём - решил проверить, будет ли работать другая редакция,в частности, кде. С флэшки работает изумительно. После установки не смог дождаться даже экрана входа. Переключился в виртуальную консоль, обновляюсь. Надеюсь, поможет.

Если заработает, формально можно за считать факт внедрения в ООО “Геофизмаш” г.Саратов. :slight_smile:

Часто подобные вещи происходят из-за настроенного до этого профиля. Т.к. livecd по сути та же система, только с дефолтным профилем, на нем легко можно проверить работу системы без установки на конкретном железе, так же опробовать разные видеодрайвера, pulseaudio/alsa, openrc/networkmanager, всё это задаётся в меню загрузчика.

Если система уже стоит, можно скопировать iso-образ в /var/calculate/linux и выполнить cl-setup-boot-live и все образы пропишутся в настройки Grub. Можно будет запустить без флешки.

P.S. Если перейдёте на кальку, будем признательны, если вы напишете здесь.

М-да. Все плохо. С КДЕ превосходно работает с флэшки, но после установки имеем черный экран с немигающим курсором в левом верхнем углу. И все. Даже после обновления. В виртуальную консоль, правда, переключиться можно. Но несколько задумчиво.
При этом (проверял МАТЕ версию) великолепно работает на Lenovo X60s, десктопах с Intel Celeron G1610 и материнками ASUS P8B75-M и H61M-K. А вот с зенбуком дружба что-то не заладилась…

В любом случае добьюсь работоспособности. Раз уж работает с флэшки, заработает и здесь. Просто незнакомая система, нужно найти нужные конфиги и профили.
Ну и вначале озадачило, что работает везде, кроме конкретного ноутбука.

Спасибо за оперативную и подробную консультацию. Весьма признателен.

Не мытьем, так катаньем…после очередной перестановки все заработало. Причем все изменения на первый взгляд совершенно не имеют отношения к имевшей место проблеме - в этот раз при инсталляции ноутбук был подключен к домашней, а не корпоративной сети; подключен через wi-fi, а не ethernet; не указан свап-раздел; явно указана дефолтная звуковая карта. Все остальное не изменялось. Однако в этот раз все работает без нареканий.

А нет, самое главное забыл - на работе к ноуту подключен внешний монитор. Ну, и внешние мышка и клавиатура по USB. Может, в этом все дело?

Причина установлена, хотя и непонятно пока, как с ней бороться - это действительно подключенный по HDMI внешний монитор. Принес ноут на работу, подключил монитор - и прекрасно работающая дома система опять работать перестала! Firefox опять висит…полный набор симптомов повторился. Отключил монитор - все заработало.

вернее - непосредственная причина. С LiveDVD-то все работало! Ну, хотя бы круг поисков сузился

Что содержится в /etc/X11/xorg.conf?

Попробуйте в установленной системе выбрать настройку видео-драйвера по умолчанию:

cl-setup-video --video default

Mikhail Hiretsky wrote:

Что содержится в /etc/X11/xorg.conf?

#------------------------------------------------------------------------------
 # Modified Calculate Utilities 3.5.0.10
 # Processed template files:
 # /var/lib/layman/calculate/profiles/templates/3.5/3_ac_install_live/1-merge/x11-base/xorg-server/X11/xorg.conf
 # For modify this file, create /etc/X11/xorg.conf.clt template.
#------------------------------------------------------------------------------

Section "ServerLayout"
  Identifier "Xorg Configured"
  Screen "Monitor"
EndSection

Section "Files"
  FontPath "/usr/share/fonts/corefonts"
  FontPath "/usr/share/fonts/misc"
  FontPath "/usr/share/fonts/droid"
EndSection

Section "Module"
  Load "dri"
  Load "i2c"
  Load "bitmap"
  Load "ddc"
  Load "int10"
  Load "vbe"
  Load "glx" # OpenGL X protocol interface
  Load "extmod" # Misc. required extension
EndSection

Section "Monitor"
  Identifier "StandardMonitor"
  Option "DPMS"
EndSection

Section "Device"
  Identifier "intelVGA"
  Driver "intel"
  Option "NoAccel" "False"
  Option "DRI"     "True"
  #https://bugs.freedesktop.org/show_bug.cgi?id=88584
  Option "AccelMethod" "uxa"
EndSection

Section "Screen"
  Identifier "Monitor"
  Device "intelVGA"
  Monitor "StandardMonitor"
  DefaultDepth 24
  Subsection "Display"
    Viewport 0 0
    Depth 24
    Modes "1920x1080"
  EndSubsection
EndSection

Section "DRI"
  Group        "video"
  Mode         0666
EndSection

Section "Extensions"
  Option "Composite" "On"
EndSection

Разрешение экрана ноутбука и внешнего монитора действительно совпадают. Возможно, проблема в том, что ультрабук имеет гибридную графику - встроенную интел и дискретную нвидию.Последняя совершенно не нужна и в дебиане отключаю ее с помощью bumblebee. Но если и не отключать, ничего страшного не происходит. Просто заряд аккумуляторов берегу.

Что-нибудь изменилось после?

cl-setup-video --video default
© 2007-2020 Calculate Ltd.
Mastodon Mastodon