Calculate Forum

Установка на систему с материнской платой ASRock B560M-HDV

Пытаюсь установить CLD на новый ПК с материнской платой ASRock B560M-HDV
и процессором Intel Pentium Gold G6400
Прошивка материнки актуальная - 2.10

При загрузке с установочного iso-образа через несколько секунд монитор отрубается - чёрный экран, на мониторе начинает моргать лампочка как при физически отключенном кабеле.
При этом если переключиться на какую нибудь виртуальную консоль по Alt+Fx и нажать Ctrl+Alt+Del, то ПК перезагрузится. То есть система не висит, а просто не выводит изображение на монитор.

Загружаю iso-образ через grub, конфигурация рабочая (установливал на много машин, пока не попалась данная материнка), часть конфига:

set cld_rev=‘20210907’
menuentry “Calculate Linux Desktop KDE x86_64 (CLD-${cld_rev})” {
set iso="/boot/iso/calculate/cld-${cld_rev}-x86_64.iso"
set label=“CLD-${cld_rev}”
set gfxpayload=keep
insmod gzio
insmod part_gpt
insmod ext2
insmod search_label
insmod loopback
loopback loop ${iso}
linux (loop)/boot/vmlinuz isoboot=${iso} boot=isolinux iso-scan/filename=${iso} root=live:LABEL=${label} rd.live.image init=/linuxrc rd.live.squashimg=livecd.squashfs nodevfs udev quiet noresume splash elevator=deadline calculate=resolution:auto,video:auto,composite:on
initrd (loop)/boot/initrd
}

Пробовал параметр video менять на intel, на vesa. Убирал splash. Ничего не помогает.

Что можно ещё попробовать? Систему очень нужно установить.

монитор по хдми подключен, вангую я…

Нет, монитор по VGA подключен. Дело не в этом.
Если в параметрах загрузки ядра убрать quiet и splash, то даже процесс загрузки отображается до определённого момента. А после - чёрный экран и моргающая лампочка на мониторе как будто кабель физически отсоединили.

А ещё я пробовал старый iso-образ загружать - 21-й релиз, не помогло.

Спасибо за рабочую конфигурацию grub! Я сам умею загружать с флешки, livecd, а у Вас тут мастер-класс по установке cld!

А с монитором я Вам не подскажу, у самого с ними плохо!

А со стандартного образа грузиться?

Проблема в ядре linux.
Подобная проблема описана например здесь https://www.reddit.com/r/linuxhardware/comments/m9z5b8/need_help_with_intel_graphics_on_asrock_b560m_mobo/
говорят что ядро нужно патчить

На ubuntu есть готовое ядро, не имеющее этой проблемы

Будет ли что нибудь подобное на Calculate Linux?

Проблема решается установкой более нового ядра.
На ядре 5.14.3 всё работает.

Установил систему так:

  1. добавил в параметры загрузки ядра nomodeset, video=vesa
    система устанавливается, но разрешение 1024x768

  2. удалил /etc/X11/xorg.conf
    с конфигом X-ы не грузились

  3. обновил ядро до 5.14.3 (боллее ранние версии не проверял)

  4. в настройках “Console Calculate” выбрал драйвер intel и установил требуемое разрешение.

Хорошо бы обновить ядро в ночных сборках.

тут, понимаешь, опасно на кальке просто так ядро обновлять. бо та же нвидиа, которую так ненавидят, скорее всего не заведется правильно, т.к., то эти, то те с выпусками и поддержкой не поспевают.
я уже лет много на данном дистре, как владелец разных моделей нвидий, страдаю от этого.

так что обожди.)

© 2007-2020 Calculate Ltd.
Mastodon Mastodon