Calculate Forum

Не могу собрать apache с php

Стыдно, но ниасилил… пробовал прописывать в /etc/portage разное… не пойму что ему нужно

eix dev-lang/php

  • dev-lang/php
    Доступные версии:
    (5.6) [M]5.6.40-r7
    (7.1) [M]7.1.33^t
    (7.2) 7.2.24^t ~7.2.25^t 7.2.26^t
    (7.3) 7.3.11^t ~7.3.12^t 7.3.13^t
    (7.4) ~7.4.0^t ~7.4.1^t
    {acl apache2 argon2 bcmath berkdb bzip2 calendar cdb cgi cjk +cli coverage crypt +ctype curl debug embed enchant exif ffi +fileinfo +filter firebird +flatfile fpm ftp gd gdbm gmp +hash +iconv imap inifile intl iodbc ipv6 +json kerberos ldap ldap-sasl libedit libmysqlclient libressl lmdb mhash mssql mysql mysqli nls oci8-instant-client odbc +opcache pcntl pdo +phar phpdbg +posix postgres qdbm readline recode selinux +session session-mm sharedmem +simplexml snmp soap sockets sodium spell sqlite ssl sybase-ct systemd sysvipc test threads tidy +tokenizer tokyocabinet truetype unicode vpx wddx webp +xml xmlreader xmlrpc xmlwriter xpm xslt zip zip-encryption zlib}
    Домашняя страница: https://php.net/
    Описание: The PHP language runtime engine

emerge dev-lang/php

  • IMPORTANT: 13 news items need reading for repository ‘gentoo’.
  • Use eselect news read to view new items.

Calculating dependencies… done!

!!! All ebuilds that could satisfy “dev-lang/php” have been masked.
!!! One of the following masked packages is required to complete your request:

  • dev-lang/php-7.3.13::gentoo (masked by: use flag configuration mismatch)
  • dev-lang/php-7.2.26::gentoo (masked by: use flag configuration mismatch)

For more information, see the MASKED PACKAGES section in the emerge
man page or refer to the Gentoo Handbook.

uname -a

Linux calculate 5.4.6-calculate #1 SMP PREEMPT Sun Dec 22 11:13:04 UTC 2019 x86_64 Intel® Core™2 CPU 6600 @ 2.40GHz GenuineIntel GNU/Linux

/etc/portage/package.mask пустой

с флагом apache2 не собирается, а он нужен

Что делать? Заранее спасибо!

Уберите все свои изменения, они неверны и вызывают ошибку.

#echo 'dev-lang/php apache2' >> /etc/portage/package.use/custom
#FEATURES="-getbinpkg" emerge -avuDN dev-lang/php

спасибо! php вроде встал, но модуля для апача не видно, не пашут скрипты по http

А php собрался с флагом apache2?

вот хз… вроде бы eix dev-lang/php пишет что собрался с флатом, но модуля php в апаче нет :((( а очень нужен, сейчас пробую собирать еще раз… о результатах напишу… надеюсь поможет

Если он собран с флагом, то это нужно уже сам апач настраивать, php тут ни при чём.

А как? если модуля php в апаче нет…

Вот с этим я не помошник. Спроси в чатике, там активнее народ.

Добрый день, тоже самое у меня было, php реально не хочет с apache собираться, делаешь из мануала генту но нет он не собирается при чем разные версии пчп пробовал нифига! вот по адриеновской инструкции делал https://www.linuxtricks.fr/wiki/installer-lamp-sur-gentoo-calculate-linux
Нет никак, остановился на nginx. Как-то так!

© 2007-2020 Calculate Ltd.
Mastodon Mastodon