Calculate Forum

AMD Ryzen Laptop - X server failed during boot time

Hi folks,
I have T14 with AMD 4650. Trying to boot latest live iso build, which switch to text console. When I try to run startx I receive x server fatal errors. I try to add “noapic” to kernel cmd line but this wont help either.
Do you have suggestions how to solve this?

EDIT:
I’ve also updated bios from 1.05 to the current version 1.30. without any impact to the issue.

You checked the ISO once written on the stick and its fine?

of course I did, besides this live USB I’ve used in multiple previous installations, but on Intel…

Is this the ‘nightly’ ISO you’re using? If not, try that one. I had some graphic issues as well on my Ryzen 4500U laptop.

1 Like

Thanks angelus, I always used releases and never tried nightly builds :slight_smile:
Indeed last nightly build worked fine!
Again thanks for suggestion. Great forum support!

1 Like

Glad that it’s working! You could have made it work with ‘release’ as well by manually updating the kernel and continue from there. But I usually use the ‘nightlies’ as they also save you the amount of initial upgrades :slight_smile:

1 Like
© 2007-2020 Calculate Ltd.
Mastodon Mastodon