adding keyboard shortcuts doesn't work on v18.12 cinamon

It’s a x64 system. I am trying to add new keyboard shortcuts:
F6 for Volume Mute, F7 for Volume Down, F8 for Volume Up
I choose: system settings/keyboard/shortcuts/Sound and Media/Volume mute.
In the keyboard bindings frame, I select the first line marked as “unassigned”,
I press F6, the widget accepts it. But it does not have any effect.

I’ve installed the system with Alsa (which was the default) instead of Pulseaudio.
could it be the reason for this issue ?

Hi Yomgui,
Although my Calculate Linux system is different - xfce iso instead of Cinnamon, pulseaudio instead of alsa, plus I am using a plugin keyboard for my notepad, not the notepad’s keyboard - maybe the following autostart instruction might help:

xbindkeys -p 

Install xbindkeys (sudo emerge xbindkeys); and then perhaps simply add that line into your autostart settings. Search online where those are for KDE; this might help.

EDIT No.1: Looking through my notes, after installing xbindkeys, you may also need to create an ~/.xbindkeysrc file by mapping your volume keys into that file. For help on how to do that, regardless of whether the distro being discussed is Gentoo-based, see here or here.

EDIT No.2: Your system is Cinnamon, not ‘KDE’, sorry. Therefore, hopefully copying an xbindkeys.desktop file into ~/.config/autostart/, as discussed here, might the way to autostart xbkindkeys in Cinnamon (or perhaps creating a xbindkeys.desktop file there) instead of adding the xbindkeys -p line into an ‘autostart’ file.

I hope this helps!