Added Grub CMDLINE gives Dracut error on boot

Good day.

I recently puchased a Lenovo Ideapad 3 laptop, and I installed Calculate Linux in it.
Everything seems to work fine, except for the touchpad on the computer, which doesn’t respond at all (well, that and the brightness Function keys not working as well, but that’s minimal).

I tried doing some digging as to why the touchpad isn’t recognize for the computer, as not even other distros have working (Ubuntu and Debian don’t have it working either).
Upon further research, I found that some possible fixes for this issue rely on including certain kernel parameters into the Grub CMDLINE, like the following:

GRUB_CMDLINE_LINUX="i8042.nopnp=1 pci=nocrs splash quiet" 

However, whenever I try to add the “pci=nocrs” parameter into the CMDLINE, the boot fails with the a Dracut error. This is my current Grub config for Calculate Linux:

			GNU GRUB  version 2.06
setparams 'Calculate Linux Desktop GNOME Adrien'

	load video
	set gfxpayload=1366x768x24,1366x768,1024x768
	insmod gzio
	insmod part_gpt
	insmod ext2
	set root='hd0,gpt6'
	if [ x$ feature_platform_search_hint = xy ]; then
	  search --no-floppy --fs-uuid --set=root --hint-bios=hd0,gpt6 --hint-efi=hd0,gpt6 --hint-baremetal-ahci0,gpt6 --hint='hd0,gpt6'  d74801fe-d052-4e89-9a64-735502b1958d
	  search --no-floppy --fs-uuid --set=root d74801fe-d052-4e89-9a64-735502b1958d
	echo	'Loading Linux 5.15.26-calculate ...'
	linux	/boot/vmlinuz-5.15.26-calculate root=UUID=d74801fe-d052-4e89-9a64-735502b1958d ro video=1366x768 resume=PARTUUID=7a448738-aad5-4b3a-a803-e0ca32ad81ae rd.retry=40 calculate=video:intel splash quiet
	echo	'Loading initial ramdisk ...'
	initrd	/boot/initramfs-5.15.26-calculate. img

And this is the Dracut error I’m getting:

dracut Warning: Cancelling resume operation. Device not found.

dracut Warning: Could not boot.

dracut Warning: /dev/disk/by-uuid/d74801fe-d052-4e89-9a64-735502b1958d does not exist

Generating "/run/initramfs/rdsosreport.txt"
You might want to save "/run/initramfs/rdsosreport.txt" to a USB stick or /boot after mounting them and attach it to a bug report.

To get more debug information in the report,
reboot with "rd.debug" added to the kernel command line.

Dropping to debug shell.

dracut:/# _

Basically, the only thing I need is to be able to boot the kernel with the “pci=nocrs” parameter added, just to test if the touchpad recognition is fixed, since I have tried several other things to no avail.

Thanks in advance!