Calculate🐧Forum

1C 8.3.10.2667 ошибка frame

#1

1C версии 8.3.10.2667 выдает ошибку “ошибка загрузки компоненты frame”
вывод ldd в прикрепленном файле

ldd.txt (6.03 KB)

#2

Разобрался сам

  1. ldd frame.so |grep not
    libwebkitgtk-1.0.so.0 => not found

2) ставим
emerge -av net-libs/webkit-gtk:2 (циферка 2 в конце имеет ОГРОМНОЕ ЗНАЧЕНИЕ)

#3

Далее

1С 64bit на CLDX 64bit завелась
Ключи есть для 1с, но прокуратура забрала сервер вместе с ключами типа на экспертизу (очередная подлянка- знаю что месяца 2 проводить будут)- поэтому пока только ломать 1С

Но вот незадача - кряка для 64bit 1С под linux НЕТ (пишут что можно виндовым пропатчить - но не сработало)

1С 32bit на CLDX 64bit ломается, но опять “ошибка загрузки компоненты frame”

Отсюда вопрос

Как собрать net-libs/webkit-gtk под 64bit системой для 32bit
флага ABI_X86 у пакета нет.
тупое копирование либ из /usr/lib64 в /usr/lib32 не помогло

#4

Решил проблему запуска 1Сv8.3 32bit на 64 битной системе
Пока криво но работает

./1cestart: error while loading shared libraries: libgssapi_krb5.so.2: cannot open shared object file: No such file or directory

ABI_X86=“64 32” emerge -av app-crypt/mit-krb5
или
в /etc/portage/package.use/custom
app-crypt/mit-krb5 abi_x86_32

ldd ./frame.so |grep not
nuke83.so => not found
libwx_gtk2u-2.9.so.2 => not found
libwebkitgtk-1.0.so.0 => not found
libsoup-2.4.so.1 => not found
stl83.so => not found
core83.so => not found
wbase.so => not found

ABI_X86=“64 32” emerge -av net-libs/libsoup
или
в /etc/portage/package.use/custom
net-libs/libsoup abi_x86_32

После запуска ./1cestart ошибки

(не важные)
Failed to load module “canberra-gtk-module”
(1cestart:24801): Gtk-WARNING ****: Загружаемый модуль тем не найден в module_path: «adwaita»,
(1cestart:24801): Gtk-WARNING ****: Загружаемый модуль тем не найден в module_path: «adwaita»,
(1cestart:24801): Gtk-WARNING ****: Загружаемый модуль тем не найден в module_path: «clearlooks»,
(1cestart:24801): Gtk-WARNING ****: Загружаемый модуль тем не найден в module_path: «clearlooks»,
(1cestart:24801): Gtk-WARNING ****: Загружаемый модуль тем не найден в module_path: «clearlooks»,
(1cestart:24801): Gtk-WARNING ****: Загружаемый модуль тем не найден в module_path: «clearlooks»

ВАЖНЫЕ ОШИБКИ

**** (1cv8c:24834): WARNING ****: Error loading plugin: /usr/lib/enchant/libenchant_myspell.so: неправильный класс ELF: ELFCLASS64

**** (1cv8c:24834): WARNING ****: The get_id method on WebKitDOMHTMLElement is deprecated. Use the one in WebKitDOMElement instead.

качаем пакет for1C_x86_32.tar.gz по ссылке https://yadi.sk/d/QkCvDxXO3QVyL4 распаковываем и кидаем в /usr/lib32

LD_PRELOAD=/usr/lib32/enchant/libenchant_myspell.so ./1cestart

ERROR: ld.so: object ‘/usr/lib32/enchant/libenchant_myspell.so’ from LD_PRELOAD cannot be preloaded (wrong ELF class: ELFCLASS32): ignored.

НО все работает без проблем

Mastodon Mastodon