Calculate Forum

Ошибка при обновлении 14.06.2021

kvaatwork kva # cl-update -C ON -e ON -R ON

Performing Global Updates
(Could take a couple of minutes if you have a lot of binary packages.)
.='update pass'  *='binary update'  #='/var/db update'  @='/var/db move'
s='/var/db SLOT move'  %='binary move'  S='binary SLOT move'
p='update /etc/portage/package.*'
/usr/portage/profiles/updates/2Q-2021.......

The following USE changes are necessary to proceed:
(see "package.use" in the portage(5) man page for more details)
# required by sys-devel/clang-runtime-11.1.0::gentoo
# required by sys-devel/clang-11.1.0::gentoo
# required by media-libs/mesa-21.0.3::gentoo[video_cards_radeon,video_cards_radeonsi,llvm,opencl,video_cards_r600,gallium]
# required by x11-libs/cairo-1.16.0-r4::gentoo[opengl]
# required by x11-libs/pango-1.48.5::gentoo
# required by dev-qt/qtwidgets-5.15.2::gentoo[gtk]
# required by dev-qt/qtsvg-5.15.2::gentoo
# required by x11-themes/calculate-icon-theme-19::calculate[qt5]
# required by @selected
# required by @world (argument)
>=sys-libs/libomp-11.1.0 -abi_x86_32
  • Выполнение Emerge завершилось с ошибкой
  • Не удалось обновить

При обновлении по emerge -vUnp --autounmask-backtrack=y @world вываливает кучу изменений по python3_9:
!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

Портежи уже давно перешли на Python 3.9. К сожалению не все ebuild-ы его поддерживают. Посмотрите какой пакет у вас препятствует обновлению.

Если я правильно понял, то:
sys-devel/clang-runtime-11.1.0::gentoo
>=sys-libs/libomp-11.1.0 -abi_x86_32

Нужно отключить поддержку 32х битности у sys-libs/libomp добавив в
/etc/portage/package.use/custom
строку
sys-libs/libomp -abi_x86_32

© 2007-2020 Calculate Ltd.
Mastodon Mastodon