10.9 installer 32bit Gnome SOLVED

With the new installer I have set 4 partitions on /dev/sda

  1. /boot 2. swap 3. / 4. /home
    install goes perfectly till reboot and then I get message
    “could not mount specified root” “/dev/sda3 is not a valid root device”.
    Please can you advise me what to do.
    I have a very good install of Gnome on 10.4 and thought I’d try 10.9 on another hard drive.

Contact with what options you have installed Calculate Linux.

Hi Alexander,
Thanks for your reply.
I created 4 partitions with fdisk /dev/sda in the terminal.
installer gui found the partitions and I formated them:
sda1 /boot ext4 400MB
sda2 swap 3000MB
sda3 / ext4 25000MB
sda4 /home ext4 222GB

installer configured defaults
added user and passwd
added root passwd
formating partitions ok
unpacking system image into target
system successfully installed
system installation complete
finish for exit
loading modules ok
activating mdev
determining root device
could not find root device
!! block device sda3 is not a valid root device
!! could not find the root block device in -
please specify another value or;
press enter for the same, type “shell” for a shell or “q” to skip.
root block device() ;; _

Alexander this is all I can think of so I hope it helps to work out where I went wrong.

Try disabling USB additional storage devices.
Try disabling any other drives.

I have no USB storage devices connected
and no other drives.
I tried another distro on these partitions and the /root was found OK.
Thanks for your help. I would like to get 10.9 working as I have had good results with 10.4.
Maybe I got a bad burn with the ISO?

Show the output of

cl-install -v
#cl-install -v
gives me this-
/bin/ash: cl-install: not found


Do you perform 'cl-install -v' from livecd?

Do you perform ‘cl-install -v’ from livecd?

No, from the shell root prompt just after the error message.
“please specify another value or;
press enter for the same, type “shell” for a shell or “q” to skip.”

Please perform this command from livecd (root user).

Ok, the command gave me a very long list of variables.
Anything special to look for?


Please, perform

cl-install -v | wgetpaste

and give received link.


Do you try load Safemode in grub? (necessarily!)
Please perform this command, and get link. (in livecd system)

cl-install -d /dev/sda1:/boot:ext4 -w /dev/sda2 -d /dev/sda3:/:ext4 -d /dev/sda4:/home:ext4 -v | wgetpaste

After install system by command

cl-install -d /dev/sda1:/boot:ext4 -w /dev/sda2 -d /dev/sda3:/:ext4 -d /dev/sda4:/home:ext4

Try load and write result.


I will try the rest of your instructions in the morning.
Thanks for your patience and help


tried this

cl-install -d /dev/sda1:/boot:ext4 -w /dev/sda2 -d /dev/sda3:/:ext4 -d /dev/sda4:/home:ext4

All went well till reboot then got exact same result as originally with gui installer

Thanks again

try use reiserfs filesystem:

cl-install -d /dev/sda1:/boot:reiserfs -w /dev/sda2 -d /dev/sda3:/:reiserfs -d /dev/sda4:/home

Did you try Safe mode in grub?

thanks again Mike
I tried this too.
cl-install -d /dev/sda1:/boot:reiserfs -w /dev/sda2 -d /dev/sda3:/:reiserfs -d /dev/sda4:/home

same result.

For Safe mode in grub do you mean to add a 3 to the end of the grub boot line in the live cd?
Sorry for my ignorance.

Try enter for the answer on message

could not mount specified root" "/dev/sda3 is not a valid root device"
  • /dev/sdb3” or “sdb3”.