Calculate Forum

Список автомагических зависимостей (обновление 07.08.2017)

Около полугода назад была решена проблема с автомагическими зависимостями. Тогда же был опубликован первый список пакетов подверженных данной проблеме. Пользователи CL активно сообщали мантейнерам Gentoo о данной проблеме и некоторые ebuild-ы были исправлены. С тех пор репозиторий бинарных пакетов вырос вдвое. Сейчас мы снова проанализировали пакеты и сформировали обновлённый список пакетов с автомагическими зависимостями.

Напомню, что в CL бинарные пакеты уже включают эти зависимости. Но тем не менее по сути это ошибки в ebuild-файлах которые следует исправить. Будем признательны за помощь в составлении багов мантейнерам Gentoo. По тем багам, которые уже есть приведены ссылки.

# app-accessibility/pocketsphinx-0.8 → media-libs/libsamplerate:0
# app-admin/elektra-0.8.15 → dev-lang/lua:0
# app-antivirus/clamav-0.99.2-r1 → dev-libs/libpcre2:0
# app-arch/star-1.5.3 → sys-libs/libcap:0
# -app-cdr/cdrtools-3.02_alpha07 → media-sound/pulseaudio:0
# app-emulation/libvirt-3.3.0 → sys-fs/lvm2:0
# app-emulation/uade-2.13 → sys-fs/fuse:0
# app-emulation/xen-tools-4.7.2 → sys-apps/pciutils:0,net-fs/libnfs:0,net-misc/vde:0,app-emulation/spice:0,sys-process/numactl:0,dev-libs/libnl:3,sys-apps/usbredir:0,app-arch/snappy:0,x11-libs/vte:0,dev-libs/cyrus-sasl:2,dev-libs/nss:0,net-libs/libssh2:0
# app-emulation/xen-tools-4.7.3 → sys-apps/pciutils:0,x11-libs/vte:0,net-fs/libnfs:0,net-misc/vde:0,sys-cluster/glusterfs:0,sys-process/numactl:0,sys-apps/dtc:0,dev-libs/libnl:3,sys-apps/usbredir:0,app-arch/snappy:0,app-emulation/spice:0,dev-libs/cyrus-sasl:2,dev-libs/nss:0,net-libs/libssh2:0
# app-i18n/freewnn-1.1.1_alpha22 → sys-apps/tcp-wrappers:0
# app-i18n/libtomoe-gtk-0.6.0-r4 → x11-libs/gtk+:2,x11-libs/pango:0,dev-libs/atk:0
# app-i18n/uim-1.8.6-r1 → app-i18n/canna:0
# app-mobilephone/gammu-1.33.0-r1 → dev-db/unixODBC:0
# app-mobilephone/obexftp-0.24-r1 → sys-fs/fuse:0
# app-office/calligra-3.0.1 → media-libs/openjpeg:0
# app-office/scribus-1.5.2-r3 → media-libs/libfreehand:0
# app-text/htmldoc-1.8.30 → net-libs/gnutls:0
# app-text/sword-1.7.4 → dev-cpp/clucene:1
# -dev-db/mysql-5.6.36 → sys-process/numactl:0
# dev-lang/erlang-19.1 → dev-db/unixODBC:0
# dev-lang/php-5.6.31 → sys-libs/libapparmor:0
# dev-lang/php-7.0.21 → sys-libs/libapparmor:0
# dev-libs/yaz-3.0.53 → net-libs/gnutls:0
# dev-python/gnome-keyring-python-2.32.0-r1 → gnome-base/libgnome-keyring:0
# dev-python/lz4-0.8.2 → app-arch/lz4:0
# dev-qt/qtsensors-5.7.1 → dev-qt/qtdbus:5
# dev-ruby/ruby-sdl-2.1.2-r2 → media-libs/sdl-image:0,media-libs/sdl-mixer:0
# dev-util/android-sdk-update-manager-24.4.1 → media-sound/pulseaudio:0,sys-libs/ncurses:5
# dev-util/android-sdk-update-manager-24.4.1 → sys-libs/ncurses:5
# dev-util/nvidia-cuda-sdk-8.0.44-r1 → sys-cluster/mpich2:0
# dev-util/systemtap-2.4-r1 → app-emulation/libvirt:0,net-dns/avahi:0,dev-libs/nss:0
# games-emulation/desmume-0.9.11-r1 → media-libs/libsoundtouch:0
# games-fps/quakeforge-0.7.2 → media-sound/jack-audio-connection-kit:0
# games-simulation/openttd-1.6.0 → dev-libs/libxdg-basedir:0
# kde-plasma/breeze-5.9.5 → kde-plasma/kdecoration:5
# kde-plasma/khotkeys-5.9.5 → kde-plasma/plasma-workspace:5
# kde-plasma/kscreen-5.9.5 → kde-plasma/libkscreen:5
# kde-plasma/ksysguard-5.9.5 → kde-plasma/libksysguard:5
# kde-plasma/kwin-5.9.5 → kde-plasma/kdecoration:5,kde-plasma/kscreenlocker:5
# kde-plasma/oxygen-5.9.5-r1 → kde-plasma/kdecoration:5
# kde-plasma/plasma-desktop-5.9.5 → kde-plasma/plasma-workspace:5
# kde-plasma/plasma-workspace-5.9.5.1-r2 → kde-plasma/libksysguard:5,kde-plasma/kscreenlocker:5
# kde-plasma/powerdevil-5.9.5 → kde-plasma/plasma-workspace:5,kde-plasma/libkscreen:5
# mail-client/evolution-3.22.6 → net-mail/ytnef:0
# -mail-client/sylpheed-3.5.1 → dev-libs/dbus-glib:0
# mate-base/caja-1.18.3 → sys-libs/libselinux:0
# mate-base/mate-applets-1.18.1 → sys-apps/apmd:0
# mate-extra/mate-user-share-1.18.0 → sys-libs/libselinux:0
# media-gfx/blender-2.76b → dev-libs/jemalloc:0
# media-gfx/gphoto2-2.5.11 → media-libs/aalib:0
# media-gfx/hugin-2016.2.0 → sci-libs/flann:0
# media-gfx/sane-frontends-1.0.14 → x11-libs/gtk+:2
# media-libs/avidemux-plugins-2.6.8 → dev-qt/qtopengl:4
# media-libs/lilv-0.24.2 → media-libs/libsndfile:0
# media-plugins/gmpc-extraplaylist-0.20.0 → gnome-base/libglade:2.0
# media-sound/abcm2ps-8.12.9 → x11-libs/pango:0
# media-sound/audacity-2.1.3-r1 → media-sound/jack-audio-connection-kit:0,media-libs/lilv:0,media-libs/suil:0
# media-sound/easytag-2.4.3 → gnome-base/nautilus:0
# media-sound/lastfmplayer-1.5.4.27091-r3 → dev-qt/qtdbus:4
# media-sound/mixxx-2.0.0-r4 → media-libs/opusfile:0
# media-sound/patchage-0.5.0-r1 → dev-libs/dbus-glib:0
# media-sound/qmidiroute-0.4.0 → dev-qt/qtwidgets:5
# media-sound/terminatorx-3.84-r1 → media-sound/jack-audio-connection-kit:0
# media-sound/timidity**-2.14.0-r2 → x11-libs/libXaw3d:0
# media-sound/zynaddsubfx-3.0.1-r1 → media-sound/jack-audio-connection-kit:0,media-libs/portaudio:0
# media-tv/plex-media-server-1.5.6 → media-tv/linuxtv-dvb-apps:0
# media-video/avidemux-2.6.8 → dev-qt/qtopengl:4
# media-video/dirac-1.0.2-r1 → dev-util/cppunit:0
# net-analyzer/echoping-6.0.2_p434-r2 → net-nds/openldap:0
# net-analyzer/icinga2-2.6.3-r1 → dev-libs/yajl:0
# net-firewall/fwbuilder-5.0.1.3592-r1 → net-analyzer/net-snmp:0
# net-fs/netatalk-3.1.11 → dev-db/mysql:0
# net-fs/samba-4.5.10 → dev-util/lttng-ust:0
# net-im/vacuum-1.2.5 → dev-qt/qtwebkit:4
# net-misc/hotot-0.9.8.15_p20150812-r2 → dev-qt/qtwebkit:4
# net-misc/iperf-3.1.3 → net-misc/lksctp-tools:0
# net-misc/modem-manager-gui-0.0.18 → app-text/gtkspell:3
# net-misc/spice-gtk-0.33-r2 → app-arch/lz4:0
# net-proxy/squid-3.5.23 → net-libs/libnetfilter_conntrack:0
# net-vpn/openconnect-7.08 → app-crypt/trousers:0
# sci-libs/io_lib-1.10.1 → net-misc/curl:0
# sci-libs/openfoam-2.3.1-r1 → dev-libs/boost:0
# sci-libs/parmetis-3.2.0 → sys-cluster/mpich2:0
# sci-libs/parmgridgen-1.0 → sys-cluster/mpich2:0
# sys-apps/biosdevname-0.7.2 → sys-apps/pciutils:0
# sys-cluster/cluster-glue-1.0.12 → net-analyzer/net-snmp:0
# sys-cluster/pacemaker-1.1.16 → net-libs/gnutls:0
# sys-devel/gdb-7.12.1 → dev-util/babeltrace:0
# sys-fs/ntfs3g-2016.2.22-r2 → sys-apps/hwinfo:0
# sys-libs/glibc-2.23-r4 → media-libs/gd:2
# -www-client/elinks-0.12_pre6-r1 → dev-libs/tre:0
# www-client/otter-0.9.12 → dev-qt/qtwebengine:5
# www-client/uget-1.10.3 → dev-libs/libappindicator:3
# www-plugins/chrome-binary-plugins-60.0.3112.78 → dev-libs/nss:0
# x11-apps/xdm-1.1.11-r3 → x11-libs/libXft:0
# x11-drivers/xf86-input-acecad-1.5.0 → sys-fs/sysfsutils:0
# x11-libs/fltk-1.3.3-r3 → x11-libs/libXcursor:0
# x11-libs/fox-1.7.54 → x11-libs/libXi:0
# x11-misc/light-locker-1.4.0-r3 → x11-libs/libXScrnSaver:0,x11-libs/libXxf86misc:0
# x11-misc/wdm-1.28-r4 → sys-libs/libselinux:0
# x11-misc/x11vnc-0.9.14_p20161013 → x11-libs/libXcursor:0,x11-libs/libXcomposite:0
# x11-misc/x2vnc-1.7.2-r1 → x11-libs/libXxf86dga:0,x11-libs/libXrandr:0
# x11-misc/xlockmore-5.50 → media-sound/rplay:0
# x11-plugins/wmacpi-2.3 → x11-libs/libdockapp:0
# x11-plugins/wmbattery-2.50 → sys-apps/apmd:0
# x11-plugins/wmcms-0.3.5-r2 → x11-libs/libdockapp:0
# x11-plugins/wmgtemp-1.0-r1 → sys-apps/lm_sensors:0
# x11-plugins/wmnd-0.4.16 → net-analyzer/net-snmp:0
# x11-terms/mlterm-3.8.0 → sys-libs/libutempter:0
# x11-wm/openbox-3.6.1 → x11-libs/libXcursor:0
# x11-wm/windowmaker-0.95.7 → media-libs/libexif:0
# x11-wm/xpra-1.0.4-r1 → media-libs/libvpx:0,x11-libs/libxkbfile:0
# x11-wm/xpra-2.0.2 → x11-libs/libxkbfile:0
# xfce-extra/xfce4-soundmenu-plugin-0.7.0 → x11-libs/libnotify:0

Mastodon Mastodon