zfs on CLDX

Hey Guys,

even if I use linux for a couple of years (privat and jobwise) I am new to CL (and gentoo) as well, so please be gentle. :slight_smile:
I really like the clean approach of gentoo and therefore CL.

I got a little confused. On pure gentoo I am able to install zfs like a charm.
On CL (DX) I got this error:

checking kernel build directory... /lib/modules/3.8.4-calculate/build
checking kernel source version... 3.8.4-calculate
checking kernel file name for module symbols... configure: error: 
    *** Please make sure the kernel devel package for your distribution
    *** is installed.  If your building with a custom kernel make sure the
    *** kernel is configured, built, and the '--with-linux=PATH' configure
    *** option refers to the location of the kernel source.

I emerged calculate-sources make gcc and I donโ€™t see what I am missing here.
But maybe I just miss the forest for the trees.



If you need to recompile your kernel, foremost you must recompile your kernel one-shot with -minimal like that :

USE="-minimal" emerge -qv calculate-sources


XKomodor | Julien