Calculate Forum

Unable to boot into new install/ UEFI Booting on New Install

Hi, all.

I’m an occasional Gentoo user, starting back in 2004, on SparcStation20. :slight_smile:

I’m really impressed by Calculate, and want to install it on a Dell Latitude E7440.

I’m having problems booting. I have completed the installation many times, but I have not been able to boot back into the new install, due to the OS not being found. I’ve tried a combination of UEFI and Legacy boot from my BIOS settings, and have tried auto partitioning and manual partitioning. Whatever I do, I am unble to boot into the OS. I also tried the Gentoo wiki, regarding GPT

The laptop is a 1.9 GHz Intel i5, 240GB HDD, with 8 gigs of RAM.

I’d prefer to have a separate /home, but my main thing is to just get Calculate running, so I can use it.

Can anyone help?

Thanks,

Chris.

BIOS settings:

IMG_20200519_102637|666x500
IMG_20200519_102730|666x500

Hi Chris,
First of all it’s not clear from your bios screenshots - did you disable Secure Boot feature as recommended for using legacy oprom? If not, now it’s time to do it. It can be bold cause of the boot problem.

Also I suggest you to try EFI boot if you prefer GPT. For traditional boot (as on screenshot with boot partition and Active flag set on it) usually you need a MBR partition table. And - no offence - but you made partitions damn wrong. That one on /dev/sda1 not needed, ext2 boot partition first, then swap, then root, and make separate partition at least for home.

Anyway, you can use autopartitioning feature on installer. It will erase all the disk but you’ll got best results automagically.

Hi, Amotsarack.

Many thanks for your reply; it’s really appreciated.

I just checked, and in the BIOS settings, Secure Boot is already Disabled.

I agree, the partition layout is not good, but having tried everything else (several automagic installations), I just used an example from the Gentoo wiki.

I am more than happy to use whichever boot method works, and am not excited by GPT, MBR is fine.

I’ll do a fresh install, from my BIOS setup, does Calculate prefer Legacy or UEFI boot? I’ve tried both before, but I may as well work through it a step at a time, and see where things are going wrong.

Many thanks,

Chris.

Hi Chris,

Well, from my experience, Gentoo WIKI have some mistakes and obsolete things, so just don’t blindly trust it.
Which one to select - for modern systems UEFI usually recommended, but it slightly more difficult to install and maintain. So, you have free choice for future, but now let’s make alive what we have for now.
On your Dell you can have another source of boot problem - the SATA controller mode. Check this out in BIOS, and if you find Matrix Raid or something like that - you should change mode to ACHI (or SATA if AHCI not available).

Thanks, amotsarack.

You make some good points. I’ve checked the SATA controller setting and that is OK. I’ve just started a fresh install, and have enabled UEFI in the BIOS, and deselected the ‘Legacy ROM’ option. I’m going to try a new automagic install, now.

Thanks,

Chris.

No idea why, but this time it booted fine. Updating are applying, now.

Chris.

Hi Chris,

Great job, congrats!
I suspect cause of that mess in selection of right mode for install. If legacy oprom was enabled you can boot LiveDisk in UEFI or Legacy mode, so installer in Legacy mode can’t correctly install system to UEFI mode, but if you start LiveDisk in UEFI mode installer can offer you a choice which one boot method you like. And if you keep installer defaults you will get correct UEFI installation, with GPT, every partitions on place, etc. So you disabled legacy oprom, started in UEFI and get good result using default settings for installer.

I think the only other thing I did, was to create a new GPT partition table, as part of the install.

I tried to mark this topic as [SOLVED], but wasn’t able to edit the topic title. Thank you for your help.

Chris

© 2007-2020 Calculate Ltd.
Mastodon Mastodon