Calculate Forum

КриптоПро

Yuri . wrote:

Владимир Кариков wrote:

файл linux-amd64.tgz с http://www.cryptopro.ru/ скачал и положил в /var/calculate/remote/distfiles
может что не так ?
[…]
Имейте в виду, что cprocsp-rdr-uec и lsb-cprocsp-fkc отсутствуют в архиве КриптоПРО CSP 3.9, а cprocsp-npcades - более старой версии.
Их можно запросить в поддержке КриптоПРО как “КриптоПРО УЭК CSP”, либо (если вам не нужна УЭК часть) не устанавливать метапакет cryptopro-uec, а ставить пакеты отдельно.

На сайте www.cryptopro.ru в личном кабинете не нашел этих пакетов cprocsp-rdr-uec и lsb-cprocsp-fkc

Владимир Кариков wrote:

На сайте www.cryptopro.ru в личном кабинете не нашел этих пакетов cprocsp-rdr-uec и lsb-cprocsp-fkc

Их там нет. Вы сами процитировали мои слова:

Yuri . wrote:

Имейте в виду, что cprocsp-rdr-uec и lsb-cprocsp-fkc отсутствуют в архиве КриптоПРО CSP 3.9, а cprocsp-npcades - более старой версии.
Их можно запросить в поддержке КриптоПРО как “КриптоПРО УЭК CSP”, либо (если вам не нужна УЭК часть) не устанавливать метапакет cryptopro-uec, а ставить пакеты отдельно.

Мне предоставили необходимый дистрибутив в течение 1 рабочего дня.

А а Вас нет ебилда что бы просто поставить КриптоПРО CSP из этого файла linux-amd64.tgz

Alexander Pilipenko wrote:

app-crypt/lsb-cprocsp-rdr-3.9.0 конфликтует с dev-libs/jemalloc потому что в нем тоже содержится файл /usr/lib64/libjemalloc.so, наверно имеет смысл не копировать этот файл и добавить зависимость от dev-libs/jemalloc

Насколько я вижу, библиотека кастомизирована (есть символы cp*), врядли это поможет.
Попробуйте app-crypt/lsb-cprocsp-rdr-3.9.0-r1 - я добавил удаление симлинка libjemalloc.so. Т. к. для libcpalloc.so требуется libjemalloc.so.0 - это не должно быть проблемой.
Если все же проблемы появятся, то добавлю блокировку.

Владимир Кариков wrote:

А а Вас нет ебилда что бы просто поставить КриптоПРО CSP из этого файла linux-amd64.tgz

Нет. Это - не “Gentoo way”. Из этого файла можно все установить и без ебилдов.

Драйвер считывателя надо ставить ? и как ?
у меня ACR38U-NEO а на сайте http://www.uec-reader.ru/drivers/ только для Debian, Fedora, openSUSE, Ubuntu :frowning:

Владимир Кариков wrote:

Драйвер считывателя надо ставить ? и как ?
у меня ACR38U-NEO а на сайте http://www.uec-reader.ru/drivers/ только для Debian, Fedora, openSUSE, Ubuntu :frowning:

Попробуйте свободный app-crypt/ccid (USE флаг ccid пакета app-crypt/cprocsp-rdr-pcsc):

grep -i acr /usr/lib/readers/usb/ifd-ccid.bundle/Contents/Info.plist 
        <string>ACS ACR 38U-CCID</string>
        <string>ACS ACR101 ICC Reader</string>
        <string>ACS ACR122U PICC Interface</string>

Yuri . wrote:

Попробуйте свободный app-crypt/ccid (USE флаг ccid пакета app-crypt/cprocsp-rdr-pcsc):

Еще есть app-crypt/acr38u

Yuri . wrote:

Yuri . wrote:

Еще есть app-crypt/acr38u
Спасибо попробую, но под виндой он у меня так и не заработал, то есть КриптоПро CSP его не видит в упор, хотя с eToken все работает.

Yuri . wrote:

Владимир Кариков wrote:

На сайте www.cryptopro.ru в личном кабинете не нашел этих пакетов cprocsp-rdr-uec и lsb-cprocsp-fkc

Мне предоставили необходимый дистрибутив в течение 1 рабочего дня.
Видать Вам повезло, на запрос молчат как рыбы.

еще один конфликт: файл /usr/bin/certmgr из app-crypt/lsb-cprocsp-capilite конфликтует с пакетом dev-lang/mono-2.10.9-r2

Alexander Pilipenko wrote:

еще один конфликт: файл /usr/bin/certmgr из app-crypt/lsb-cprocsp-capilite конфликтует с пакетом dev-lang/mono-2.10.9-r2

Исправил в lsb-cprocsp-capilite-3.9.0-r1: https://github.com/nE0sIghT/vortex-overlay/commit/d0ff139e762d88a56d3ce69bd3d5a5e75a996b65

Yuri Konotopov wrote:

Я занимаюсь написанием ебилдов для КриптоПРО УЭК.
Текущая работа доступна в ветке cryptopro оверлея vortex: https://github.com/nE0sIghT/vortex-overlay/commits/cryptopro

Приветствую, Юрий!
Вот уже не первый год пытаюсь найти решение в части Крипто-ПРО CSP теперь уже и в части работы носителя RUToken. В этой связи подскажите, если сможете относительно сборки пакетов из Вашего оверлея vortex. Конкретно, интересует невозможность сборки некоторых пакетов в Кальке, например … --> http://pastebin.com/8uDcbSyn , при этом пакет lsb-cprocsp-fkc-64-3.9.0-4.x86_64.rpm , полученный из архива cryptopro.ru находится в /var/calculate/remote/distfiles/ http://pastebin.com/RiyE4anp. Однако, надо полагать, что необходимо скорректировать ebuild? Или я неправильо понимаю решение своего вопроса, подскажите…?

Станислав Сухоруков wrote:

В этой связи подскажите, если сможете относительно сборки пакетов из Вашего оверлея vortex.

Приветствую.

sha256sum lsb-cprocsp-fkc-64-3.9.0-4.x86_64.rpm что показывает?
Если не “8b37…a657”, то КриптоПРО в очередной раз заменили пакет без изменения версии - нужно перегенерировать хеши пакетов - “ebuild …ebuild digest”

Сделал как Вы рекомендовали… Однако, все по-прежнему → http://pastebin.com/00m4pDfG
И теперь уже и ebuild…ebuild digest перестало отрабатывать(( При этом меняет имя файла в distfiles → http://pastebin.com/KhcxxpFG
а вывод интересующей команды (после замены на исходник с cryptopro.ru)таков → sha256sum lsb-cprocsp-fkc-64-3.9.0-4.x86_64.rpm
b36e7d3632e8085c1efea77018dec8b37af6a06c9a6e4ead84b28311397dca0d lsb-cprocsp-fkc-64-3.9.0-4.x86_64.rpm
Кстати архив распаковываю стандартной командой tar -xvzf linux-amd64.tgz
Видимо что-то не так делаю?

Станислав Сухоруков wrote:

Сделал как Вы рекомендовали… Однако, все по-прежнему

Владелец lsb-cprocsp-fkc-64-3.9.0-4.x86_64.rpm - portage:portage?
В файле Manifest после выполнения digest - верный хеш?

Yuri Konotopov wrote:

Станислав Сухоруков wrote:

Сделал как Вы рекомендовали… Однако, все по-прежнему

Владелец lsb-cprocsp-fkc-64-3.9.0-4.x86_64.rpm - portage:portage?
да, владелец portage:portage
В файле Manifest после выполнения digest - верный хеш?
вообщем, ОнО собралось, только после удаления Manifest-a, и еще раз e-build…ebuild digest -->
emerge app-crypt/lsb-cprocsp-fkc

Еще вопрос касается гуевого интерфейса Крипто-ПРО, есть ли какие-то наработки у Вас или в сети может видели…? Гугль особенно ничего не говорит по этой части. Однако, есть таковая необходимость Клиентам не в строке мучаться и смотреть/устанавливать подробности КЭП (ЭЦП) а именно в гуях…

Да вот же недавно было на опеннете: https://www.opennet.ru/opennews/art.shtml?num=45410

Yuri Konotopov wrote:

Да вот же недавно было на опеннете: https://www.opennet.ru/opennews/art.shtml?num=45410

Хорошая статейка, однако требуется подсобить по возможности с инсталляцией RUToken…
Например почему-то токен виден, но только без имени устройства http://pastebin.com/EJVBR9gx и далее видимо продолжением ошибки чтения сертификата получается → http://pastebin.com/Bk9fhJzb
Может какой-то пакет(ы) не установлены ?
В системе есть вот это → http://pastebin.com/EKP7cfFG
От части сам же и поясняю ответ на свой вопрос…
На http://www.cryptopro.ru/products/cpfox описаны какие пакеты необходимы для работы Крипто-ПРО CSP. И потому вопрос остается но в части пакета app-crypt/lsb-cprocsp-pkcs11, и адаптированного под российские средства криптографии клон браузера firefox - КриптоПРО fox…
А может, то что в системе доступны пакеты http://pastebin.com/Kh8SVsxX, какая-то часть из них является аналогом пока неустановленного в системе пекета app-crypt/lsb-cprocsp-pkcs11. То есть осталось понять выпиливал ли кто либо e-build-ы под эти два пакета (благо исходники под CentOS и RedHat вроде доступны)? В таком случае надо полагать, что КриптоПРО CSP должна будет взлететь, так как остальные пакеты установлены в системе …))) Кто же займется ebuild-о писательством…?
Верно ли я понимаю, Юрий?

Приветствую, Александр!
Если есть Возможность и Желание, то я прошу у Вас помощи в параллельной теме все про тот же КриптоПРО CSP. Подскажите если сможете. Ссылка здесь

© 2007-2020 Calculate Ltd.
Mastodon Mastodon