Calculate Forum

КриптоПро

Ну и ладно, меня больше занимает как установить Крипто Про inux-ia32.tgz,
как поставить там есть install.sh - им ? или через rpm ? или нужен ebuild ?
Коллективный разум - помоги, или ткни носом в нужную страницу :-))

Владимир Кариков wrote:

На офф. сайте нашел такое
Либо Вы добиваетесь сответствия Вашего Линукса стандарту LSB 3.1 либо выбираете из списка
Вопрос, а соответствует Наш Линукс этому стандарту ?

Не Наш, а Gentoo.
И нет, не соответствует. Но формально. Фактически - по большей части соответствует. Но, к сожалению, я так и не смог объяснить это некоему софту типа КриптоПро

Владимир Кариков wrote:

Ну и ладно, меня больше занимает как установить Крипто Про inux-ia32.tgz,
как поставить там есть install.sh - им ? или через rpm ? или нужен ebuild ?
Коллективный разум - помоги, или ткни носом в нужную страницу :-))

Попробуй сперва установить “в ручном” режиме, с помощью install.sh
А затем уж можешь написать и ebuild =)

с помощью install.sh не получится, нужно каждую рпмку ставить через rpm -i --nodeps (за исключением пары штук каких то, определить что ставить можно как раз почитав install.sh), а потом уже запускать из /opt то что поставится и по ошибкам определять недостающие зависимости

Alexander Pilipenko wrote:

с помощью install.sh не получится

Я этот install не видел в глаза :slight_smile:
Но, думаю, что его в принципе возможно переработать…

Владимир Кариков wrote:

Кто нибудь ставил сей продукт http://www.cryptopro.ru в кальке ?
поделитесь опытом

Всем Привет!

А есть ли на текущий момент новости в этой теме (Установка Крипто ПРО) и в частности ветка CSP? Очень уж Важный вопрос! Поделитесь кто может? Лучше бы конечно через ebuild, дабы не ломать систему. Ну а если нет тогда уж как есть…? Гугл вроде молчит, так же впрочем как и сами http://www.cryptopro.ru/forum2/default.aspx?g=forum Заранее Благодарю!

Я ставил, но опять же только с целью тестирования работы с УЭК. Потом забросил на полпути, приложил ебилд, его нужно немного подправить под нужный вариант установки (я его под тестовую версию писал) так что если кому то нужно можете доработать.

cprocsp-3.9.0.ebuild (1004 Bytes)

Alexander Pilipenko wrote:

ебилд, нужно немного подправить под нужный вариант установки (я его под тестовую версию писал) так что если кому то нужно можете доработать.

Уважаемый Александр подскажите что и где нужно доработать в ебилде чтобы установить пакеты Крипто Про linux-amd64.tgz или linux-ia32.tgz

Я занимаюсь написанием ебилдов для КриптоПРО УЭК.
Текущая работа доступна в ветке cryptopro оверлея vortex: https://github.com/nE0sIghT/vortex-overlay/commits/cryptopro

Этот ебилд для КриптоПРО УЭК или с eToken тоже работает ?

За основу взят дистрибутив КриптоПРО УЭК CSP, полученный от КриптоПРО 4 дня назад.
Пакеты внутри, предполагаю, идентичны КриптоПРО CSP 3.9.

УЭК-специфичная часть должна быть только в ебилде cryptopro-uek.

Работа пока не завершена - браузерный плагин завести еще не удалось

Владимир Кариков wrote:

Этот ебилд для КриптоПРО УЭК или с eToken тоже работает ?

Я сравнил дистрибутивы УЭК и CSP 3.9/Browser plugin 1.5

В дистрибутиве УЭК - более свежие билды Browser plugin, поэтому контрольные суммы по 4 ебилдам сходиться не будут для скаченного дистрибутива с сайта КриптоПРО.
Пакеты CSP 3.9 - идентичны, но в дистрибутиве УЭК некоторые отсутствуют (например, модуль ядра) - соответственно, в моём оверлее ебилдов для этих пакетов нет. При желании - можно легко написать по аналогии с уже созданными, используя cryptopro.eclass.

Т.е. по плагину - можно запросить в КриптоПРО дистрибутив УЭК или пересчитать контрольные суммы для более старой версии 1.5
По CSP - вполне можно использовать ебилды не только для УЭК, но не стоит устанавливать пакет cryptopro-uec.

Я перенес все изменения из ветки cryptopro в основную - как я вижу, сейчас все работает корректно. В файрфоксе браузерный плагин не работает, но это, видимо, проблема совместимости ибо в Opera 12 плагин подхватывается корректно.

Т. о. сейчас установка КриптоПРО УЭК в Gentoo также проста как 2 команды:
layman -a vortex
emerge cryptopro-uec

Yuri . wrote:

Я занимаюсь написанием ебилдов для КриптоПРО УЭК.
Текущая работа доступна в ветке cryptopro оверлея vortex: https://github.com/nE0sIghT/vortex-overlay/commits/cryptopro

Приветствую Вас, Уважаемый!
Ранее я уже интересовался в этом же посте, относительно установки версии КриптоПро CSP 3.6 R4 для Linux (x64).
Если у Вас имеется таковая возможность, направьте меня пожалуйста, в части установки именного этого варианта CSP? (так как есть приобретенная лицензия) Я имею ввиду выложите пожалуйста ebuild и необходимые для установки пакеты? Или черкните пожалуйста в личку?
При многом Вам Благодарен!

Станислав Сухоруков wrote:

Если у Вас имеется таковая возможность, направьте меня пожалуйста, в части установки именного этого варианта CSP? (так как есть приобретенная лицензия) Я имею ввиду выложите пожалуйста ebuild и необходимые для установки пакеты? Или черкните пожалуйста в личку?

Добрый день.

Я не думаю, что версия 3.9 (в части установки) сильно отличается от 3.6.
Попробуйте сделать ебилды на основе моих - в eclass многие вещи автоматизировал, поэтому ебилды могут быть очень простыми. Как пример: https://github.com/nE0sIghT/vortex-overlay/blob/master/app-crypt/lsb-cprocsp-cades/lsb-cprocsp-cades-3.9.0.ebuild.

Вас понял. Буду пробовать.

Yuri . wrote:

Владимир Кариков wrote:

Этот ебилд для КриптоПРО УЭК или с eToken тоже работает ?
Т. о. сейчас установка КриптоПРО УЭК в Gentoo также проста как 2 команды:

emerge cryptopro-uec

Не все так просто вот что вылазит
http://pastebin.calculate-linux.ru/en/show/10786

файл linux-amd64.tgz с http://www.cryptopro.ru/ скачал и положил в /var/calculate/remote/distfiles
может что не так ?

Владимир Кариков wrote:

файл linux-amd64.tgz с http://www.cryptopro.ru/ скачал и положил в /var/calculate/remote/distfiles
может что не так ?

 *  1. Visit https://www.cryptopro.ru/
 *  2. Download proper *linux_*.tar.gz archive
 *  3. Unpack following file to $DISTDIR:
 *     
 *  cprocsp-rdr-uec-64-3.9.0-4.x86_64.rpm

Как и написано в инструкции - нужно копировать в $DISTDIR не сам *tar.gz файл, а распаковать требуемый .rpm.

Имейте в виду, что cprocsp-rdr-uec и lsb-cprocsp-fkc отсутствуют в архиве КриптоПРО CSP 3.9, а cprocsp-npcades - более старой версии.
Их можно запросить в поддержке КриптоПРО как “КриптоПРО УЭК CSP”, либо (если вам не нужна УЭК часть) не устанавливать метапакет cryptopro-uec, а ставить пакеты отдельно.

app-crypt/lsb-cprocsp-rdr-3.9.0 конфликтует с dev-libs/jemalloc потому что в нем тоже содержится файл /usr/lib64/libjemalloc.so, наверно имеет смысл не копировать этот файл и добавить зависимость от dev-libs/jemalloc

Yuri . wrote:

Владимир Кариков wrote:

файл linux-amd64.tgz с http://www.cryptopro.ru/ скачал и положил в /var/calculate/remote/distfiles
может что не так ?
[…]
Имейте в виду, что cprocsp-rdr-uec и lsb-cprocsp-fkc отсутствуют в архиве КриптоПРО CSP 3.9, а cprocsp-npcades - более старой версии.
Их можно запросить в поддержке КриптоПРО как “КриптоПРО УЭК CSP”, либо (если вам не нужна УЭК часть) не устанавливать метапакет cryptopro-uec, а ставить пакеты отдельно.

На сайте www.cryptopro.ru в личном кабинете не нашел этих пакетов cprocsp-rdr-uec и lsb-cprocsp-fkc

Владимир Кариков wrote:

На сайте www.cryptopro.ru в личном кабинете не нашел этих пакетов cprocsp-rdr-uec и lsb-cprocsp-fkc

Их там нет. Вы сами процитировали мои слова:

Yuri . wrote:

Имейте в виду, что cprocsp-rdr-uec и lsb-cprocsp-fkc отсутствуют в архиве КриптоПРО CSP 3.9, а cprocsp-npcades - более старой версии.
Их можно запросить в поддержке КриптоПРО как “КриптоПРО УЭК CSP”, либо (если вам не нужна УЭК часть) не устанавливать метапакет cryptopro-uec, а ставить пакеты отдельно.

Мне предоставили необходимый дистрибутив в течение 1 рабочего дня.

© 2007-2020 Calculate Ltd.
Mastodon Mastodon