И опять обновление

Так Вы сейчас какой версией “LibreOffice” пользуетесь?

У Вас этот пакет замаскирован (Я опускаю указание версий):
dev-util/mdds
а он нужен для этого пакета:
app-text/libetonyek

Проверьте обратные зависимости для:
app-text/libetonyek
проанализируйте ответ (там наверняка как раз и окажется “LibreOffice”) и, возможно, попробуйте его удалить.

Version: 7.3.1.1 / LibreOffice Community
Build ID: 30(Build:1)
CPU threads: 6; OS: Linux 5.15; UI render: default; VCL: kf5 (cairo+xcb)
Locale: ru-RU (ru_RU.utf8); UI: ru-RU
Gentoo official package
Calc: threaded

eix libreoffice
Спойлер

guest@calculate ~ $ eix libreoffice
[?] app-office/libreoffice
Доступные версии: 7.2.5.2-r1^t{tbz2} ~7.2.6.2^t **7.2.9999l^t **7.3.1.3^t **7.3.9999l^t **9999*l^t {accessibility base bluetooth +branding clang coinmp +cups custom-cflags +dbus debug eds firebird googledrive gstreamer +gtk java kde ldap +mariadb odk pdfimport postgres test vulkan LIBREOFFICE_EXTENSIONS=“nlpsolver scripting-beanshell scripting-javascript wiki-publisher” PYTHON_SINGLE_TARGET=“python3_8 python3_9 python3_10”}
Установленные версии: 7.3.1.1-r1^t(14:51:13 25.02.2022)(bluetooth cups dbus gstreamer gtk kde mariadb odk pdfimport vulkan -accessibility -base -branding -clang -coinmp -custom-cflags -debug -eds -firebird -googledrive -java -ldap -postgres -test LIBREOFFICE_EXTENSIONS="-nlpsolver -scripting-beanshell -scripting-javascript -wiki-publisher" PYTHON_SINGLE_TARGET=“python3_9 -python3_8 -python3_10”)
Домашняя страница: https://www.libreoffice.org
Описание: A full office productivity suite

  • app-office/libreoffice-bin
    Доступные версии: 7.2.5.2^st {gnome java kde PYTHON_SINGLE_TARGET="+python3_9"}
    Домашняя страница: https://www.libreoffice.org
    Описание: A full office productivity suite. Binary package

  • app-office/libreoffice-bin-debug
    Доступные версии: 7.2.5.2^st {gnome java kde}
    Домашняя страница: https://www.libreoffice.org
    Описание: LibreOffice, a full office productivity suite. Binary package, debug info

[?] app-office/libreoffice-l10n
Доступные версии: 7.2.5.2^s{tbz2} ~7.2.6.2^s ~7.3.1.3^s {offlinehelp L10N=“af am ar as ast be bg bn bn-IN bo br brx bs ca ca-valencia ckb cs cy da de dgo dsb dz el en en-GB en-ZA eo es et eu fa fi fr fur fy ga gd gl gu gug he hi hr hsb hu id is it ja ka kab kk km kmr-Latn kn ko kok ks lb lo lt lv mai mk ml mn mni mr my nb ne nl nn nr nso oc om or pa pl pt pt-BR ro ru rw sa sat sd si sid sk sl sq sr sr-Latn ss st sv sw-TZ szl ta te tg th tn tr ts tt ug uk uz ve vec vi xh zh-CN zh-TW zu”}
Установленные версии: 7.3.1.1^s(13:20:59 25.02.2022)(-offlinehelp L10N=“be bg bs cs da de el en es et fi fr hr hu it kk lt lv nl pl pt pt-BR ro ru sk sl sq sr sv uk -af -am -ar -as -ast -bn -bn-IN -bo -br -brx -ca -ca-valencia -ckb -cy -dgo -dsb -dz -en-GB -en-ZA -eo -eu -fa -fur -fy -ga -gd -gl -gu -gug -he -hi -hsb -id -is -ja -ka -kab -km -kmr-Latn -kn -ko -kok -ks -lb -lo -mai -mk -ml -mn -mni -mr -my -nb -ne -nn -nr -nso -oc -om -or -pa -rw -sa -sat -sd -si -sid -sr-Latn -ss -st -sw-TZ -szl -ta -te -tg -th -tn -tr -ts -tt -ug -uz -ve -vec -vi -xh -zh-CN -zh-TW -zu”)
Домашняя страница: https://www.libreoffice.org
Описание: Translations for the Libreoffice suite

[1] “calculate” /var/db/repos/calculate

Найдено 6 совпадение.

Спасибо за подсказки. Попробую с удалением вариант.

$ equery g app-office/libreoffice-7.3.1.3:0 | grep -i mdds
 [  1]  dev-util/mdds-9999

$ equery g app-office/libreoffice-7.2.5.2-r1:0 | grep -i mdds
 [  1]  dev-util/mdds-1.7.0

1 Like

Сегодня и вчера обновился на 2 машинах. Вот лог с одной:

2022-03-21 17:04:48,110 - packages - system-config-printer-1.5.16.tbz2,ptyprocess-0.7.0.tbz2,pycups-2.0.1.tbz2,pip-21.3.1-r1.tbz2,distro-1.6.0.tbz2,strict-rfc3339-0.7-r1.tbz2,tomli-2.0.0.tbz2,notify2-0.3.1-r2.tbz2,importlib_metadata-4.10.1.tbz2,charset_normalizer-2.0.11.tbz2,paramiko-2.9.2.tbz2,python-dotenv-0.19.2-r1.tbz2,calculate-sources-5.15.26.tbz2,wpa_supplicant-2.10.tbz2,ffmpeg-4.4.1-r2.tbz2
2022-03-21 17:04:51,249 - distfiles - gimp-2.10.24.tar.bz2,gegl-0.4.32.tar.xz,paramiko-2.9.2.tar.gz,pip-21.3.1.tar.gz,.mirror-cache.json,gsettings-desktop-schemas-40.0.tar.xz,python-gentoo-patches-2.7.18_p13.tar.xz,skypeforlinux_8.78.0.161-1.x86_64.rpm,binutils-2.37_p1-patches-0.tar.xz,gtk-update-icon-cache-3.24.30.tar.bz2,libgphoto2-2.5.27.tar.bz2,babl-0.1.86.tar.xz,glib-2.70.2.tar.xz,gegl-0.4.30.tar.xz,pangomm-2.42.2.tar.xz,tomli-2.0.0.gh.tar.gz,at-spi2-core-2.40.3.tar.xz,NetworkManager-openvpn-1.8.12.tar.xz,xdg-dbus-proxy-0.1.2.tar.xz,wpa_supplicant-2.9-r3-patches.tar.bz2,librsvg-2.50.7.tar.xz,libqmi-1.30.2.tar.xz,itstool-2.0.6.tar.bz2,pango-1.48.10.tar.xz,fribidi-1.0.10.tar.xz,rhash-1.3.6-src.tar.gz,libsecret-0.20.4.tar.xz,accountsservice-0.6.55.tar.xz,adwaita-icon-theme-40.1.1.tar.xz,.layout.conf.distfiles.gentoo.org,importlib_metadata-4.10.1.tar.gz,ModemManager-1.18.4.tar.xz,charset_normalizer-2.0.11.gh.tar.gz,patch-5.15.26.xz,wpa_supplicant-2.9.tar.gz,tomli-2.0.0-py3-none-any.whl.zip,distro-1.6.0.tar.gz,gtk+-3.24.30.tar.xz,system-config-printer-1.5.15.tar.xz,NetworkManager-openvpn-1.8.14.tar.xz

Из списка wifi сетей исчез мой роутер Xiaomi. При переходе с двух сетей на одну 2.4ГГц он в списке появляется. После попытки подключения пропал снова.
Другие сети в доме видятся. К телефону подключается.

Mar 21 22:14:14 kvaatwork NetworkManager[4577]: <info>  [1647893654.4264] device (wlan0): set-hw-addr: set MAC address to AA:7C:77:4D:E3:3D (scanning)
Mar 21 22:14:14 kvaatwork NetworkManager[4577]: <info>  [1647893654.6407] manager: NetworkManager state is now DISCONNECTED
Mar 21 22:14:14 kvaatwork NetworkManager[4577]: <info>  [1647893654.6415] device (wlan0): supplicant interface state: completed -> disconnected
Mar 21 22:14:14 kvaatwork NetworkManager[4577]: <info>  [1647893654.6416] device (wlan0): supplicant interface state: disconnected -> interface_disabled
Mar 21 22:14:14 kvaatwork NetworkManager[4577]: <info>  [1647893654.6493] device (wlan0): supplicant interface state: interface_disabled -> disconnected
Mar 21 22:14:16 kvaatwork NetworkManager[4577]: <info>  [1647893656.6217] device (wlan0): Activation: starting connection 'Xiaomi_9DD6' (c87133e7-b849-4ab0-8b25-9c175751ddd8)
Mar 21 22:14:16 kvaatwork NetworkManager[4577]: <info>  [1647893656.6218] audit: op="connection-activate" uuid="c87133e7-b849-4ab0-8b25-9c175751ddd8" name="Xiaomi_9DD6" pid=5064 uid=1001 result="success"
Mar 21 22:14:16 kvaatwork NetworkManager[4577]: <info>  [1647893656.6220] device (wlan0): state change: disconnected -> prepare (reason 'none', sys-iface-state: 'managed')
Mar 21 22:14:16 kvaatwork NetworkManager[4577]: <info>  [1647893656.6227] manager: NetworkManager state is now CONNECTING
Mar 21 22:14:16 kvaatwork NetworkManager[4577]: <info>  [1647893656.6524] device (wlan0): set-hw-addr: reset MAC address to B0:48:7A:93:56:FB (preserve)
Mar 21 22:14:16 kvaatwork NetworkManager[4577]: <info>  [1647893656.8660] device (wlan0): state change: prepare -> config (reason 'none', sys-iface-state: 'managed')
Mar 21 22:14:16 kvaatwork NetworkManager[4577]: <info>  [1647893656.8661] device (wlan0): Activation: (wifi) access point 'Xiaomi_9DD6' has security, but secrets are required.
Mar 21 22:14:16 kvaatwork NetworkManager[4577]: <info>  [1647893656.8661] device (wlan0): state change: config -> need-auth (reason 'none', sys-iface-state: 'managed')
Mar 21 22:14:16 kvaatwork NetworkManager[4577]: <info>  [1647893656.8665] device (wlan0): supplicant interface state: disconnected -> interface_disabled
Mar 21 22:14:16 kvaatwork NetworkManager[4577]: <info>  [1647893656.8671] device (wlan0): state change: need-auth -> prepare (reason 'none', sys-iface-state: 'managed')
Mar 21 22:14:16 kvaatwork NetworkManager[4577]: <info>  [1647893656.8672] device (wlan0): state change: prepare -> config (reason 'none', sys-iface-state: 'managed')
Mar 21 22:14:16 kvaatwork NetworkManager[4577]: <info>  [1647893656.8673] device (wlan0): Activation: (wifi) connection 'Xiaomi_9DD6' has security, and secrets exist.  No new secrets needed.
Mar 21 22:14:16 kvaatwork NetworkManager[4577]: <info>  [1647893656.8673] Config: added 'ssid' value 'Xiaomi_9DD6'
Mar 21 22:14:16 kvaatwork NetworkManager[4577]: <info>  [1647893656.8673] Config: added 'scan_ssid' value '1'
Mar 21 22:14:16 kvaatwork NetworkManager[4577]: <info>  [1647893656.8673] Config: added 'bgscan' value 'simple:30:-70:86400'
Mar 21 22:14:16 kvaatwork NetworkManager[4577]: <info>  [1647893656.8674] Config: added 'key_mgmt' value 'WPA-PSK WPA-PSK-SHA256 FT-PSK SAE FT-SAE'
Mar 21 22:14:16 kvaatwork NetworkManager[4577]: <info>  [1647893656.8674] Config: added 'psk' value '<hidden>'
Mar 21 22:14:16 kvaatwork NetworkManager[4577]: <info>  [1647893656.8711] device (wlan0): supplicant interface state: interface_disabled -> disconnected
Mar 21 22:14:16 kvaatwork NetworkManager[4577]: <info>  [1647893656.9651] device (wlan0): supplicant interface state: disconnected -> scanning
Mar 21 22:14:42 kvaatwork NetworkManager[4577]: <warn>  [1647893682.5230] device (wlan0): Activation: (wifi) association took too long, failing activation
Mar 21 22:14:42 kvaatwork NetworkManager[4577]: <info>  [1647893682.5230] device (wlan0): state change: config -> failed (reason 'ssid-not-found', sys-iface-state: 'managed')
Mar 21 22:14:42 kvaatwork NetworkManager[4577]: <info>  [1647893682.5236] manager: NetworkManager state is now DISCONNECTED
Mar 21 22:14:42 kvaatwork NetworkManager[4577]: <info>  [1647893682.6390] device (wlan0): set-hw-addr: set MAC address to 46:18:9A:08:04:21 (scanning)
Mar 21 22:14:42 kvaatwork NetworkManager[4577]: <warn>  [1647893682.8522] device (wlan0): Activation: failed for connection 'Xiaomi_9DD6'
Mar 21 22:14:42 kvaatwork NetworkManager[4577]: <info>  [1647893682.8523] device (wlan0): supplicant interface state: scanning -> disconnected
Mar 21 22:14:42 kvaatwork NetworkManager[4577]: <info>  [1647893682.8523] device (wlan0): supplicant interface state: disconnected -> interface_disabled
Mar 21 22:14:42 kvaatwork NetworkManager[4577]: <info>  [1647893682.8525] device (wlan0): state change: failed -> disconnected (reason 'none', sys-iface-state: 'managed')
Mar 21 22:14:42 kvaatwork NetworkManager[4577]: <info>  [1647893682.8583] device (wlan0): supplicant interface state: interface_disabled -> disconnected
Mar 21 22:14:56 kvaatwork NetworkManager[4577]: <info>  [1647893696.8517] audit: op="connection-delete" uuid="c87133e7-b849-4ab0-8b25-9c175751ddd8" name="Xiaomi_9DD6" pid=9015 uid=1001 result="fail" reason="Error checking authorization: connection was deleted"
Mar 21 22:14:56 kvaatwork NetworkManager[4577]: <info>  [1647893696.8518] audit: op="connection-delete" uuid="c87133e7-b849-4ab0-8b25-9c175751ddd8" name="Xiaomi_9DD6" pid=9015 uid=1001 result="success"

Как вариант.
Для версии libreoffice-7.3.1.1 возможно (не знаю) версия mdds-2.0.2 и работала.
А затем в mdds-9999 внесли пару +100500 патчей (возможно), что пришлось “экстренно” (по плану) выпускать libreoffice-7.3.1.3. Нового ебилда mdds делать не хотят/не успели - эксперимент не закончился.

Для текущего стабильного требуемого Либрой app-text/libetonyek версия mdds вроде не важна. А вот в ебилдах dev-libs/libixion видно, что версии 9999 и требуют размаскировать mdds-9999.

Наверно осталось определить, какому пакету (и с какого рожна) сдалась “сиюминутная” libixion

Хех, и Меня беда-печаль посетила…

Что-то с такой ошибкой, на “CLDX” при обновлении, сборка “open-cv” падает (ниже “полный” вывод ошибки):

Спойлер
 # emerge --ask --update --deep @world

Local copy of remote index is up-to-date and will be used.

Local copy of remote index is up-to-date and will be used.

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild  N     ] media-libs/opencv-4.5.5-r1  USE="contrib contribdnn eigen features2d ffmpeg gphoto2 gstreamer ieee1394 jpeg jpeg2k openexr opengl openmp png python qt5 threads tiff v4l vaapi webp (-contribcvv) -contribfreetype (-contribhdf) (-contribovis) (-contribsfm) (-contribxfeatures2d) (-cuda) -debug -dnnsamples -download -examples -gdal (-gflags) (-glog) -gtk3 -java -lapack -lto -opencl -opencvapps (-tesseract) -testprograms (-vtk) -xine" ABI_X86="(64) -32 (-x32)" CPU_FLAGS_X86="sse sse2 sse3 -avx -avx2 -avx512f -f16c -fma3 -popcnt -sse4_1 -sse4_2 -ssse3" PYTHON_TARGETS="python3_9 -python3_8 -python3_10"

Would you like to merge these packages? [Yes/No] y
>>> Verifying ebuild manifests
>>> Running pre-merge checks for media-libs/opencv-4.5.5-r1
>>> Emerging (1 of 1) media-libs/opencv-4.5.5-r1::gentoo
>>> Failed to emerge media-libs/opencv-4.5.5-r1, Log file:
>>>  '/var/calculate/tmp/portage/media-libs/opencv-4.5.5-r1/temp/build.log'
>>> Jobs: 0 of 1 complete, 1 failed                 Load avg: 1.27, 1.15, 1.05
 * Package:    media-libs/opencv-4.5.5-r1
 * Repository: gentoo
 * Maintainer: amynka@gentoo.org
 * USE:        abi_x86_64 amd64 contrib contribdnn cpu_flags_x86_sse cpu_flags_x86_sse2 cpu_flags_x86_sse3 eigen elibc_glibc features2d ffmpeg gphoto2 gstreamer ieee1394 jpeg jpeg2k kernel_linux openexr opengl openmp png python python_targets_python3_9 qt5 threads tiff userland_GNU v4l vaapi webp
 * FEATURES:   network-sandbox preserve-libs sandbox usersandbox
>>> Unpacking source...
>>> Unpacking opencv-4.5.5.tar.gz to /var/calculate/tmp/portage/media-libs/opencv-4.5.5-r1/work
>>> Unpacking opencv-4.5.5_contrib.tar.gz to /var/calculate/tmp/portage/media-libs/opencv-4.5.5-r1/work
>>> Unpacking opencv-3.4.0-face_landmark_model.tar.gz to /var/calculate/tmp/portage/media-libs/opencv-4.5.5-r1/work
>>> Source unpacked in /var/calculate/tmp/portage/media-libs/opencv-4.5.5-r1/work
>>> Preparing source in /var/calculate/tmp/portage/media-libs/opencv-4.5.5-r1/work/opencv-4.5.5 ...
 * Source directory (CMAKE_USE_DIR): "/var/calculate/tmp/portage/media-libs/opencv-4.5.5-r1/work/opencv-4.5.5"
 * Build directory  (BUILD_DIR):     "/var/calculate/tmp/portage/media-libs/opencv-4.5.5-r1/work/opencv-4.5.5_build"
 * Applying opencv-3.4.0-disable-download.patch ...
patching file CMakeLists.txt
Hunk #1 succeeded at 214 with fuzz 1 (offset 27 lines).
patching file cmake/OpenCVDownload.cmake
Hunk #1 succeeded at 38 with fuzz 1 (offset 6 lines).
Hunk #2 succeeded at 252 (offset 15 lines).
 [ ok ]
 * Applying opencv-3.4.1-cuda-add-relaxed-constexpr.patch ...
 [ ok ]
 * Applying opencv-4.1.2-opencl-license.patch ...
 [ ok ]
 * Applying opencv-4.4.0-disable-native-cpuflag-detect.patch ...
 [ ok ]
 * Applying opencv-4.5.0-link-with-cblas-for-lapack.patch ...
 [ ok ]
 * Hardcoded definition(s) removed in CMakeLists.txt:
 *    set(CMAKE_BUILD_TYPE "Release" CACHE STRING "Choose the type of build")
 *        set(CMAKE_INSTALL_PREFIX "${CMAKE_BINARY_DIR}/install" CACHE PATH "Inst
 *        set(CMAKE_INSTALL_PREFIX "/usr/local" CACHE PATH "Installation Director
 *      set(CMAKE_INSTALL_PREFIX "${CMAKE_BINARY_DIR}/install" CACHE PATH "Instal
>>> Source prepared.
>>> Configuring source in /var/calculate/tmp/portage/media-libs/opencv-4.5.5-r1/work/opencv-4.5.5 ...
 * abi_x86_64.amd64: running multilib-minimal_abi_src_configure
 * Source directory (CMAKE_USE_DIR): "/var/calculate/tmp/portage/media-libs/opencv-4.5.5-r1/work/opencv-4.5.5"
 * Build directory  (BUILD_DIR):     "/var/calculate/tmp/portage/media-libs/opencv-4.5.5-r1/work/opencv-4.5.5_build-abi_x86_64.amd64"
cmake -C /var/calculate/tmp/portage/media-libs/opencv-4.5.5-r1/work/opencv-4.5.5_build-abi_x86_64.amd64/gentoo_common_config.cmake -G Ninja -DCMAKE_INSTALL_PREFIX=/usr -DENABLE_DOWNLOAD=no -DWITH_QUIRC=OFF -DWITH_1394=yes -DWITH_VTK=no -DWITH_EIGEN=yes -DWITH_VFW=OFF -DWITH_FFMPEG=yes -DWITH_GSTREAMER=yes -DWITH_GSTREAMER_0_10=OFF -DWITH_GTK=no -DWITH_GTK_2_X=OFF -DWITH_IPP=OFF -DWITH_JASPER=OFF -DWITH_JPEG=yes -DWITH_OPENJPEG=yes -DWITH_WEBP=yes -DWITH_OPENEXR=yes -DWITH_OPENGL=yes -DWITH_OPENVX=OFF -DWITH_OPENNI=OFF -DWITH_OPENNI2=OFF -DWITH_PNG=yes -DWITH_GDCM=OFF -DWITH_PVAPI=OFF -DWITH_GIGEAPI=OFF -DWITH_ARAVIS=OFF -DWITH_QT=5 -DWITH_WIN32UI=OFF -DWITH_TBB=yes -DWITH_OPENMP=yes -DWITH_CSTRIPES=OFF -DWITH_PTHREADS_PF=ON -DWITH_TIFF=yes -DWITH_UNICAP=OFF -DWITH_V4L=yes -DWITH_LIBV4L=yes -DWITH_MSMF=OFF -DWITH_XIMEA=OFF -DWITH_XINE=no -DWITH_CLP=OFF -DWITH_OPENCL=no -DWITH_OPENCL_SVM=OFF -DWITH_OPENCLAMDFFT=no -DWITH_OPENCLAMDBLAS=no -DWITH_DIRECTX=OFF -DWITH_INTELPERC=OFF -DWITH_IPP_A=OFF -DWITH_MATLAB=OFF -DWITH_VA=yes -DWITH_VA_INTEL=yes -DWITH_GDAL=no -DWITH_GPHOTO2=yes -DWITH_LAPACK=no -DWITH_ITT=OFF -DWITH_CUDA=no -DWITH_CUBLAS=no -DWITH_CUFFT=no -DWITH_NVCUVID=OFF -DCUDA_NPP_LIBRARY_ROOT_DIR= -DBUILD_SHARED_LIBS=ON -DBUILD_JAVA=no -DBUILD_ANDROID_EXAMPLES=OFF -DBUILD_opencv_apps=OFF -DBUILD_DOCS=OFF -DBUILD_EXAMPLES=no -DBUILD_PERF_TESTS=OFF -DBUILD_TESTS=no -DBUILD_WITH_DEBUG_INFO=no -DBUILD_WITH_DYNAMIC_IPP=OFF -DBUILD_FAT_JAVA_LIB=OFF -DBUILD_CUDA_STUBS=no -DOPENCV_EXTRA_MODULES_PATH=/var/calculate/tmp/portage/media-libs/opencv-4.5.5-r1/work/opencv_contrib-4.5.5/modules -DINSTALL_CREATE_DISTRIB=OFF -DINSTALL_C_EXAMPLES=no -DINSTALL_TESTS=no -DINSTALL_PYTHON_EXAMPLES=no -DINSTALL_TO_MANGLED_PATHS=OFF -DOPENCV_GENERATE_PKGCONFIG=ON -DLIB_SUFFIX= -DENABLE_CCACHE=OFF -DENABLE_PRECOMPILED_HEADERS=OFF -DENABLE_SOLUTION_FOLDERS=OFF -DENABLE_PROFILING=OFF -DENABLE_COVERAGE=OFF -DHAVE_opencv_java=NO -DENABLE_NOISY_WARNINGS=OFF -DOPENCV_WARNINGS_ARE_ERRORS=OFF -DENABLE_IMPL_COLLECTION=OFF -DENABLE_INSTRUMENTATION=OFF -DGENERATE_ABI_DESCRIPTOR=OFF -DDOWNLOAD_EXTERNAL_TEST_DATA=OFF -DENABLE_LTO=no -DBUILD_PACKAGE=OFF -DBUILD_PROTOBUF=OFF -DPROTOBUF_UPDATE_FILES=ON -DCMAKE_SKIP_RPATH=ON -DOPENCV_DOC_INSTALL_PATH= -DBUILD_opencv_features2d=ON -DOPENCV_CPU_OPT_IMPLIES_IGNORE=ON -DCPU_BASELINE=SSE;SSE2;SSE3; -DCPU_DISPATCH= -DBUILD_opencv_dnn=ON -DTINYDNN_ROOT=/var/calculate/tmp/portage/media-libs/opencv-4.5.5-r1/work/tiny-dnn-1.0.0a3 -DBUILD_opencv_dnns_easily_fooled=OFF -DBUILD_opencv_xfeatures2d=OFF -DBUILD_opencv_cvv=OFF -DBUILD_opencv_hdf=OFF -DBUILD_opencv_sfm=OFF -DBUILD_opencv_freetype=OFF -DBUILD_opencv_ovis=OFF -DCMAKE_DISABLE_FIND_PACKAGE_Tesseract=yes -DPYTHON_EXECUTABLE=OFF -DINSTALL_PYTHON_EXAMPLES=OFF -DBUILD_opencv_python2=OFF -DBUILD_opencv_python3=OFF -DCMAKE_BUILD_TYPE=Gentoo -DCMAKE_TOOLCHAIN_FILE=/var/calculate/tmp/portage/media-libs/opencv-4.5.5-r1/work/opencv-4.5.5_build-abi_x86_64.amd64/gentoo_toolchain.cmake /var/calculate/tmp/portage/media-libs/opencv-4.5.5-r1/work/opencv-4.5.5
loading initial cache file /var/calculate/tmp/portage/media-libs/opencv-4.5.5-r1/work/opencv-4.5.5_build-abi_x86_64.amd64/gentoo_common_config.cmake
-- The CXX compiler identification is GNU 11.2.1
-- The C compiler identification is GNU 11.2.1
-- Detecting CXX compiler ABI info
-- Detecting CXX compiler ABI info - done
-- Check for working CXX compiler: /usr/bin/x86_64-pc-linux-gnu-g++ - skipped
-- Detecting CXX compile features
-- Detecting CXX compile features - done
-- Detecting C compiler ABI info
-- Detecting C compiler ABI info - done
-- Check for working C compiler: /usr/bin/x86_64-pc-linux-gnu-gcc - skipped
-- Detecting C compile features
-- Detecting C compile features - done
-- Detected processor: x86_64
-- Could NOT find PythonInterp (missing: PYTHON_EXECUTABLE) (Required is at least version "2.7")
-- Found PythonInterp: /usr/bin/python (found suitable version "3.9.9", minimum required is "3.2")
-- Found PythonLibs: /usr/lib64/libpython3.9.so (found suitable exact version "3.9.9")
-- Performing Test HAVE_CXX_FSIGNED_CHAR
-- Performing Test HAVE_CXX_FSIGNED_CHAR - Success
-- Performing Test HAVE_C_FSIGNED_CHAR
-- Performing Test HAVE_C_FSIGNED_CHAR - Success
-- Performing Test HAVE_CXX_W
-- Performing Test HAVE_CXX_W - Success
-- Performing Test HAVE_C_W
-- Performing Test HAVE_C_W - Success
-- Performing Test HAVE_CXX_WALL
-- Performing Test HAVE_CXX_WALL - Success
-- Performing Test HAVE_C_WALL
-- Performing Test HAVE_C_WALL - Success
-- Performing Test HAVE_CXX_WERROR_RETURN_TYPE
-- Performing Test HAVE_CXX_WERROR_RETURN_TYPE - Success
-- Performing Test HAVE_C_WERROR_RETURN_TYPE
-- Performing Test HAVE_C_WERROR_RETURN_TYPE - Success
-- Performing Test HAVE_CXX_WERROR_NON_VIRTUAL_DTOR
-- Performing Test HAVE_CXX_WERROR_NON_VIRTUAL_DTOR - Success
-- Performing Test HAVE_C_WERROR_NON_VIRTUAL_DTOR
-- Performing Test HAVE_C_WERROR_NON_VIRTUAL_DTOR - Failed
-- Performing Test HAVE_CXX_WERROR_ADDRESS
-- Performing Test HAVE_CXX_WERROR_ADDRESS - Success
-- Performing Test HAVE_C_WERROR_ADDRESS
-- Performing Test HAVE_C_WERROR_ADDRESS - Success
-- Performing Test HAVE_CXX_WERROR_SEQUENCE_POINT
-- Performing Test HAVE_CXX_WERROR_SEQUENCE_POINT - Success
-- Performing Test HAVE_C_WERROR_SEQUENCE_POINT
-- Performing Test HAVE_C_WERROR_SEQUENCE_POINT - Success
-- Performing Test HAVE_CXX_WFORMAT
-- Performing Test HAVE_CXX_WFORMAT - Success
-- Performing Test HAVE_C_WFORMAT
-- Performing Test HAVE_C_WFORMAT - Success
-- Performing Test HAVE_CXX_WERROR_FORMAT_SECURITY
-- Performing Test HAVE_CXX_WERROR_FORMAT_SECURITY - Success
-- Performing Test HAVE_C_WERROR_FORMAT_SECURITY
-- Performing Test HAVE_C_WERROR_FORMAT_SECURITY - Success
-- Performing Test HAVE_CXX_WMISSING_DECLARATIONS
-- Performing Test HAVE_CXX_WMISSING_DECLARATIONS - Success
-- Performing Test HAVE_C_WMISSING_DECLARATIONS
-- Performing Test HAVE_C_WMISSING_DECLARATIONS - Success
-- Performing Test HAVE_CXX_WMISSING_PROTOTYPES
-- Performing Test HAVE_CXX_WMISSING_PROTOTYPES - Failed
-- Performing Test HAVE_C_WMISSING_PROTOTYPES
-- Performing Test HAVE_C_WMISSING_PROTOTYPES - Success
-- Performing Test HAVE_CXX_WSTRICT_PROTOTYPES
-- Performing Test HAVE_CXX_WSTRICT_PROTOTYPES - Failed
-- Performing Test HAVE_C_WSTRICT_PROTOTYPES
-- Performing Test HAVE_C_WSTRICT_PROTOTYPES - Success
-- Performing Test HAVE_CXX_WUNDEF
-- Performing Test HAVE_CXX_WUNDEF - Success
-- Performing Test HAVE_C_WUNDEF
-- Performing Test HAVE_C_WUNDEF - Success
-- Performing Test HAVE_CXX_WINIT_SELF
-- Performing Test HAVE_CXX_WINIT_SELF - Success
-- Performing Test HAVE_C_WINIT_SELF
-- Performing Test HAVE_C_WINIT_SELF - Success
-- Performing Test HAVE_CXX_WPOINTER_ARITH
-- Performing Test HAVE_CXX_WPOINTER_ARITH - Success
-- Performing Test HAVE_C_WPOINTER_ARITH
-- Performing Test HAVE_C_WPOINTER_ARITH - Success
-- Performing Test HAVE_CXX_WSHADOW
-- Performing Test HAVE_CXX_WSHADOW - Success
-- Performing Test HAVE_C_WSHADOW
-- Performing Test HAVE_C_WSHADOW - Success
-- Performing Test HAVE_CXX_WSIGN_PROMO
-- Performing Test HAVE_CXX_WSIGN_PROMO - Success
-- Performing Test HAVE_C_WSIGN_PROMO
-- Performing Test HAVE_C_WSIGN_PROMO - Failed
-- Performing Test HAVE_CXX_WUNINITIALIZED
-- Performing Test HAVE_CXX_WUNINITIALIZED - Success
-- Performing Test HAVE_C_WUNINITIALIZED
-- Performing Test HAVE_C_WUNINITIALIZED - Success
-- Performing Test HAVE_CXX_WSUGGEST_OVERRIDE
-- Performing Test HAVE_CXX_WSUGGEST_OVERRIDE - Success
-- Performing Test HAVE_C_WSUGGEST_OVERRIDE
-- Performing Test HAVE_C_WSUGGEST_OVERRIDE - Failed
-- Performing Test HAVE_CXX_WNO_DELETE_NON_VIRTUAL_DTOR
-- Performing Test HAVE_CXX_WNO_DELETE_NON_VIRTUAL_DTOR - Success
-- Performing Test HAVE_C_WNO_DELETE_NON_VIRTUAL_DTOR
-- Performing Test HAVE_C_WNO_DELETE_NON_VIRTUAL_DTOR - Failed
-- Performing Test HAVE_CXX_WNO_UNNAMED_TYPE_TEMPLATE_ARGS
-- Performing Test HAVE_CXX_WNO_UNNAMED_TYPE_TEMPLATE_ARGS - Failed
-- Performing Test HAVE_C_WNO_UNNAMED_TYPE_TEMPLATE_ARGS
-- Performing Test HAVE_C_WNO_UNNAMED_TYPE_TEMPLATE_ARGS - Failed
-- Performing Test HAVE_CXX_WNO_COMMENT
-- Performing Test HAVE_CXX_WNO_COMMENT - Success
-- Performing Test HAVE_C_WNO_COMMENT
-- Performing Test HAVE_C_WNO_COMMENT - Success
-- Performing Test HAVE_CXX_WIMPLICIT_FALLTHROUGH_3
-- Performing Test HAVE_CXX_WIMPLICIT_FALLTHROUGH_3 - Success
-- Performing Test HAVE_C_WIMPLICIT_FALLTHROUGH_3
-- Performing Test HAVE_C_WIMPLICIT_FALLTHROUGH_3 - Success
-- Performing Test HAVE_CXX_WNO_STRICT_OVERFLOW
-- Performing Test HAVE_CXX_WNO_STRICT_OVERFLOW - Success
-- Performing Test HAVE_C_WNO_STRICT_OVERFLOW
-- Performing Test HAVE_C_WNO_STRICT_OVERFLOW - Success
-- Performing Test HAVE_CXX_FDIAGNOSTICS_SHOW_OPTION
-- Performing Test HAVE_CXX_FDIAGNOSTICS_SHOW_OPTION - Success
-- Performing Test HAVE_C_FDIAGNOSTICS_SHOW_OPTION
-- Performing Test HAVE_C_FDIAGNOSTICS_SHOW_OPTION - Success
-- Performing Test HAVE_CXX_WNO_LONG_LONG
-- Performing Test HAVE_CXX_WNO_LONG_LONG - Success
-- Performing Test HAVE_C_WNO_LONG_LONG
-- Performing Test HAVE_C_WNO_LONG_LONG - Success
-- Performing Test HAVE_CXX_PTHREAD
-- Performing Test HAVE_CXX_PTHREAD - Success
-- Performing Test HAVE_C_PTHREAD
-- Performing Test HAVE_C_PTHREAD - Success
-- Performing Test HAVE_CXX_FOMIT_FRAME_POINTER
-- Performing Test HAVE_CXX_FOMIT_FRAME_POINTER - Success
-- Performing Test HAVE_C_FOMIT_FRAME_POINTER
-- Performing Test HAVE_C_FOMIT_FRAME_POINTER - Success
-- Performing Test HAVE_CXX_FFUNCTION_SECTIONS
-- Performing Test HAVE_CXX_FFUNCTION_SECTIONS - Success
-- Performing Test HAVE_C_FFUNCTION_SECTIONS
-- Performing Test HAVE_C_FFUNCTION_SECTIONS - Success
-- Performing Test HAVE_CXX_FDATA_SECTIONS
-- Performing Test HAVE_CXX_FDATA_SECTIONS - Success
-- Performing Test HAVE_C_FDATA_SECTIONS
-- Performing Test HAVE_C_FDATA_SECTIONS - Success
-- Performing Test HAVE_CXX_MSSE (check file: cmake/checks/cpu_sse.cpp)
-- Performing Test HAVE_CXX_MSSE - Success
-- Performing Test HAVE_CXX_MSSE2 (check file: cmake/checks/cpu_sse2.cpp)
-- Performing Test HAVE_CXX_MSSE2 - Success
-- Performing Test HAVE_CXX_MSSE3 (check file: cmake/checks/cpu_sse3.cpp)
-- Performing Test HAVE_CXX_MSSE3 - Success
-- Performing Test HAVE_CPU_BASELINE_FLAGS
-- Performing Test HAVE_CPU_BASELINE_FLAGS - Success
-- Performing Test HAVE_CXX_FVISIBILITY_HIDDEN
-- Performing Test HAVE_CXX_FVISIBILITY_HIDDEN - Success
-- Performing Test HAVE_C_FVISIBILITY_HIDDEN
-- Performing Test HAVE_C_FVISIBILITY_HIDDEN - Success
-- Performing Test HAVE_CXX_FVISIBILITY_INLINES_HIDDEN
-- Performing Test HAVE_CXX_FVISIBILITY_INLINES_HIDDEN - Success
-- Performing Test HAVE_C_FVISIBILITY_INLINES_HIDDEN
-- Performing Test HAVE_C_FVISIBILITY_INLINES_HIDDEN - Failed
-- Performing Test HAVE_LINK_AS_NEEDED
-- Performing Test HAVE_LINK_AS_NEEDED - Success
-- Looking for pthread.h
-- Looking for pthread.h - found
-- Looking for posix_memalign
-- Looking for posix_memalign - found
-- Looking for malloc.h
-- Looking for malloc.h - found
-- Looking for memalign
-- Looking for memalign - found
-- Found OpenMP_C: -fopenmp (found version "4.5")
-- Found OpenMP_CXX: -fopenmp (found version "4.5")
-- Found OpenMP: TRUE (found version "4.5")
-- Found ZLIB: /usr/lib64/libz.so (found suitable version "1.2.11", minimum required is "1.2.3")
-- Found JPEG: /usr/lib64/libjpeg.so (found version "62")
-- Found TIFF: /usr/lib64/libtiff.so (found version "4.3.0")
-- Found WebP: /usr/lib64/libwebp.so
-- Found system OpenJPEG: openjp2 (found version "")
-- Found ZLIB: /usr/lib64/libz.so (found version "1.2.11")
-- Found PNG: /usr/lib64/libpng.so (found version "1.6.37")
-- Looking for /usr/include/libpng/png.h
-- Looking for /usr/include/libpng/png.h - not found
CMake Error at cmake/OpenCVFindLibsGUI.cmake:17 (find_package):
  Could not find a package configuration file provided by "Qt5" with any of
  the following names:

    Qt5Config.cmake
    qt5-config.cmake

  Add the installation prefix of "Qt5" to CMAKE_PREFIX_PATH or set "Qt5_DIR"
  to a directory containing one of the above files.  If "Qt5" provides a
  separate development package or SDK, be sure it has been installed.
Call Stack (most recent call first):
  cmake/OpenCVFindLibsGUI.cmake:42 (ocv_find_package_Qt)
  CMakeLists.txt:730 (include)


-- Configuring incomplete, errors occurred!
See also "/var/calculate/tmp/portage/media-libs/opencv-4.5.5-r1/work/opencv-4.5.5_build-abi_x86_64.amd64/CMakeFiles/CMakeOutput.log".
See also "/var/calculate/tmp/portage/media-libs/opencv-4.5.5-r1/work/opencv-4.5.5_build-abi_x86_64.amd64/CMakeFiles/CMakeError.log".
 * ERROR: media-libs/opencv-4.5.5-r1::gentoo failed (configure phase):
 *   cmake failed
 *
 * Call stack:
 *     ebuild.sh, line  127:  Called src_configure
 *   environment, line 5787:  Called cmake-multilib_src_configure
 *   environment, line 1469:  Called multilib-minimal_src_configure
 *   environment, line 4474:  Called multilib_foreach_abi 'multilib-minimal_abi_src_configure'
 *   environment, line 4724:  Called multibuild_foreach_variant '_multilib_multibuild_wrapper' 'multilib-minimal_abi_src_configure'
 *   environment, line 4429:  Called _multibuild_run '_multilib_multibuild_wrapper' 'multilib-minimal_abi_src_configure'
 *   environment, line 4427:  Called _multilib_multibuild_wrapper 'multilib-minimal_abi_src_configure'
 *   environment, line  726:  Called multilib-minimal_abi_src_configure
 *   environment, line 4468:  Called multilib_src_configure
 *   environment, line 4959:  Called cmake_src_configure
 *   environment, line 1730:  Called die
 * The specific snippet of code:
 *       "${CMAKE_BINARY}" "${cmakeargs[@]}" "${CMAKE_USE_DIR}" || die "cmake failed";
 *
 * If you need support, post the output of `emerge --info '=media-libs/opencv-4.5.5-r1::gentoo'`,
 * the complete build log and the output of `emerge -pqv '=media-libs/opencv-4.5.5-r1::gentoo'`.
!!! When you file a bug report, please include the following information:
GENTOO_VM=  CLASSPATH="" JAVA_HOME=""
JAVACFLAGS="" COMPILER=""
and of course, the output of emerge --info =opencv-4.5.5
 * The complete build log is located at '/var/calculate/tmp/portage/media-libs/opencv-4.5.5-r1/temp/build.log'.
 * The ebuild environment file is located at '/var/calculate/tmp/portage/media-libs/opencv-4.5.5-r1/temp/environment'.
 * Working directory: '/var/calculate/tmp/portage/media-libs/opencv-4.5.5-r1/work/opencv-4.5.5_build-abi_x86_64.amd64'
 * S: '/var/calculate/tmp/portage/media-libs/opencv-4.5.5-r1/work/opencv-4.5.5'

 * Messages for package media-libs/opencv-4.5.5-r1:

 * ERROR: media-libs/opencv-4.5.5-r1::gentoo failed (configure phase):
 *   cmake failed
 *
 * Call stack:
 *     ebuild.sh, line  127:  Called src_configure
 *   environment, line 5787:  Called cmake-multilib_src_configure
 *   environment, line 1469:  Called multilib-minimal_src_configure
 *   environment, line 4474:  Called multilib_foreach_abi 'multilib-minimal_abi_src_configure'
 *   environment, line 4724:  Called multibuild_foreach_variant '_multilib_multibuild_wrapper' 'multilib-minimal_abi_src_configure'
 *   environment, line 4429:  Called _multibuild_run '_multilib_multibuild_wrapper' 'multilib-minimal_abi_src_configure'
 *   environment, line 4427:  Called _multilib_multibuild_wrapper 'multilib-minimal_abi_src_configure'
 *   environment, line  726:  Called multilib-minimal_abi_src_configure
 *   environment, line 4468:  Called multilib_src_configure
 *   environment, line 4959:  Called cmake_src_configure
 *   environment, line 1730:  Called die
 * The specific snippet of code:
 *       "${CMAKE_BINARY}" "${cmakeargs[@]}" "${CMAKE_USE_DIR}" || die "cmake failed";
 *
 * If you need support, post the output of `emerge --info '=media-libs/opencv-4.5.5-r1::gentoo'`,
 * the complete build log and the output of `emerge -pqv '=media-libs/opencv-4.5.5-r1::gentoo'`.
 * The complete build log is located at '/var/calculate/tmp/portage/media-libs/opencv-4.5.5-r1/temp/build.log'.
 * The ebuild environment file is located at '/var/calculate/tmp/portage/media-libs/opencv-4.5.5-r1/temp/environment'.
 * Working directory: '/var/calculate/tmp/portage/media-libs/opencv-4.5.5-r1/work/opencv-4.5.5_build-abi_x86_64.amd64'
 * S: '/var/calculate/tmp/portage/media-libs/opencv-4.5.5-r1/work/opencv-4.5.5'

Ниже “вывод” покороче:

Спойлер
# cl-update
Синхронизация репозиториев
 * Проверка текущего сервера обновлений ...                                                                                                                                                                                                                                   [ ok ]
 * Проверка обновлений Distros ...                                                                                                                                                                                                                                            [ ok ]
 * Проверка обновлений Calculate ...                                                                                                                                                                                                                                          [ ok ]
 * Проверка обновлений Gentoo ...                                                                                                                                                                                                                                             [ ok ]
 * Обновление индекса пакетов ...                                                                                                                                                                                                                                             [ ok ]
 * Проверка подписи индекса пакетов ...                                                                                                                                                                                                                                       [ ok ]
 * Синхронизация репозитория Linuxbuh ...                                                                                                                                                                                                                                     [ ok ]
 * Обновление кэша репозитория Distros ...                                                                                                                                                                                                                                    [ ok ]
 * Обновление кэша репозитория Calculate ...
 * У репозитория Linuxbuh есть свой кэш
 * Обновление кэша eix для репозиториев Linuxbuh, Distros, Calculate, Gentoo ...                                                                                                                                                                                              [ ok ]
 * Обновление кэша настраиваемых пакетов ...                                                                                                                                                                                                                                  [ ok ]
 * Удаление устаревших архивов и бинарных пакетов ...                                                                                                                                                                                                                         [ ok ]
 * Синхронизация завершена
Конфигурация системы
 * Сервер обновлений http://miroir.linuxtricks.fr/calculate
 * Исправление настроек ...                                                                                                                                                                                                                                                   [ ok ]
 * Обновление конфигурационных файлов ...                                                                                                                                                                                                                                     [ ok ]
Обновление пакетов
 * Вычисление зависимостей ...
 * Список пакетов для установки
 * Набор различных алгоритмов компьютерного зрения и примеров кода (N) media-libs/opencv-4.5.5-r1 (0 KiB)
 * 1 пакетов будет установлено, 0 KiB будет загружено

Вы хотите установить эти пакеты? (Yes/No): y
 * Получение пакетов... ...                                                                                                                                                                                                                                                   [ ok ]
 * (1 из 1) Набор различных алгоритмов компьютерного зрения и примеров кода
 * Сборка media-libs/opencv-4.5.5-r1 ...                                                                                                                                                                                                                                      [ ok ]
See also "/var/calculate/tmp/portage/media-libs/opencv-4.5.5-r1/work/opencv-4.5.5_build-abi_x86_64.amd64/CMakeFiles/CMakeError.log".
 * ERROR: media-libs/opencv-4.5.5-r1::gentoo failed (configure phase):
 *   cmake failed
 *
 * Call stack:
 *     ebuild.sh, line  127:  Called src_configure
 *   environment, line 5788:  Called cmake-multilib_src_configure
 *   environment, line 1470:  Called multilib-minimal_src_configure
 *   environment, line 4475:  Called multilib_foreach_abi 'multilib-minimal_abi_src_configure'
 *   environment, line 4725:  Called multibuild_foreach_variant '_multilib_multibuild_wrapper' 'multilib-minimal_abi_src_configure'
 *   environment, line 4430:  Called _multibuild_run '_multilib_multibuild_wrapper' 'multilib-minimal_abi_src_configure'
 *   environment, line 4428:  Called _multilib_multibuild_wrapper 'multilib-minimal_abi_src_configure'
 *   environment, line  727:  Called multilib-minimal_abi_src_configure
 *   environment, line 4469:  Called multilib_src_configure
 *   environment, line 4960:  Called cmake_src_configure
 *   environment, line 1731:  Called die
 * The specific snippet of code:
 *       "${CMAKE_BINARY}" "${cmakeargs[@]}" "${CMAKE_USE_DIR}" || die "cmake failed";
 *
 * If you need support, post the output of `emerge --info '=media-libs/opencv-4.5.5-r1::gentoo'`,
 * the complete build log and the output of `emerge -pqv '=media-libs/opencv-4.5.5-r1::gentoo'`.
!!! When you file a bug report, please include the following information:
GENTOO_VM=  CLASSPATH="" JAVA_HOME=""
JAVACFLAGS="" COMPILER=""
and of course, the output of emerge --info =opencv-4.5.5
 * The complete build log is located at '/var/calculate/tmp/portage/media-libs/opencv-4.5.5-r1/temp/build.log'.
 * The ebuild environment file is located at '/var/calculate/tmp/portage/media-libs/opencv-4.5.5-r1/temp/environment'.
 * Working directory: '/var/calculate/tmp/portage/media-libs/opencv-4.5.5-r1/work/opencv-4.5.5_build-abi_x86_64.amd64'
 * S: '/var/calculate/tmp/portage/media-libs/opencv-4.5.5-r1/work/opencv-4.5.5'

 * Не удалось собрать media-libs/opencv-4.5.5-r1::gentoo
 * Не удалось обновить

Честно, сейчас и не вспомню, что ранее делал с этим “open-cv” - удалял ли или не удалял.

Интересный случай:

 ~ $ equery d opencv
 * These packages depend on opencv:
media-gfx/nomacs-3.16.224-r2 (opencv ? >=media-libs/opencv-3.4)

 ~ $ equery d nomacs
 * These packages depend on nomacs:

 ~ $
*  media-gfx/nomacs
      Latest version available: 3.16.224-r2
      Latest version installed: 3.16.224-r2
      Size of files: 1888 KiB
      Homepage:      https://nomacs.org/
      Description:   Qt-based image viewer
      License:       GPL-3+

Может вообще удалить это “Qt-based” приложение?
Почему именно это приложение оказалось в системе?
Неужели ему отсутствует замена на GTK?

Удаляю - делаю cl-update. Он зараза снова ставится. Маскирую. все равно хочет.
Как его окончательно запретить для установки?

А с зависимостями как там дела обстоят?

По моему, в случае с opencv,tbb,hwloc,nomacs если хочется удалить что-то одно, то придется удалять весь бандл. У меня в xfce дела обстоят так.

Разобрался. У меня nomacs затесался в ворлд файл, удалил его оттуда и все путем.

Уважаемые!

В последних обновлениях ни у кого в осадок с такой ошибкой не выпадало ли?

Спойлер
# cl-update
Синхронизация репозиториев
 * Проверка текущего сервера обновлений ...                                                                                                                                                                                                                                   [ ok ]
 * Проверка обновлений Distros ...                                                                                                                                                                                                                                            [ ok ]
 * Проверка обновлений Calculate ...                                                                                                                                                                                                                                          [ ok ]
 * Проверка обновлений Gentoo ...                                                                                                                                                                                                                                             [ ok ]
 * Обновление индекса пакетов ...                                                                                                                                                                                                                                             [ ok ]
 * Проверка подписи индекса пакетов ...                                                                                                                                                                                                                                       [ ok ]
 * Синхронизация репозитория Linuxbuh ...                                                                                                                                                                                                                                     [ ok ]
 * Обновление кэша репозитория Distros ...                                                                                                                                                                                                                                    [ ok ]
 * Обновление кэша репозитория Calculate ...
 * У репозитория Linuxbuh есть свой кэш
 * Обновление кэша eix для репозиториев Linuxbuh, Distros, Calculate, Gentoo ...                                                                                                                                                                                              [ ok ]
 * Обновление кэша настраиваемых пакетов ...                                                                                                                                                                                                                                  [ ok ]
 * Удаление устаревших архивов и бинарных пакетов ...                                                                                                                                                                                                                         [ ok ]
 * Синхронизация завершена
Конфигурация системы
 * Сервер обновлений http://sft.if.usp.br/calculate
 * Исправление настроек ...                                                                                                                                                                                                                                                   [ ok ]
 * Обновление конфигурационных файлов ...                                                                                                                                                                                                                                     [ ok ]
Обновление пакетов
 * Вычисление зависимостей ...                                                                                                                                                                                                                                                [ ok ]

!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

app-text/ghostscript-gpl:0

  (app-text/ghostscript-gpl-9.56.1-r3:0/9.56::gentoo, binary scheduled for merge) USE="X cups dbus gtk (unicode) -static-libs" ABI_X86="(64)" L10N="de (-ja) -ko -zh-CN -zh-TW" pulled in by
    (no parents that aren't satisfied by other packages in this slot)

  (app-text/ghostscript-gpl-9.55.0-r2:0/9.55::gentoo, installed) USE="X cups dbus gtk (unicode) -static-libs" ABI_X86="(64)" L10N="de (-ja) -ko -zh-CN -zh-TW" pulled in by
    >=app-text/ghostscript-gpl-9.53.0:0/9.55= required by (app-text/libspectre-0.2.10:0/0::gentoo, installed) USE="-debug -doc" ABI_X86="(64)"
                                     ^^^^^^^^
    (and 1 more with the same problem)

NOTE: Use the '--verbose-conflicts' option to display parents omitted above

It may be possible to solve this problem by using package.mask to
prevent one of those packages from being selected. However, it is also
possible that conflicting dependencies exist such that they are
impossible to satisfy simultaneously.  If such a conflict exists in
the dependencies of two different packages, then those packages can
not be installed simultaneously.

For more information, see MASKED PACKAGES section in the emerge man
page or refer to the Gentoo Handbook.

The following USE changes are necessary to proceed:
 (see "package.use" in the portage(5) man page for more details)
# required by @selected
# required by @world (argument)
>=app-emulation/wine-vanilla-7.0-r3:7.0 -abi_x86_32
 * Выполнение Emerge завершилось с ошибкой
 * Не удалось обновить

Вот думаю, обождать чуток - может какое чудо произойдёт и всё само по себе рассосётся (у Меня в системе ничего такого накручено не было, считай чистый “CLDX” + репо “Linuxbuh”), или идти разгребать?

Прописал эту строчку в “package.use/app-emulation” и обновление прошло нормально.

Т.е. тоже напоролись?
Угу, в выводе есть эта подсказка, а не аукнется ли эта запись в будущем?

Не знаю. Можно после успешного обновления попробовать удалить и посмотреть, что пишут.
Кстати да. На днях так и сделаю.

Замаскал строчку
>=app-emulation/wine-vanilla-7.0-r3:7.0 -abi_x86_32
Запустил
emerge wine-vanilla -O1pv
then
emerge wine-vanilla -O1
and i get error about new vkd3d
Это он бинарно прилетел только для ABI_X86=“64”
добавил
app-emulation/vkd3d abi_x86_32
emerge app-emulation/vkd3d -O1
emerge wine-vanilla -pv
emerge wine-vanilla -O1
Получилось!

1 Like

Хмм, тоже сейчас сделаю так, спасибо!

у Меня так вышло:

Спойлер
# emerge wine-vanilla -O1pv

Local copy of remote index is up-to-date and will be used.

Local copy of remote index is up-to-date and will be used.

These are the packages that would be merged, in order:

[binary   R    ] app-emulation/wine-vanilla-7.0-r3:7.0::gentoo  USE="X alsa cups fontconfig gecko gphoto2 mingw mono nls openal opengl pulseaudio samba scanner sdl ssl truetype udev udisks unwind usb v4l vkd3d vulkan xcomposite xinerama -capi -crossdev-mingw -custom-cflags -debug -dos -gstreamer -kerberos -ldap -llvm-libunwind -netapi -odbc -opencl -osmesa -pcap -perl (-selinux)" ABI_X86="64 -32" 0 KiB

Total: 1 package (1 reinstall, 1 binary), Size of downloads: 0 KiB
# emerge wine-vanilla -O1

Local copy of remote index is up-to-date and will be used.

Local copy of remote index is up-to-date and will be used.
>>> Running pre-merge checks for app-emulation/wine-vanilla-7.0-r3
>>> Emerging binary (1 of 1) app-emulation/wine-vanilla-7.0-r3::gentoo
>>> Installing (1 of 1) app-emulation/wine-vanilla-7.0-r3::gentoo
>>> Jobs: 1 of 1 complete                           Load avg: 0.71, 0.22, 0.13
>>> Auto-cleaning packages...

>>> No outdated packages were found on your system.

 * GNU info directory index is up-to-date.
# cl-update
Синхронизация репозиториев
 * Проверка текущего сервера обновлений ...                                                                                                                                                                                                                                   [ ok ]
 * Проверка обновлений Distros ...                                                                                                                                                                                                                                            [ ok ]
 * Проверка обновлений Calculate ...                                                                                                                                                                                                                                          [ ok ]
 * Проверка обновлений Gentoo ...                                                                                                                                                                                                                                             [ ok ]
 * Обновление индекса пакетов ...                                                                                                                                                                                                                                             [ ok ]
 * Проверка подписи индекса пакетов ...                                                                                                                                                                                                                                       [ ok ]
 * Синхронизация репозитория Linuxbuh ...                                                                                                                                                                                                                                     [ ok ]
 * Обновление кэша репозитория Distros ...                                                                                                                                                                                                                                    [ ok ]
 * Обновление кэша репозитория Calculate ...
 * У репозитория Linuxbuh есть свой кэш
 * Обновление кэша eix для репозиториев Linuxbuh, Distros, Calculate, Gentoo ...                                                                                                                                                                                              [ ok ]
 * Обновление кэша настраиваемых пакетов ...                                                                                                                                                                                                                                  [ ok ]
 * Удаление устаревших архивов и бинарных пакетов ...                                                                                                                                                                                                                         [ ok ]
 * Синхронизация завершена
Конфигурация системы
 * Сервер обновлений http://sft.if.usp.br/calculate
 * Исправление настроек ...                                                                                                                                                                                                                                                   [ ok ]
 * Обновление конфигурационных файлов ...                                                                                                                                                                                                                                     [ ok ]
Обновление пакетов
 * Вычисление зависимостей ...
 * Система находится в актуальном состоянии
 * Получение пакетов... ...                                                                                                                                                                                                                                                   [ ok ]
Очистка системы от ненужных пакетов
 * Вычисление зависимостей ...                                                                                                                                                                                                                                                [ ok ]
Пересборка зависимых модулей
 * Обновление сохранённых библиотек ...                                                                                                                                                                                                                                       [ ok ]
 * Обновление конфигурационных файлов ...                                                                                                                                                                                                                                     [ ok ]
 * Обновление системы завершено!

Ну так вайн у вас бинарно и переустановился. Вы ту строчку не закомментили. Про vkd3d может и добавили, а про app-emulation/wine-vanilla -abi_x86_32 не убрали.
И у меня в мейк-конф на время опытов строчка
EMERGE_DEFAULT_OPTS="${EMERGE_DEFAULT_OPTS} --binpkg-changed-deps=n --quiet-build=n --binpkg-respect-use=y --jobs=1"
помогает.
Вайн у Вас должен скомпилиться, а не переустановиться бинарно. Пока ещё всё это на серверах пересоберут, синхронизируют - не меньше дня пройдёт. может больше.

Ага, тупанул!

А у Вас такое вылезало ли:

checking for -lvkd3d… not found
checking for -lvkd3d-shader… not found
configure: error: vkd3d development files not found (or too old), Direct3D 12 won’t be supported.
This is an error since --with-vkd3d was requested.

Может без этого модуля установить, интересно, что будет?

Да вылезало.
Да, можно скомпилировать вайн с USE="-vkd3d". (но в самом ебилде прописана рекомендация (+)vkd3d)
Будет вайн скомпилен без поддержки dx12 на новых Вулканах. Одной-двумя зависимостями меньше. Дополнительным временем на компиляцию вайна меньше.

Накой он Мне сдался на такой карточке :rofl:

lspci -nnk | grep -A2 VGA
00:02.0 VGA compatible controller [0300]: Intel Corporation 4 Series Chipset Integrated Graphics Controller [8086:2e32] (rev 03)
        Subsystem: Gigabyte Technology Co., Ltd 4 Series Chipset Integrated Graphics Controller [1458:d000]
        Kernel driver in use: i915