Calculate Forum

Вот опять началось!

Опять установка и удаление пакета.

~ # cl-update -v
Синхронизация репозиториев

  • Проверка текущего сервера обновлений … [ ok ]
  • Проверка обновлений Distros … [ ok ]
  • Проверка обновлений Calculate … [ ok ]
  • Проверка обновлений Gentoo … [ ok ]
  • Синхронизация завершена
    Конфигурация системы
  • Сервер обновлений https://mirror.yandex.ru/calculate
    Обновление пакетов
  • Вычисление зависимостей …
  • Список пакетов для установки
  • Виртуальный пакет Pod-Parser (N) virtual/perl-Pod-Parser-1.630.0-r8 (0 KiB)
  • 1 пакетов будет установлено, 0 KiB будет загружено

Вы хотите установить эти пакеты? (Yes/No): y

  • (1 из 1) Виртуальный пакет Pod-Parser
  • Сборка virtual/perl-Pod-Parser-1.630.0-r8 … [ ok ]
  • Установка virtual/perl-Pod-Parser-1.630.0-r8 … [ ok ]
    Очистка системы от ненужных пакетов
  • Вычисление зависимостей …
  • Список удаляемых пакетов
  • Виртуальный пакет Pod-Parser virtual/perl-Pod-Parser-1.630.0-r8

Вы хотите удалить неиспользуемые пакеты (рекомендуется)? (Yes/No):

Периодически появляются пакеты, которые сначала устанавливаются, а затем сразу удаляются. Причём, одновременно, как на сервере, так и десктопе. Как это дело прекратить?

1 Like

Стоит посмотреть, каким пакетам он нужен. Это автомагия, обычно её убирают при следующем обновлении.

Так в чём и дело, что он устанавливается и удаляется в одиночку. Если бы была зависимость, он бы не удалился.

Подтверждаю. У меня такая же история.
Нажимал “Да” и нажимал “Нет”. Всё равно при следующем обновлении он закачивается и удаляется.

$ eix --verbose --installed virtual/perl-Pod-Parser
Совпадений не найдено.

У меня этот покет не установлен. Не знаю зачем он вообще нужен.

Нет таких покетов, которые бы зависели от него

$ equery g virtual/perl-Pod-Parser
 * Searching for perl-Pod-Parser in virtual ...

 * dependency graph for virtual/perl-Pod-Parser-1.630.0-r8
 `--  virtual/perl-Pod-Parser-1.630.0-r8  amd64 
   `--  dev-perl/Pod-Parser-1.630.0-r1  (~dev-perl/Pod-Parser-1.630.0) [~amd64 keyword] 
   `--  dev-lang/perl-5.30.3  (=dev-lang/perl-5.30*) amd64 
[ virtual/perl-Pod-Parser-1.630.0-r8 stats: packages (3), max depth (1) ]

Однако он зависим от перла.

Стоит внимательно посмотреть, возможно что-то у вас в /etc/portage/

Смотреть нужно через equery.
Это автомагия, думаю, что пакет уже из неё убрали и он перестал мелькать.

А ни фига не убрали. Так и летает при апдейте на всех станциях и серверах. Сдаётся мне, что это уже похоже на вирусный пакет. По крайней мере, от администрации дистра не поступало внятных объяснений происходящего.

© 2007-2020 Calculate Ltd.
Mastodon Mastodon