Calculate Forum

Учтановка php -apache2

21.04 выяснилось, что по дефолту php идет с отключенной поддержкой appache2. Мб у этого есть причины? PS попытка собрать рукамис dev-lang/php apache к успеху не привела.

Да, этому есть причины. Приходится делать выбор добавляя флаги чтобы по умолчанию не ставились все зависимости. Если вы посмотрите, вся документация у нас заточена на использование nginx и postgresql. Такую документацию проще улучшать и поддерживать.

Ваш выбор, как автора дистрибутива, мне вполне понятен. Я отредактировал /etc/portage/package.use/custom добавив dev-lang/php apache2. Я думал, что теперь я собираю php с поддержкой apache. К сожалению, я получаю [binary N ] dev-lang/php-7.4.16:7.4::gentoo USE="acl bcmath berkdb bzip2 cgi cli ctype curl exif fileinfo filter flatfile fpm ftp gd gdbm gmp iconv intl ipv6 jit json mysql mysqli nls opcache pcntl pdo phar posix postgres readline session simplexml sockets sqlite ssl sysvipc threads tokenizer truetype unicode webp xml xmlreader xmlwriter zip zlib -apache2 -argon2 -calendar -cdb -cjk (-coverage) -debug -embed -enchant -ffi (-firebird) -imap -inifile -iodbc -kerberos -ldap -ldap-sasl -libedit (-libressl) -lmdb -mhash -mssql -oci8-instant-client -odbc -phpdbg -qdbm (-selinux) -session-mm -sharedmem -snmp -soap -sodium -spell (-systemd) -test -tidy -tokyocabinet -xmlrpc -xpm -xslt". Пожалуйста, подскажите, что мне нужно сделать для достижения нужного мне результата.

Должно быть так:

dev-lang/php apache2
app-eselect/eselect-php apache2

Спасибо за Ваш ответ.

© 2007-2020 Calculate Ltd.
Mastodon Mastodon